You are on page 1of 31

CHAPTER-1

Analog circuits:

Loop start: When a phone is on-hook, the CO sees the circuit is broken. As soon as
the phone goes off-hook to make an outgoing call, the circuit is completed and a -48V
DC current flows. The CO sees the circuit as complete and sends a dial-tone.

When a phone receives an incoming call, the CO sends a 90V AC current and that
makes the phone ring.

Loop start signalling is ideal for home users but can cause a problem known as
“glare”.

Ground start: This type of signalling is very common between a PBX and a CO
switch. Here, both ends can request and confirm the use of circuit by closing the
circuits from their end. The two wires are typically called the “tip” and the “ring”
wires.

E&M- Usually called Ear and Mouth, or Earth and Magneto or Receive and Transmit.
This type of signalling is used between PBXs.

Numbering Plans: It is a set of rules used to construct numbers. An authority


regulates number distribution in the territory. Two types- E.164 and NANP.

The ITU developed an international standard for telephone numbering called the
E.164 Addressing. It has 3 components-
- CC – Country Code
- NDC- National Designation Code
- SN- Subscriber Number

It can have a maximum of 15 digits.

Telephony signalling:

Supervisory signalling: On-hook, Off-hook and ringing. It communicates the state of


the phone.

Informational signalling: The local CO sends different frequencies to notify the caller
about, once the caller phone goes offhook- dial-tone, busy, ringback, congestion,
reorder, receiver-offhook, no such number and confirmation. It communicates the
current state of the call.

Address signalling: Once the dial-tone is available, user can dial digits. Two types of
address signalling- DTMF (tone) and Pulse. The digits dialled are also address
signalling.

Drawbacks: 1) Distance limitation


2) One line can only support one phone call at a time
Converting analog-to-digital signals:

1) Sample the signal- According to Nyquist theorem, if a signal is sampled at twice


the rate of its highest frequency per second, it can be regenerated. This sampling
process is called PAM.

2) Quantize the signal- Each sample is matched to a voltage level on the scale, and
assigned a value from 16 different values (0-7 positive and 0-7 negative).

3) Encode each sample to a binary value- Each sample voltage is converted to an 8-bit
binary value. This process is called PCM.
So, 8000 samples per second for human speech gives 8000*8 (=64000) bits per
second.

4) Compress the sample (optional)-Compress the samples before sending.

Digital circuits:

CAS (Channel Associated Signalling)- Every 8th bit of the 6th frame is used for
signalling in a T1 connection. A&B signalling bits for SuperFrame and A,B,C&D for
Extended SuperFrame.
Each T1 connection has 24 DS0, each DS0 can carry one phone call. 1 DS0 = 64kbps
After every 24 frames are transmitted, one framing bit is sent.
Each T1 frame (a big frame of 24 smaller frames) has 193 bits [(8 bits of each DS0 x
24 DS0) + 1 framing bit]

E1 CAS connection has- channel 0 (DS0/timeslot 1) for framing


channel 1-15 for voice traffic
channel 16 (timeslot 17) for signalling
channel 17-31 for voice traffic

CCS (Common Channel Signalling aka out-of-band signalling)- uses a complete


channel for signalling
T1 CCS uses 24th channel for signalling
E1 CCS uses 17th channel for signalling and 1st channel for framing.
CHAPTER-2

Cisco VOIP architecture:

Endpoints- Cisco IP Phones (3911, 7906- single-line, 794x- two-line, 796x- six-lines,
7916- 14-lines expansion module, Cisco ATA- for analog devices)

Applications- Cisco Unity Express (up to 250 users), Cisco Unity Connection (up to
3000 users) and Cisco Unity (up to 7500 users). IVR/AA, Contact Centre, Meeting
Place, ER and Presence.

ER- This application tracks the location of the IP Phone based on the physical
switchport it is connected to.

Contact Centre- Call centre application.

Meeting Place- This is a web-conferencing application enabling voice and


video conferencing as well as document sharing, white-boarding, etc.

Presence- Presence information like “On the phone”, “Out to Lunch”, etc..

Call Processing- Cisco UC500 (up to 48 users), Cisco CME (up to 250 users), Cisco
Unified Communication Manager Business Edition (500+ users), Cisco Unified
Communication Manager (30000+ users)

Infrastructure- Cisco routers (1861, 2801, 2811, 2621XM, 3725, 3745, 3845) aka
voice-gateways and Cisco voice-enabled switches.
CHAPTER-3

Powering a Cisco IP Phone:


1) Cisco Inline Power- When an un-powered Cisco IP Phone is connected to a
Switch port (capable of sending power, Cisco pre-standard), the switch sends
an FLP (Fast Link Pulse) to the phone. The phone loops the tone back and
hence, the switch becomes aware that there is a Cisco IP Phone endpoint. Via
CDP protocol, they negotiate actual power requirements and then the phone
boots up.
2) IEEE 802.3af PoE- Same as Cisco pre-standard except this is an industry
standard. The catalyst switch sends an 8V DC current and recognises Cisco IP
Phone. Rest is similar.
3) Power patch-panel- A power patch-panel between the switch and IP phones.
4) Individual power supply- wall power for individual phones.

Vision:

Configuring VLAN and VTP:

Switch B:
vlan 10
name VOICE
vlan 50
name DATA
!
vtp mode server
vtp domain voice
vtp password cisco
vtp version 2
!

Switch A:
vtp mode transparent
vtp domain voice
vtp password cisco
vtp version 2
!

Associating ports to VLAN:

Switch B:
interface range fastethernet 0/1 – 3
spanning-tree portfast
switchport mode access
switchport access vlan 50
switchport voice vlan 10
!

Configuring Trunk:

Switch B:
interface fastethernet 0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!

Switch A:
interface fastethernet 0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!

Configuring CME router:

CME-voice:
interface fastethernet 0/1
no ip address
no shutdown
!
interface fastethernet 0/1.10
ip address 172.16.1.1 255.255.255.0
encapsulation dot1q 10
ip helper-address 172.16.2.5
!
interface fastethernet 0/1.50
ip address 172.16.2.1 255.255.255.0
encapsulation dot1q 50
!
ntp server 64.209.210.24
clock timezone abc 10
!

Configuring DHCP router:

DHCP-router:
interface fastethernet 0/1
ip address 172.16.2.5 255.255.255.0
no shutdown
!
ip dhcp excluded-address 172.16.1.1 172.16.1.10
ip dhcp excluded-address 172.16.2.1 172.16.2.10
ip dhcp pool VOICE
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
dns-server 4.2.2.2
option 150 ip 172.16.1.1
!
ip dhcp pool DATA
network 172.16.2.0 255.255.255.0
dns-server 4.2.2.2
default-router 172.16.2.1
!
CHAPTER-4

Licenses required:
1) IOS license
2) Feature license
3) Phone user license (number of phones to be connected)

Cisco IP Phone boot process:


1) Connect the IP phone to the switch. The switch sends a small voltage on that
port. The Cisco phone loops it back to the switch and so the switch recognises
an un-powered Cisco phone.
2) Via CDP, the phone and switch negotiates the actual power required by the
phone. The phone boots up and negotiates its VLAN with the switch. The
phone then sends a broadcast packet to the DHCP server for an IP address.
3) Here, the broadcast packet ends up to the CME router (by default, the router
drops all the broadcast packets). But since there is an ip helper-address
command configured on the VOICE VLAN interface, it will direct that
broadcast, converting to unicast, and send to the DHCP server.
4) The DHCP server (here router) sends a unicast packet back to the CME
router, which in turn forwards back to the IP phone, with an ip address,
default-gateway, dns-server and OPTION 150 (IP address of TFTP-server).
5) The phone then sends a request to the TFTP-server for firmware and
configuration files.
6) Based on the IP address in the configuration files, the phones contacts the
CME Agent which supports VOIP functions.

Installing CME:

Install a recent IOS on the flash of the router from a working TFTP-server.

CME_Router# copy tftp://172.16.1.10/c2801-adventerprisek9-mz.124-19.bin flash:

Reboot the router and new IOS is available to work with. Then download the required
TAR files for CME from Cisco.com to the TFTP-server. Using the archive command,
extract the files to the flash.

CME_Router# archive tar /xtract tftp://172.16.1.10/cme-package.tar flash:

Now configure the router as a TFTP-server for the IP Phones. The IP Phones will
come to the TFTP-server (because of OPTION 150) and ask for firmware and
configuration files. All files for a particular phone model should be available to the
phone from the TFTP-server. To configure the router as TFTP-server,

CME_Router(config)# tftp-server flash:/phone/7970/file1.bin alias file1.bin


CME_Router(config)# tftp-server flash:/phone/7970/file2.loads alias file2.loads
CME_Router(config)# tftp-server flash:/phone/7970/file3.sbin alias file3.sbin

Configuring CME:

CME can be configured by telephony-service command. From Global configuration,


telephony-service
max-dn 20 ! maximum number of directory numbers supported
max-ephones 24 ! maximum number of phones supported
ip source-address 172.16.1.1 ! IP address to use when communicating
load 7970 file2 ! Recommended firmware file for the phone by Cisco
create cnf-files ! creates the generic configuration files
CHAPTER-5

Ephone-dn : Directory Number. Single-line or Dual-line option available.

Ephone: Digital representation of a physical phone on the CME router.

Button command: Associates an ephone to the directory number.


Different operators for button command-
1) : - normal ring
2) f – feature ring
3) m –monitor mode
4) w – watch mode
5) o – overlay operator (no call waiting)
6) c – overlay operator (with call waiting)
7) x – overlay operator (call rollover)
8) b – call waiting beep, no ring
9) s – silent ring

Scenario: A technical support group (containing 2 guys). Both phones should be able
to make outgoing calls at the same time. When a call comes in, both phones should
ring. If one phone is busy, only the other phone should ring- first phone should not
hear the call-waiting beep. If both phones are busy, the caller should hear BUSY tone.

From Global configuration mode,

ephone-dn 1 dual-line
number 1010
preference 0
huntstop channel ! Stop hunting for second channel for that DN match
no huntstop ! Don’t stop hunting for that DN match

ephone-dn 2 dual-line
number 1010
preference 1
huntstop channel
!
ephone 1
mac-address 0101.0101.0101
button 1o1,2
!
ephone 2
mac-address 0202.0202.0202
button 1o1,2

User and Network Locales:

User Locale: It specifies the language used for text displays.

Network Locale: It specifies country-specific tones and cadences.


In CME 4.0 and later, up to 5 different languages are supported by default. Multiple
locales are supported for different phones.

To configure locales system-wide,

telephony-service
user-locale 1 AU
network-locale 1 AU

To configure locales per phone,

ephone-template 1
user-locale 1
network-locale 1
!
ephone 10
ephone-template 1

Troubleshooting IP Phone registration:

1) Once the phone boots up, it sends broadcast packets to get an IP address. On
the phone screen, it displays “Configuring IP”. If the message continues to be
displayed for a long time, there is a communication problem between the
phone and the DHCP server (router). On the DHCP server, do

DHCP_Router(config)# show ip dhcp binding

It displays all the devices that have received the IP address from this DHCP
Server.

2) Once the phone gets the IP address of the TFTP server from DHCP server
option 150, it requests firmware and configuration files from the TFTP server.

CME_TFTP_Router(config)# show telephony-service tftp-bindings

It displays all the files available for different IP phones.

CME_TFTP_Router(config)#debug tftp events

It displays all the files being requested by IP phones and then provided by
CME/TFTP router.

3) Once the phone gets the firmware and configuration files, it requests feature
support from the CME router.

CME_TFTP_Router(config)#debug ephone register

It displays the communication between CME and IP Phone during registration.


The phone uses SCCP (Skinny Client Control Protocol) to communicate with
the CME router.
Supporting Auto-registration and Auto-assigning DNs to IP Phones:

By default, the CME allows auto-registration of IP Phones. It doesn’t assign them any
DNs by default. The running configuration does not show any ephones registered.
To disable auto-registration,

telephony-service
no auto-reg-ephone

To assign DNs to ephones,

telephony-service
auto assign 20 to 24 type 7960

The above command assigns ephone-dn 20 to the first 7960 phone. It also appears on
the running configuration of the CME router.

show ephone attempted-registrations command shows all the ephone (with their
MAC addresses) that tried to auto-register with the CME.

show ephone [summary] command displays all the ephones with their status
(REGISTERED, UNREGISTERED or DECEASED)
CHAPTER-6

Configuring local voice network directory:

This configuration builds a local directory (also caller-id) and takes immediate effect,
no restart/ reset needed.

ephone-dn 1
number 1001
name Amit Bhagat
ephone-dn 2
number 1002
name Heena Bhagat

To create manual entries (up to 100 entries allowed on CME) for things like FAX,
external numbers, etc.

telephony-service
directory entry 1 1599 name Floor1 Fax
^-- Directory Number

To disable local-directory service provided by CME on all phones,

telephony-service
no service local-directory

Configuring Call Forward:

Each phone has a CFwdAll switch on the screen which can be used to forward all the
calls. This is from the user-perspective.

But from the administrator’s perspective, it can be done using CLI.

ephone-dn 1 dual-line
call-forward busy 1005 ! Forward incoming call to 1005 when this line (both
channels) is busy
call-forward noan 1005 timeout 25 ! Forward incoming call to 1005 when no-
answer for 25 seconds

To enable call-forward to only a specific number of digits (like 4-digit extensions),

telephony-service
call-forward max-length 4
call-forward max-length 0 ! Disables call-forwarding & greys out CFwdAll button

To enable call-forward to only a specific pattern of numbers,

telephony-service
call-forward pattern 1… ! This enables all 4-digit extensions H.450.3 compatible
H.450.3 is an industry standard that solves hair-pinning problem. When an incoming
call is forwarded to another extension (say located geographically distant), the
forwarding phone takes responsibility of the call and hence the call is forwarded
through that phone. This is called hair-pinning and causes serious issues with voice
quality.
In case of H.450.3 support, the forwarding CME redirects the call directly to the
router supporting that forwarded extension and so the call doesn’t go through the
forwarding phone.

Configuring Call Transfer:

Two types of call-transfer modes-


1) Consult
2) Blind

To configure system-wide call transfer functionality,

telephony-service
transfer-system full-consult
transfer-pattern 1… ! Allows transfer to only 4-digit extension starting with 1
transfer-pattern 9…….. ! Allows local-call, 9 to indicate PSTN call

The H.450.2 is a standard protocol for exchanging call-transfer information across


the network.

The H.450.3 is a standard protocol for exchanging call-forward information across


the network.

The H.450.12 is a standard protocol which provides a means to advertise and


dynamically discover the H.450.2 and H.450.3 call capabilities of the voice gateway
endpoints on a call-by-call basis. If the endpoints do not support H.450.2 and H.450.3
capabilities, they use standard hair-pinning or H.450 tandem gateway capabilities for
call-transferring and call-forwarding.

Configuring Call Park:

To configure call park,

ephone-dn 10
number 3001
park-slot
ephone-dn 11
number 3002
park-slot timeout 20 limit 3 recall
The last command signifies that if a call is parked at 3002 for more than 20 seconds,
recall back to the phone that parked. That particular call can be parked only 3 times
(or 60 seconds) before it is disconnected.

To park the active call, press Park button on the phone.


3 ways to pickup parked calls-
1) using PickUp button on screen and dialling DN for call-park.
2) using the line, dial the DN of call-park.
3) press PickUp button and press * to recall the parked call.

Use show ephone-dn park command to display configured call park-slots and their
status.

Configuring Call Pickup:

Scenario: There are 2 groups- Sales (2 people) and Accounting (1 person). Sales
people can answer their own groups call from their own phone. They should also be
able to answer Accounting group phone if need be.

ephone-dn 12
number 1101
name Sales_1
pickup-group 1200
ephone-dn 13
number 1102
name Sales_2
pickup-group 1200
ephone-dn 14
number 1103
name Accounting
pickup-group 1300

To answer Sales_2 from Sales_1 phone, the person can


1) press PickUp button on the phone and dial Sales_2 DN. This is also called
Directed Pickup.
2) Press GpickUp button on the phone and answer directly. [Sometimes * is
needed]. Also called Local-group pickup.

To answer Accounting group phone from Sales_1 or 2’s phone, Sales people can
1) Press GpickUp button on the phone and dial Accounting person’s DN
number. Also called Other-group pickup.

Configuring Intercom:

To configure intercom,

ephone-dn 30
number A100
intercom A101 label “Manager”
ephone-dn 31
number A101
intercom A100 label “Assistant”
ephone 10
button 2:30 ! Assigns DN to the button
ephone 11
button 2:31

Pressing the button, directly connects the phone at other end on the speaker but the
call is muted by default.

Configuring Paging:

Paging –
- is one-way, speaker-based communication
- one IP phone can be a member of only one group
- maximum 10 IP phones allowed in a unicast group, no limit for
multicast group
- groups can be a member of a parent group

To configure paging,

ephone-dn 40
number 5500
paging
ephone-dn 41
number 5511
paging
ephone-dn 42
number 5512
paging
paging group 40,41 ! Groups 5500 and 5511 are members of parent group 5512

ephone 1
paging-dn 40
ephone 2
paging-dn 41

Configuring After-hours call blocking:

Scenario: Configure after-hours calling blocking from 5PM to 8AM for all calls.
Exempt Manager from any call blocking; exempt some phones using PIN (timeout 2
hours when idle, login clear after 11PM) and block 1900 numbers for all, 24x7.

telephony-service
after-hours day mon 17:00 08:00
after-hours day tue 17:00 08:00
after-hours block pattern 1 91900…….. 7-24
after-hours block pattern 2 .T
login timeout 120 clear 23:00

ephone 1
after-hour exempt
ephone 2
pin 1234
NOTE: Users can login second time after 11PM.

Configuring CDRs:

CDR- Call Detail Records. It can be configured to store the logs in router RAM or to
store the records on the syslog server.

To configure the CME router to store router logs, from global configuration mode

logging buffered 512000 ! Assigned 512 Kbytes to store the logs on RAM
dial-control-mib retain-timer 10080 ! Logs retained for 7 days
dial-control-mib max-size 700 ! Maximum 700 records stored

Use show logging command to view the logs.

To configure the CME router to store logs on syslog server,

gw-accounting syslog ! configuring to store logs on syslog server


logging 172.16.1.100 ! IP address of syslog server

Configuring Music on Hold:

telephony-service
moh music-on-hold.au

Only supports .wav and .au files.

Enabling the CME GUI:

The CME GUI TAR file is needed from Cisco.com and extracted into flash.

- Enable the CME router to serve as a web-server (and a secure web-server).

ip http server
ip http secure-server

- Define the path for CME GUI files and also (local database user) authentication.

ip http path flash:/gui


ip http authentication local

- Create CME web administration account.

telephony-service
web admin system name NinjaAdmin secret 0 cisco
dn-webedit ! Allows DN editing from CME GUI.
time-webedit ! Allows Time editing from CME GUI
CHAPTER-7

Different Codecs:

1) G.711 – 64 kbps
2) G.729 – 8 kbps
3) G.729A – 8 kbps
4) G.728 – 16 kbps
5) G.723 – 6.3 kbps
6) iLBC – 15.2 kbps

Calculating Codec Bandwidth Requirements:

Step 1: Number of Bytes per packet for G.711 Codec with 20 ms sampling size.
NOTE: A single voice packet by default, contains a payload of 20 msec of voice.

Bytes per packet = (sampling size * codec bandwidth)/ 8


= (0.02 * 64000)/ 8
= 160
= voice payload

Step 2: Layer 2 Header size

Ethernet = 18 bytes (debateable)


Frame-relay = 4-6 bytes
PPP = 6 bytes
Here, we assume the data-link layer is Ethernet medium.

Step 3: Layer 3 and Layer 4 Header size

IP = 20 bytes
UDP = 8 bytes
RTP = 12 bytes

Step 4: Additional Header size

IPSec VPN = 50 – 57 bytes


GRE/L2TP = 24 bytes
MPLS = 4 bytes

We assume there are no additional headers included.

Step 5: Total bandwidth.

Total bytes per packet = voice payload + Ethernet Header + IP + UDP +RTP
= 160 + 20 + 20 + 8 + 12
= 220 bytes per packet

Total bandwidth = Packet size (= total bytes per packet) * packets per second
= 220 * (1000 ms/ 20 ms)
= 220 * 50
= 11000 bytes per second
= 11000 * 8 bits per second
= 88000 bits per second
= 88 kbps

Step 6: Bandwidth Saving Measures.

VAD – Voice Activity Detection- “sound of silence”. It saves around 35% of


bandwidth.

Compresses RTP – 40 bytes (IP + UDP + RTP) header information can be


compressed to 3-5 bytes.

Digital Signal Processors DSP:

A DSP is a small chip-like processor. DSPs usually do sampling, encoding and


compression of audio. The complexity of a codec is based on the number of DSPs
consumed.

Medium Complexity High Complexity


G.711 G.729
G.729A G.729B
G.729AB G.723
G.726 G.728
iLBC

In addition to digitizing voice, DSP resources are also used for conferencing,
transcoding, media termination point (MTP) and echo cancellations.

RTP and RTCP:

RTP – Real-time Transport Protocol


It runs on top of UDP. It adds timestamp and sequence number to header information.

RTP Payload Sequence Number Timestamp

RTP Payload is audio or video.


Once two devices attempt to establish a session, RTP picks a random port from the
range 16384 – 32767. It only uses an even-numbered port. It is only for one-way
stream. If the communication is two-way, the other device also picks an RTP port.

RTCP – Real-time Transport Control Protocol


Like RTP, RTCP also engages when two devices attempt to establish a session. It
picks up the odd-numbered port following the RTP port from the same range.

RTCP carries packet count, packet loss, packet delay and jitter statistics.
Trunking CME to other VOIP systems:

VOIP Signalling protocols-


1) H.323- It is an industry-standard, peer-to-peer protocol. Hence, all the VOIP-
gateways need to be configured individually. An H.323 Gatekeeper can be
setup which can act as a centralized reference point in the H.323 network. This
gatekeeper provides call admission control (CAC aka access control),
directory service (phone number lookup) and bandwidth management (check
enough bandwidth for the call).

Advantages:
- Industry-standard
- Easy of configuration
- Mature and stable
Disadvantages:
- Binary messages makes it very difficult to understand and troubleshoot
- Peer-to-peer architecture can make complex configuration

2) SIP- SIP is designed by IETF as an alternative to H.323. It starts, manages and


ends the session. It uses IP, UDP and RTP to transport audio or video.

Advantages:
- Simple, easy-to-understand messages
- Wide support across multiple vendors
Disadvantages:
- It is still an evolving standard
- It consumes more router processor and memory

3) MGCP- Media Gateway Control Protocol. It is truly a server-client based


protocol. Essentially, all the gateways act as dumb-terminals and contact the
MGCP-based server (aka Call Agents) for intelligence. The commands are
sent from Call Agents to MGCP-controlled gateways on UDP port 2427.
MGCP configuration is mainly centralized on the Call Agent, with very
limited configuration on the gateways.

Advantages:
- Centralized configuration on Call Agents
- Minimal local configuration on gateways
Disadvantages:
- Not widely supported
- Call Agent becomes single point of failure

4) SCCP- Skinny Client Control Protocol. It is a Cisco-proprietary protocol.


Like MGCP, it is client-server based. All Cisco IP Phones and Cisco ATA
only support SCCP protocol. It uses TCP connection between the phone and
call agents (ex. CME) to setup, manage and teardown voice and video calls.

Disadvantages:
- Cisco-proprietary
CHAPTER-8

Configuring Analog interfaces:

FXS- Foreign Exchange Station. This interface/port is used to connect analog devices
like telephone, fax-machine, etc to the router.

voice-port 1/0/0 ! FXS port position on the router


signal loopstart ! Type of signalling- loopstart (by default) or groundstart
cptone AU ! Tone according to the country
station-id name Amit ! Caller-id Name
station-id number 3301 ! Caller-id Number

FXO- Foreign Exchange Office. This interface/port is used to connect to the CO or


the PBX from the router.

voice-port 1/0/1 ! FXO port position on the router


signal loopstart ! Signalling type (Specified by the CO or PBX-vendor)
dial-type dtmf ! DTMF or Pulse
ring number 2 ! Number of rings after router answers the incoming call
on FXO port (by default it is 1, meaning immediately)

E & M (Ear and Mouth)- This interface is used to connect to specific PBXs. It
mainly uses ground-start signalling.

Configuring Digital Interfaces:

T1/E1 interfaces (VWIC-MFT-2T1 or E1) can be used as digital interfaces to connect


to PSTN or PBX.

 Configuring T1/E1 as CAS Connection-

controller t1 1/0 ! Position of T1 controller on the router


framing esf ! Specified by the CO
linecode b8zs ! Specified by the CO
ds0-group 1 timeslots 1-12 type fxo-loop-start ! Here, 12 channels (DSOs) used
to connect the CO

 Configuring T1/E1 as CCS (ISDN PRI) Connection-

isdn switch-type primary-5ess ! Important. Specified by service-provider


!
controller t1 1/0
framing esf
linecode b8zs
pri-group timeslots 1-24 ! Here, 24 channels with last channel (channel 23)
used for signalling.
Dial peers:

2 types- 1) POTS dial-peer – It is used for any analog connections including T1/E1. It
strips of any explicitly specified digits in a dial-peer.
2) VOIP dial-peer – It is used for any digital connections with an IP address

Vision:

Legacy-voice router:

Configuring voice-ports and PSTN trunk-

voice-port 1/0/0
signal loopstart
cptone AU
station-id name Amit
station-id number 3301
!
voice-port 1/0/1
signal loopstart
cptone AU
station-id name Heena
station-id number 3302
!
isdn switch-type primary-5ess
!
controller e1 1/0
pri-group timeslots 1-30
!

Configuring POTS dial-peers-

dial-peer voice 3301 pots


destination-pattern 3301
port 1/0/0
!
dial-peer voice 3302 pots
destination-pattern 3302
port 1/0/1
!
dial-peer voice 9 pots
description Local dialling to PSTN
destination-pattern 903[89]…….
forward-digits 10
port 1/0:16
!

Configuring VOIP dial-peer-

dial-peer voice 10 voip


description Dialling 10XX extensions
destination-pattern 10..
session target ipv4:10.1.1.1
!

CME-router:

Configuring VOIP dial-peers-

dial-peer voice 330 voip


description Dialling 33XX extensions
destination-pattern 33..
session target ipv4:10.1.1.2

Various show and debug commands:


1) show voice port summary- This command displays all the voice ports on the
routers. All the ephones are displayed as EFXS.
2) show dial-peer voice summary- This command shows all the dial-peers
configured on the router and their status (up or down).
3) debug voip dialpeer- This command displays how the router processes the
dialled digits from the phone and what dial-peer matches the dialled digits.

NOTE: By default, all the VOIP dial-peers use G.729 codec. If the codec don’t
match on both ends, the call will fail and the router will return a re-order tone.

Wildcards:
1) . – Any single dialled digit
2) + - Matches one or more instances of preceding digits.
3) [] – Matches a range of digits
4) T – Matches any number of digits (range 0-32)
5) , - Inserts one second delay between dialled digits

Digit Manipulation:

By default, POTS dial-peers automatically strips off any explicitly defined digits by
the destination-pattern command.

 Prefix- Adds the prefix to the number. (POTS dial-peer)


Ex. dial-peer voice 100 pots
destination-pattern 6…
prefix 0398246

 Forward digit- Allows all the rightmost justified digits to pass. (POTS dial-peer)
Ex. dial-peer voice 100 pots
destination-pattern 9[469]11
forward-digits 3

 Digit strip- Using a “no” in front of the digit-strip command negates the auto-
stripping rule. (POTS dial-peer)
Ex. dial-peer voice 100 pots
destination-pattern 911
no digit-strip

 num-exp- matches a particular pattern and changes to the desired one. (Global
configuration command)
Ex. num-exp 0 5000
num-exp 1 5001

 voice translation-profile- This can be used for VOIP and POTS dial-peers.
(Global configuration command/s)
Ex. voice translation-rule 1
rule 1 /6/ /5/
exit
voice translation-profile PROF
translate called 1
exit
dial-peer voice 100 pots
translation-profile outgoing PROF
In this example, the router checks for every digit. Here, it checks for DNIS (Dialled
Number Identification Service aka dialled-number) and checks for all the digits of the
dialled number (incoming call) (digit 6 in this case), and as soon as it has a match, it
translates (5 here). Hence, 6544 translates to 5544.

To check the translation, use test voice translation-rule <rule-number>


command.To verify translation rules and profiles, use
show voice translation-profile <profile-name> and
show voice translation-rule <rule-number> commands.

Digit manipulation order of operation for POTS dial-peer:


1) num-exp
2) auto-stripping rule
3) voice translation-profile
4) prefix
5) forward digits

Important: Order of preference for incoming dial-peer selection:

1) Match the dialled number (DNIS) using incoming called-number dial-peer


configuration command.
2) Match the caller-id information (ANI) using answer-address dial-peer
configuration command.
3) Match the caller-id information (ANI) using destination-pattern dial-peer
configuration command.
4) Match the POTS dial-peer for port dial-peer configuration command.
5) Use dial-peer 0.
CHAPTER-9

Cisco Unity Express CUE:

It is a small hardware appliance that is installed in the cisco router. It is Linux-based.


It comes in following flavours-
1) AIM- CUE – fits on the motherboard, up to 50 mailboxes, up to 6 sessions, 14
hours of recording
2) NM- CUE – takes up a slot on the router, up to 100 mailboxes, up to 8
sessions, 100 hours of recording
3) NM- CUE- EC- takes up a slot on the router, up to 250 mailboxes, up to 16
sessions, 300 hours of recording
4) NME- CUE- takes up a slot on the router, up to 250 mailboxes, up to 24
sessions, 300 hours of recording

Features and functions of CUE voicemail:


1) User (subscriber) and group accounts
2) Subscriber mailbox and Group Delivery Mailbox (GDM)
3) Mailbox subscriber features- mailbox login, password and PIN, tutorial,
greetings, MWI, mailbox storage, message notification
4) Mailbox caller features- record message option, operator assistance and
mailbox login
5) VoiceView Express- voicemail checking on the phone using XML service.
6) Integrated messaging- integrating email and voicemail accounts into a single
IMAP-based email client (both different accounts on a single email client)
7) Voice Profile for Internet Mail (VPIM)- allows one voicemail system to
exchange voicemails with another voicemail system

Functions and features of CUE Auto-Attendant:


1) CUE Auto Attendant- allows the business to answer and direct incoming calls
to appropriate persons without human intervention
2) CUE Custom Scripting
CHAPTER-10

Installing CUE Module:

The AIM-CUE module fits on the motherboard of the router while the NM-CUE
module fits on one of the slots on the router.

Once the CUE module is installed and powered up, the show ip interface brief
command shows the service interface as service-engine on the CME.

The AIM-CUE always shows as service-engine 0/1 (slot 0, unit 1).

Step 1: Assign an IP address to service-engine using ip unnumbered command.

interface service-engine 0/1


ip unnumbered loopback 0

Step 2: Assign IP address and default-gateway to service-module from service-engine.

interface service-engine 0/1


service-module ip address 10.1.1.10 255.255.255.0
service-module ip default-gateway 10.1.1.1 ! IP address of service-engine

Step 3: Create a static route to point to service-engine from service-module (from


global configuration mode). Traffic for CUE to be sent via service-engine.

ip route 10.1.1.10 255.255.255.255 service-engine 0/1

To connect the CLI of CUE service-module from CME, (from global configuration
mode)

CME# service-module service-engine 0/1 session

Installing and upgrading the CUE software:

Download the necessary software and license files on to the FTP server, then you can
either copy the files to the hardware platform and run the files locally or run the
software from the FTP server directly.

The CUE can be only upgraded (using software install upgrade command) to version
3.1 only if the current version is 2.3.4, otherwise it will require a clean install.

To perform a clean install,

CME# service-module service-engine 0/1 session


CUE> en
Password:
CUE# software install clean url ftp://10.1.1.11/cue_file_for_cme.version.pkg

You can check the status using software install status command.
You can upgrade from version 2.3.4 using the command

software install upgrade url ftp://10.1.1.11/cue_file_for_cme_3.1.1.pkg

The CUE license dictates the following factors-


1) Support for CCM or CME
2) Number of GDM
3) Number of subscriber mailboxes
4) Number of IVR ports supported

To install the license file, use the command

software install clean url ftp://10.1.1.11/cue_license_file.version.pkg

After the installation of license file, the show software license command displays the
number of subscriber mailboxes supported, the number of GDM supported, the
platform (CCM or CME) supported, total mailbox capacity and the number of
languages supported.

CUE Post-installation configuration:

It includes-
1) Hostname
2) Domain name
3) Primary and secondary DNS servers
4) Primary and secondary NTP servers
5) Time zone
6) Administrative credentials (username and password for CUE system
administration to login via web-based GUI)

Configuring CME to support CUE:


Step 1: Enable HTTP server support including path and authentication.

ip http server
ip http path flash:
ip http authentication local

Step 2: Configure SIP dial-peers for CUE (voicemail, auto-attendant and AVT)

dial-peer voice 7000 voip


description Voicemail
destination-pattern 7000
session target ipv4:10.1.1.10
session protocol sipv2
dtmf-relay sip-notify
no vad
codec g711ulaw
!
dial-peer voice 7001 voip
description AA
destination-pattern 7001
session target ipv4:10.1.1.10
session protocol sipv2
dtmf-relay sip-notify
no vad
codec g711ulaw
!
dial-peer voice 7002 voip
description AVT
destination-pattern 7002
session target ipv4:10.1.1.10
session protocol sipv2
dtmf-relay sip-notify
no vad
codec g711ulaw

All the features point to CUE service-module (10.1.1.10). CUE only supports SIPv2
protocol and G.711 codec at this stage. VAD should be turned OFF.

If CUE is integrated with CME, additional telephony-service configurations are


needed.

telephony-service
voicemail 7000
web admin system username CMEadmin secret 0 cisco

The web-admin configuration is for CME web-administration via GUI. The CUE will
use these credentials to access CME GUI.

MWI (Message Waiting Indicator) configuration:

MWI is used by CUE to notify CME that a new message has arrived in subscriber’s
mailbox. The CUE does this by sending a static string of unique digits and appending
the extension number of the subscriber. The CME then discards the static string of
unique digits and uses the extension number to indicate message on the IP phone.

To configure MWI, create 2 DN (one for ON and other for OFF),

ephone-dn 19
number A41….
mwi on
!
ephone-dn 20
number A40….
mwi off
!
CUE GUI can be accessed from a web-browser using the URL
http://<cue_service-module_ip_address>
CUE Troubleshooting:

1) Using the show version command, check the compatibility between CME and
CUE softwares. Also check the presence of service-engine interface.
2) Using the show interface service-engine 0/1 command, check the status of
layer-1 and layer-2, and IP address.
3) Using the service-module service-engine 0/1 status command, check the
status of the module (steady-state) and version.
4) Ping the service-module from CME.
5) Check call routing by dial-peers using show dial-peer voice 7000 and debug
ccsip calls commands.
6) Check MWI operation using debug ephone mwi command.
7) From CUE, trace and log commands can be used.

To restore CUE to factory defaults, use

CME# service-module service-engine 0/1 session


CUE> offline
CUE(offline)> restore factory default
CHAPTER-11

CCA- Cisco Configuration Assistant

It has 4 main menus-

1) Setup menu- It has a Device Setup Wizard which allows configuration of


hostname, time and date, IP address and other device parameters like
language, region, etc.

2) Configure menu- It has various options to configure Ports, Security, Device


Properties, Routing and Telephony.

- Device Properties-
IP Address, Hostname, System Time, HTTP Port, Users and
Passwords, Device Access (Telnet, SSH) and SNMP

- Ports -> Port Settings -> 1. Configuration Settings Tab- allows you to
enable and disable ports, set duplex and speed, and enable or disable PoE
negotiation.
2. Runtime Status Tab- shows what the port is
actually doing.

- Security- allows to configure NAT, VPN Server, Security Audit, and


Firewall and DMZ.

- Routing- no dynamic routing protocols are supported, here you can


configure static routes. You can also configure DHCP Server to allocate IP
addresses to hosts on the LAN.

- Smartports- allows for rapid configuration of common interface settings


appropriate to different device types like routers and switches.

3) Monitor menu-

Monitor -> Views -> 1. Front Panel View


2. Topology – This view allows to annotate devices with
IP addresses, port IDs, a friendly name or MAC address.

- Topology View-

• Device Tab- It allows to change the hardware configurations. It also


lists the number of licenses the unit supports.

• System Tab- It allows to configure region, voicemail, phone language


settings, clock format and speed dials.

• Network Tab- Here you configure Voice VLAN and DHCP scope.
• AA & Voicemail- Here you configure AA and Voicemail extension
numbers and their PSTN access numbers.

• SIP Trunk- SIP Trunks are used to connect to other telephony devices
or SP.

• Voice Features- Here you can enable all the voice features.

• Dial Plan- Here you can configure number of extension digits and set
numbering plan.

• Users- Here you associate users with phone and add new phones.

- Reports -> 1. Inventory


2. VPN Status

- Health -> it generates a graphical representation of critical & general health


statistics like bandwidth utilization, packet error rate, temperature, CPU utilization,
etc

- Event Notification -> view event logs for all devices in the network.
- Critical errors are marked as Level 0 and 1.
- Errors are marked as level 2 or 3
- Warnings are marked as level 4
- Informational events are marked as level 5, 6 or 7

- System Messages -> allows to view system messages from all devices in the
network.

4) Maintenance menu- allows software upgrades (drag and drop), manage files
stored on flash memory, restart/ reset devices.

- Configuration Archive -> Backup and Restore


During backup, by default, the MAC address, IP Address and Hostname of the
device is added.

You might also like