You are on page 1of 5

CCIEv5 BGPv6 (IPv6 Over BGP) By CCSI: Yasser Auda

IPv6 BGP

Multiprotocol BGP is the supported exterior gateway protocol (EGP) for IPv6. Supports many of the
same features and functionality as IPv4 BGP. IPv6 enhancements to multiprotocol BGP include support
for an IPv6 address family and network layer reachability information (NLRI) and next hop (the next
router in the path to the destination) attributes that use IPv6 addresses
The IPv6 multiprotocol BGP can be configured between two IPv6 routers (peers) using link-local
addresses. For this function to work, the interface for the neighbor must be identified by using the
update-source command, and a route map must be configured to set an IPv6 global next hop.

router bgp 100


no bgp default ipv4-unicast <Without configuring ""no bgp default ipv4-unicast"" only IPv4 will be
advertised

neighbor 2010:AB8:0:2:C601:10FF:FE58:0 remote-as 2

address-family ipv6
neighbor 2010:AB8:0:2:C601:10FF:FE58:0 activate
network 2010:AB8:2::/48
network 2010:AB8:3::/48

show ipv6 route bgp

Configuring an IPv6 Multiprotocol BGP Peer Using a Link-Local Address


Configuring IPv6 multiprotocol BGP between two IPv6 routers (peers) using link-local addresses requires
that the interface for the neighbor be identified by using the update-source command and that a route
map be configured to set an IPv6 global next hop.

1
CCIEv5 BGPv6 (IPv6 Over BGP) By CCSI: Yasser Auda

IPv6 BGP Lab

R1
ipv6 unicast-routing
int f0/0
ipv6 add 2001:cc1e:13:13::1/64
int f0/1
ipv6 add 2001:cc1e:12:12::1/64
int loop0
ipv6 add 2001:1:1:1::1/128

router bgp 100


no bgp default ipv4-unicast

address-family ipv6
nei 2001:cc1e:13:13::3 remote-as 200
nei 2001:cc1e:12:12::2 remote-as 200
nei 2001:cc1e:13:13::3 activate
nei 2001:cc1e:12:12::2 activate
network 2001:1:1:1::1/128

R2
ipv6 unicast-routing
int f0/0
ipv6 add 2001:cc1e:12:12::2/64
int f0/1
ipv6 add 2001:cc1e:23:23::2/64

int loop0
ipv6 add 2001:2:2:2::2/128

router bgp 200


no bgp default ipv4-unicast

2
CCIEv5 BGPv6 (IPv6 Over BGP) By CCSI: Yasser Auda

address-family ipv6
nei 2001:cc1e:23:23::3 remote-as 200
nei 2001:cc1e:12:12::1 remote-as 100
nei 2001:cc1e:23:23::3 activate
nei 2001:cc1e:12:12::1 activate
network 2001:2:2:2::2/128

R3
ipv6 unicast-routing
int f0/0
ipv6 add 2001:cc1e:13:13::3/64
int f0/1
ipv6 add 2001:cc1e:23:23::3/64

int loop0
ipv6 add 2001:3:3:3::3/128

router bgp 200


no bgp default ipv4-unicast

address-family ipv6
nei 2001:cc1e:23:23::2 remote-as 200
nei 2001:cc1e:13:13::1 remote-as 100
nei 2001:cc1e:23:23::2 activate
nei 2001:cc1e:13:13::1 activate
network 2001:3:3:3::3/128

R1#show bgp ipv6 unicast


% BGP cannot run because the router-id is not configured
BGP table version is 1, local router ID is 0.0.0.0
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
* 2001:1:1:1::1/128
:: 0 32768 i
*Mar 1 00:25:05.455: %BGP-4-NORTRID: BGP could not pick a router-id. Please configure manually.
So we add router-id
R1
router bgp 100
bgp router-id 1.1.1.1
R2
router bgp 200
bgp router-id 2.2.2.2
R3
router bgp 200
bgp router-id 3.3.3.3
show bgp ipv6 unicast sum

3
CCIEv5 BGPv6 (IPv6 Over BGP) By CCSI: Yasser Auda

Creating BGP neighbors using Link-Local


Yes , also we can create BGP neighbors using link-local address but notice we will need tie to our link
local address the interface belong to it.
R2
int f0/1
ipv6 add fe80::2 link-local

router bgp 200


neighbor fe80::3%FastEthernet0/1 remote-as 200
!
address-family ipv6
neighbor fe80::3%FastEthernet0/1 act

R3
int f0/1
ipv6 add fe80::3 link-local

router bgp 200


neighbor fe80::2%FastEthernet0/1 remote-as 200
!
address-family ipv6
neighbor fe80::2%FastEthernet0/1 act

R2#sh bgp ipv6 un


BGP table version is 8, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path


* i 2001:1:1:1::1/128
2001:CC1E:13:13::1
0 100 0 100 i
*> 2001:CC1E:12:12::1
0 0 100 i
*> 2001:2:2:2::2/128
:: 0 32768 i
r>i 2001:3:3:3::3/128
FE80::3 0 100 0 i

4
CCIEv5 BGPv6 (IPv6 Over BGP) By CCSI: Yasser Auda

IPv4 to carry ipv6 session


we can use ipv4 to carry ipv6 session using our IPv4 session.
but remember advertise ipv6 NLRI via IPv4 BGP session results in next-hop issue , this issue can be fixed
using route-map or “no bgp deafult ipv6-nexthop” command

R1
int f0/0
ip add 10.13.13.1 255.255.255.0

router bgp 100


neighbor 10.13.13.3 remote-as 200

address-family ipv6
neighbor 10.13.13.3 activate

R3
int f0/0
ip add 10.13.13.3 255.255.255.0

router bgp 200


neighbor 10.13.13.1 remote-as 100

address-family ipv6
neighbor 10.13.13.1 activate

in sh bgp ipv6 uni you found next hop for R3 loop0 in R1 is link local address , we can fix this using :

R2/R3
router bgp 200
no bgp default ipv6-nexthop

Resources :
http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_bgp/configuration/15-mt/irg-15-mt-
book/ip6-mbgp-ext.html

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_bgp/configuration/15-mt/irg-15-mt-
book/ip6-mbgp-lla-peer.html

Good Luck
CCSI: Yasser Auda
https://www.facebook.com/YasserRamzyAuda
https://learningnetwork.cisco.com/people/yasser.r.a?view=documents
https://www.youtube.com/user/yasserramzyauda

You might also like