You are on page 1of 24

8/26/2019 Print content

Interconnecting Cisco Networking Devices (ICND1 v3.0)

Compare Static and Dynamic Routing

Introduction
Exercise 1 - Static Routing
Exercise 2 - Dynamic Routing
Exercise 3 - Compare Static and Dynamic Routing
Summary

Introduction
The Compare Static and Dynamic Routing module provides you with the
instructions and Cisco hardware to develop your hands on skills in maintaining and
troubleshooting Cisco devices. This module includes the following activities:

Review the routing table of a Cisco router


Implement static routing and observe how it functions
Implement dynamic routing and examine its operation
Compare the functionality of static and dynamic routing and especially how each
reacts to changes in the network

Lab Diagram

During your session you will have access to the following lab configuration. Depending
on the exercises you may or may not use all of the devices, but they are shown here in the
layout to get an overall understanding of the topology of the lab.

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 1/24
8/26/2019 Print content

Connecting to your Lab

In this module you will be working on the following equipment to carry out the steps
defined in each exercise.

NYEDGE1
NYEDGE2
NYWAN1

To start, simply choose a device and click Power on. In some cases, the devices may
power on automatically.

For further information and technical support, please see our Help and Support
page.

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 2/24
8/26/2019 Print content

Copyright Notice
This document and its content is copyright of Practice-IT - © Practice-IT 2016. All rights reserved. Any
redistribution or reproduction of part or all of the contents in any form is prohibited other than the
following:
1. You may print or download to a local hard disk extracts for your personal and non-commercial use
only.
2. You may copy the content to individual third parties for their personal use, but only if you
acknowledge the website as the source of the material. You may not, except with our express written
permission, distribute or commercially exploit the content. Nor may you transmit it or store it in any
other website or other form of electronic retrieval system.

Exercise 1 - Static Routing


In this exercise you will learn how to view and understand a routing table and how to
configure static routes and verify their configuration.

Task 1 - Viewing the routing table

A routing table on a router is a list of networks that are known to that device. The routing
table includes information such as how to reach each network and how far away each
network is. If a network is unknown, then a special address called a default gateway or
a default route is used. Traffic with a destination that is unknown to the device will be
sent to the default gateway.

Note: When speaking about end devices such as a PC or a server, this special
address is known as a default gateway. In the context of a network device such
as a router, this special address is known as a default route or gateway of last
resort.

In this section, you will view the routing table that exists on the NYEDGE1 router and
understand the information it displays.

Step 1
https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 3/24
8/26/2019 Print content

Connect to the NYEDGE1 router and issue the following command:

NYEDGE1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M -
mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF
inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1,
L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U -
per-user static route
o - ODR, P - periodic downloaded static route, H -
NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
192.168.16.0/24 is variably subnetted, 2 subnets, 2
masks
C 192.168.16.0/24 is directly connected,
GigabitEthernet0/0
L 192.168.16.1/32 is directly connected,
GigabitEthernet0/0
NYEDGE1#

This command displays the routing table of the device. The output is separated into
several sections:

Codes - This is a legend for the codes found at the beginning of each line of the
routing table. The codes are used to indicate how a specific route has been learned.
Gateway of last resort is not set - This indicates that the default route has not
been configured. If it had been, it would appear here.
The routing table itself - The routing table consists of entries of networks. These
are further explained below:

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 4/24
8/26/2019 Print content

Step 2
Examine the following line of the routing table:

C 192.168.16.0/24 is directly connected,


GigabitEthernet0/0

From the above entry, you can determine the following:

The network 192.168.16.0/24 is a known network since it exists in the routing table.
This network is directly connected to an interface of the router. This can be seen by the C
code at the beginning of the line but also because it indicates the interface to which the
network is connected, specifically GigabitEthernet 0/0.

Note: A directly connected network is one whose network address contains the IP
address of an interface of the router. In the case of NYEDGE1, the interface
GigabitEthernet 0/0 has an IP address of 192.168.16.1 and a subnet mask of
255.255.255.0. Therefore, the network to which the specific interface is connected
to is 192.168.0.0/24. The router actually inserts this route in the routing table
directly from the information contained in the configuration of the interfaces.

Starting from IOS version 15 and onward, an additional routing entry is added for each
directly connected route. This entry has a code of L and is known as a local route. This is
nothing more than the IP address of the interface which is associated with the directly
connected route with a subnet /32 subnet mask indicating a host. An example of this can
be seen in the following route entry:

L 192.168.16.1/32 is directly connected,


GigabitEthernet0/0

You can see from the above that a router that has no routing configuration implemented
has only its directly connected networks as entries in the routing table, that is, those with
codes C and L.
https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 5/24
8/26/2019 Print content

Step 3
In this step you will configure the GigabitEthernet 0/1 interface of the NYEDGE1
router with an IP address of 172.14.0.1 and a subnet mask of 255.255.255.0 and you
will activate it. You will then examine what affect this has on the routing table. To do this,
issue the following commands:

NYEDGE1#configure terminal Enter configuration commands,


one per line. End with CNTL/Z.
NYEDGE1(config)#interface gigabitethernet 0/1
NYEDGE1(config-if)#ip address 172.14.0.1 255.255.255.0
NYEDGE1(config-if)#no shutdown
NYEDGE1(config-if)#exit
NYEDGE1(config)#exit
NYEDGE1#

Note: Make sure to include the no shutdown command. If you configure the IP
address and you don’t bring the interface up, the routing table will not include the
new routing entries. A directly connected routing entry will only be added if the
interface associated with the IP address is active.

Step 4
Examine the routing table once again:

NYEDGE1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M -
mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF
inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 6/24
8/26/2019 Print content

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1,


L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U -
per-user static route
o - ODR, P - periodic downloaded static route, H -
NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
172.14.0.0/16 is variably subnetted, 2 subnets, 2
masks
C 172.14.0.0/24 is directly connected,
GigabitEthernet0/1
L 172.14.0.1/32 is directly connected,
GigabitEthernet0/1
192.168.16.0/24 is variably subnetted, 2 subnets, 2
masks
C 192.168.16.0/24 is directly connected,
GigabitEthernet0/0
L 192.168.16.1/32 is directly connected,
GigabitEthernet0/0
NYEDGE1#

Notice that additional entries appear in the routing table. Compare those new entries
with the IP address that was configured on interface GigabitEthernet 0/1 in the
previous step.

Task 2 - Implementing Static Routes

As you have seen so far, if no static or dynamic routing is configured on a router, the only
routes in the routing table are those of the directly connected networks.

In this section you will add a static route to the NYWAN1 router that will allow the
NYEDGE1 router reach the 172.16.16.0/24 network. Specifically, you will add a static
route so that the NYEDGE1 will be able to ping the GigabitEthernet 0/1 interface of
the NYWAN1 router. Take a look at the lab topology once again to visualize your goal
more clearly.

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 7/24
8/26/2019 Print content

Step 1
Examine the routing table of the NYEDGE1 router once again. You can use the following
command to omit the code legend from the output:

NYEDGE1#show ip route | begin Gateway


Gateway of last resort is not set
172.14.0.0/16 is variably subnetted, 2 subnets, 2
masks
C 172.14.0.0/24 is directly connected,
GigabitEthernet0/1
L 172.14.0.1/32 is directly connected,
GigabitEthernet0/1
192.168.16.0/24 is variably subnetted, 2 subnets, 2
masks
C 192.168.16.0/24 is directly connected,
GigabitEthernet0/0
L 192.168.16.1/32 is directly connected,
GigabitEthernet0/0
NYEDGE1#

Alert: The text after the | begin section of the command is case sensitive.

You will notice that the 172.16.16.0/24, which is the subnet you want to reach, is not
included in the routing table. So any attempts to reach it will fail. You can confirm this by
attempting to ping the IP address of the GigabitEthernet 0/1 interface of the
NYWAN1 router which has an IP address of 172.16.16.1:

NYEDGE1#ping 172.16.16.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.16.1, timeout is 2
seconds:
.....

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 8/24
8/26/2019 Print content

Success rate is 0 percent (0/5)


NYEDGE1#

Step 2
Before you add a static route that will enable NYEDGE1 to reach the desired network,
you must first determine where NYEDGE1 must send any packets that are destined for
the 172.16.16.0/24 network. Examining the lab topology, you can see that such packets
should be sent to the GigabitEthernet 0/0 interface of NYWAN1. Connect to the
NYWAN1 router to determine the IP address of this interface:

NYWAN1#show ip interface brief


Interface IP-Address OK? Method
Status Protocol
Embedded-Service-Engine0/0 unassigned YES unset
administratively down down
GigabitEthernet0/0 192.168.16.3 YES manual
administratively down down
GigabitEthernet0/1 172.16.16.1 YES manual
administratively down down
GigabitEthernet0/2 unassigned YES unset
administratively down down
Serial0/0/0 unassigned YES unset
administratively down down
Serial0/0/1 unassigned YES unset
administratively down down
Serial0/1/0 unassigned YES unset
administratively down down
Serial0/1/1 unassigned YES unset
administratively down down
Serial0/2/0 unassigned YES unset
administratively down down
NYWAN1#

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 9/24
8/26/2019 Print content

The IP address of the GigabitEthernet 0/0 interface is 192.168.16.3. For the static
route that you will create, this will be the next hop address.

Step 3
Return to NYEDGE1 and configure the static route. As you enter the command, use the
context sensitive help using the ? character as seen below to aid you in appropriately
issuing the command:

NYEDGE1#configure terminal
Enter configuration commands, one per line. End with
CNTL/Z.
NYEDGE1(config)#ip route ?
A.B.C.D Destination prefix
profile Enable IP routing table profile
static Allow static routes
vrf Configure static route for a VPN
Routing/Forwarding instance
NYEDGE1(config)#ip route 172.16.16.0 ?
A.B.C.D Destination prefix mask
NYEDGE1(config)#ip route 172.16.16.0 255.255.255.0 ?
A.B.C.D Forwarding router's address
Async Async interface
Auto-Template Auto-Template interface
!<-- Output Omitted -->
NYEDGE1(config)#ip route 172.16.16.0 255.255.255.0
192.168.16.3
NYEDGE1(config)#exit
NYEDGE1#

Step 4
Examine the routing table of the NYEDGE1 router once again:

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 10/24
8/26/2019 Print content

NYEDGE1#show ip route | begin Gateway


Gateway of last resort is not set
172.14.0.0/16 is variably subnetted, 2 subnets, 2
masks
C 172.14.0.0/24 is directly connected,
GigabitEthernet0/1
L 172.14.0.1/32 is directly connected,
GigabitEthernet0/1
172.16.0.0/24 is subnetted, 1 subnets
S 172.16.16.0 [1/0] via 192.168.16.3
192.168.16.0/24 is variably subnetted, 2 subnets, 2
masks
C 192.168.16.0/24 is directly connected,
GigabitEthernet0/0
L 192.168.16.1/32 is directly connected,
GigabitEthernet0/0
NYEDGE1#

Notice a new routing entry with a code of S has been added. It states that to reach
172.16.16.0 you must go via 192.168.16.3 which is the GigabitEthernet 0/0
interface of the NYWAN1 router.

Step 5
You will now test the route by attempting to reach the 172.16.16.0/24 subnet. You will
attempt once again to ping the IP address of the GigabitEthernet 0/1 interface of the
NYWAN1 router which has an IP address of 172.16.16.1:

NYEDGE1#ping 172.16.16.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.16.1, timeout is 2
seconds:
.!!!!

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 11/24
8/26/2019 Print content

Success rate is 80 percent (4/5), round-trip min/avg/max =


1/1/1 ms
NYEDGE1#

The ping should be successful.

Note: When pinging from a Cisco device, the “.” indicates the ping request has
timed out. The “!” indicates a successful reply. You will notice that occasionally, the
first several pings have timed out. It may be that even the first 5 pings time out
and you may need to issue the command again. This is normal, as the first time
such a communication is made between devices, an interval of time is necessary to
execute an Address Resolution Protocol or ARP request successfully. If you still
don’t have replies to your pings after two tries, review your configuration. To find
out more about the ARP protocol, its purpose and how it works, use your favorite
search engine to research the subject further.

Step 6
Configure one more static route, this time to the 172.14.0.0/24 network from the
NYWAN1 router. Review the lab topology to orientate yourself and understand the
purpose of this static route. The next hop IP address will be 192.168.16.1 which is the IP
address of the GigabitEthernet 0/0 interface on the NYEDGE1 router. Connect to the
NYWAN1 router and issue the following commands:

NYWAN1#configure terminal
Enter configuration commands, one per line. End with
CNTL/Z.
NYWAN1(config)#ip route 172.14.0.0 255.255.255.0
192.168.16.1
NYWAN1(config)#exit
NYWAN1#

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 12/24
8/26/2019 Print content

Step 7
Test the results of this command by attempting to ping 172.14.0.1 which is the IP
address of the GigabitEtherent 0/1 interface of the NYEDGE1 router:

NYWAN1#ping 172.14.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.14.0.1, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
1/1/4 ms
NYWAN1#

The ping should be successful.

At this point, you have successfully implemented two static routes on the NYEDGE1 and
NYWAN1 routers.

Leave all the network devices powered on and proceed to the next exercise.

Exercise 2 - Dynamic Routing


In this exercise, you will learn how to implement dynamic routing. In contrast to static
routing, dynamic routing involves the exchange of routing information between devices
using a routing protocol. From this information, each device builds a topology of the
network. There are many different routing protocols; some are industry standard, and
some are proprietary. These routing protocols fall into two major categories depending
on how they function. These categories are distance vector and link state.

Task 1 - Implement Dynamic Routing

You will implement dynamic routing such that NYEDGE1 and NYEDGE2 will
dynamically exchange routing information. You will use the Routing Information
https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 13/24
8/26/2019 Print content

Protocol (RIP) when implementing dynamic routing.

Step 1
Before making any routing configurations on the routers, you will first activate a
loopback interface that has been preconfigured on the NYEDGE1 router. This will allow
additional networks to be advertised via RIP.

Note: Think of a looback interface as a virtual router interface. It is essentially


just like any other router interface except that it has no physical counterpart. It
has many purposes in the real world. However, its purpose for this lab is to allow
for additional networks to exist on the router without the need for additional
physical ports. For more information, use your favorite search engine to search for
loopback interfaces.

The loopback 0 interface has an IP address of 172.18.0.1/24 and thus is in the


172.18.0.0/24 subnet.

Issue the following commands to activate the loopback 0 interface:

NYEDGE1#configure terminal
Enter configuration commands, one per line. End with
CNTL/Z.
NYEDGE1(config)#interface loopback 0
NYEDGE1(config-if)#no shutdown
NYEDGE1(config-if)#exit
Sep 11 23:59:23.339: %LINK-3-UPDOWN: Interface Loopback0,
changed state to up
Sep 11 23:59:24.339: %LINEPROTO-5-UPDOWN: Line protocol on
Interface Loopback0, changed state to up
NYEDGE1(config)#

Step 2
https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 14/24
8/26/2019 Print content

Next, you will enable the RIP protocol with the following command:

NYEDGE1(config)#router rip
NYEDGE1(config-router)#

RIP has now been enabled on the NYEDGE1 router. Notice how the prompt changes to
NYEDGE1(config-router)#. This is because you are now in the configuration mode in
which you can configure all of the RIP parameters of the router.

Step 3
At this point RIP is enabled. However, no routes are being advertised to other RIP
routers. You must indicate to the router which directly connected networks will
participate in the RIP process. To do this, you can use the network command as follows:

NYEDGE1(config-router)#network 172.14.0.0
NYEDGE1(config-router)#network 192.168.16.0
NYEDGE1(config-router)#network 172.18.0.0
NYEDGE1(config-router)#exit
NYEDGE1(config)#exit

Remember to include the 172.18.0.0 network which belongs to the loopback 0


interface.

The router has now begun advertising these three networks out of all its active interfaces.
Notice that these are the networks to which the two active physical interfaces and the
looback interface of the router are directly connected.

Note: When adding networks with the network command, these must be
directly connected networks. It is possible to add any network using this
command as you will not get an error message, however, a network command

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 15/24
8/26/2019 Print content

that contains a network other than the directly connected networks will have
no effect on any configuration.

Step 4
By advertising these networks, the router is essentially saying that any other router that
wants to get to these network destinations should send their packets to it. At this point,
however, there is no other router configured to listen to such advertisements. You will
now configure the RIP protocol on the NYEDGE2 router as follows:

NYEDGE2#configure terminal
Enter configuration commands, one per line. End with
CNTL/Z.
NYEDGE2(config)#router rip
NYEDGE2(config-router)#

Step 5
Just as before, RIP is enabled, but no routes are being advertised. Indicate which directly
connected networks will participate in the RIP process, again, by using the network
command as follows:

NYEDGE2(config-router)#network 172.14.0.0
NYEDGE2(config-router)#network 192.168.16.0
NYEDGE2(config-router)#exit
NYEDGE2(config)#exit
NYEDGE2#

Notice once again that these are the networks to which the two active interfaces of the
router are directly connected.

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 16/24
8/26/2019 Print content

Step 6
Now take a look at the routing table of NYEDGE2:

NYEDGE2#show ip route | begin Gateway


Gateway of last resort is not set
172.14.0.0/16 is variably subnetted, 2 subnets, 2
masks
C 172.14.0.0/24 is directly connected,
GigabitEthernet0/1
L 172.14.0.2/32 is directly connected,
GigabitEthernet0/1
R 172.18.0.0/16 [120/1] via 192.168.16.1, 00:00:01,
GigabitEthernet0/0
[120/1] via 172.14.0.1, 00:00:07,
GigabitEthernet0/1
192.168.16.0/24 is variably subnetted, 2 subnets, 2
masks
C 192.168.16.0/24 is directly connected,
GigabitEthernet0/0
L 192.168.16.2/32 is directly connected,
GigabitEthernet0/0
NYEDGE2#

A new entry in the routing table appears with the R code indicating that the route was
learned via the RIP protocol. You will also note that in order to reach this new network of
172.18.0.0, there are two possible routes: one via the 192.168.16.1 next hop and one
via 172.14.0.1. These are the GigabitEthernet 0/0 and 0/1 interfaces of NYEDGE1
router respectively. Both options are equally viable routes to reach the desired network.

Note: In general, when using dynamic routing protocols, when multiple routes
are available to a specific network destination, only the best route is included in
the routing table. The only exception is when the routes are of equal cost and of
equal administrative distance as is the case in this example. In this instance,
both routes will be used to reach this destination. This has benefits because you can
https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 17/24
8/26/2019 Print content

now have redundant paths to your destination and you can load balance the
traffic between these routes as well. You will find out more about these concepts in
later lab modules, or you can use your favorite search engine to research them
further.

Step 7
Test to make sure that this new route that was added is functioning correctly. Attempt to
ping the loopback 0 interface of the NYEDGE1 router from the NYEDGE2 router and
examine the results:

NYEDGE2#ping 172.18.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.18.0.1, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
1/1/4 ms
NYEDGE2#

The ping should be successful.

You have successfully configured dynamic routing between the NYEDGE1 and NYEDGE2
routers. Leave the devices in their current states and continue on to the next exercise.

Exercise 3 - Compare Static and Dynamic Routing


There are many advantages to dynamic routing as compared to static routing. The major
advantage is the way that dynamic routing automatically adjusts to changes in the
network whereas static routing requires manual changes to the configuration in order to
accommodate such changes.

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 18/24
8/26/2019 Print content

Task 1 - Static vs. Dynamic

In the previous two exercises, you configured a static route on NYEDGE1 to the
172.16.16.0/24 network, a static route on NYWAN1 to the 172.14.0.0/24 network and
you configured dynamic routing between NYEDGE1 and NYEDGE2. In this exercise,
you will see how these configurations are affected by changes in the network.

Step 1
First, you will test connectivity to the GigabitEthernet 0/1 interface of the NYEDGE1
router from both the NYWAN1 router and the NYEDGE2 router. The first test will use
the static route you configured while the second test will use the dynamic routing you
implemented. Connect to the NYWAN1 router and issue the following command:

NYWAN1#ping 172.14.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.14.0.1, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
1/1/4 ms
NYWAN1#

Connect to the NYEDGE2 router and attempt the same command:

NYEDGE2#ping 172.14.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.14.0.1, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
1/1/4 ms
NYEDGE2#

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 19/24
8/26/2019 Print content

Connectivity is successful in both cases.

Step 2
In this step, you will implement a change to the network. Specifically, you will change the
IP address of the GigabitEthernet 0/1 interface of the NYEDGE1 router from
172.14.0.1/24 to 172.15.0.1/24 as this will place this interface in a completely new
subnet. You will then add this new network to the RIP advertised networks. Connect to
the NYEDGE1 router and issue the following commands:

NYEDGE1#configure terminal
Enter configuration commands, one per line. End with
CNTL/Z.
NYEDGE1(config)#interface GigabitEthernet 0/1
NYEDGE1(config-if)#ip address 172.15.0.1 255.255.255.0
NYEDGE1(config-if)#exit
NYEDGE1(config)#router rip
NYEDGE1(config-router)#network 172.15.0.0
NYEDGE1(config-router)#exit
NYEDGE1(config)#

Step 3
Next, you will attempt to reach this new IP address from both the NYWAN1 and the
NYEDGE2 routers:

NYWAN1#ping 172.15.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.15.0.1, timeout is 2
seconds:
.....
Success rate is 0 percent (0/5)
NYWAN1#
https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 20/24
8/26/2019 Print content

As expected, the attempt from NYWAN1 has failed.

NYEDGE2#ping 172.15.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.15.0.1, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
1/1/4 ms
NYEDGE2#

The attempt from NYEDGE2, however, is successful.

Step 4
Examine the routing table of NYEDGE2:

NYEDGE2#show ip route | begin Gateway


Gateway of last resort is not set
172.14.0.0/16 is variably subnetted, 2 subnets, 2
masks
C 172.14.0.0/24 is directly connected,
GigabitEthernet0/1
L 172.14.0.2/32 is directly connected,
GigabitEthernet0/1
R 172.15.0.0/16 [120/1] via 192.168.16.1, 00:00:19,
GigabitEthernet0/0
R 172.18.0.0/16 [120/1] via 192.168.16.1, 00:00:19,
GigabitEthernet0/0
192.168.16.0/24 is variably subnetted, 2 subnets, 2
masks
C 192.168.16.0/24 is directly connected,
https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 21/24
8/26/2019 Print content

GigabitEthernet0/0
L 192.168.16.2/32 is directly connected,
GigabitEthernet0/0
NYEDGE2#

You should notice two things. First of all, a new route entry has been added with a
destination of 172.15.0.0 via 192.168.16.1. This is to be expected as this is the new
network that was added to NYEDGE1 and advertised via RIP.

The second thing is a little more subtle. The routing entry of 172.18.0.0 now has only
one possible route whereas before, there were two. This is because the second or
redundant route was via 172.14.0.1 which was the IP address of the GigabitEthernet
0/1 interface of NYEDGE1. You have now changed the IP address of this interface and
thus belongs to a different subnet. Therefore this route is no longer available. Notice that
this information was exchanged between the two routers automatically via the RIP
routing protocol.

Step 5
In order to successfully route from NYWAN1 to the new IP address on NYEDGE1, you
must manually reconfigure the static route on NYWAN1. To do this, connect to
NYWAN1. You will first remove the static route that you had configured in a previous
exercise by issuing the following command:

NYWAN1(config)#no ip route 172.14.0.0 255.255.255.0


192.168.16.1
NYWAN1(config)#

You will then implement the new static route:

NYWAN1(config)#ip route 172.15.0.0 255.255.255.0


192.168.16.1

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 22/24
8/26/2019 Print content

NYWAN1(config)#exit
NYWAN1#

Step 6
Finally, you will test to see if this new static route is configured correctly by pinging the
new IP address of the interface on NYEDGE1:

NYWAN1#ping 172.15.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.15.0.1, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
1/1/1 ms
NYWAN1#

The ping is successful.

Note: The network that you configured in this lab involved three routers. You
might be able to administrate a network of this size with static routing
successfully. However, imagine configuring routing in a network that has ten or
twenty routers. If you configured static routing, you would have to configure each
router separately. This would not only be time-consuming, but it would also
require long periods of network downtime. Such a configuration would also be
prone to errors and would require extensive troubleshooting. Dynamic routing
protocols, on the other hand, allow you to make a change to the network in one
location without having to change anything else on any other device. The changes
are propagated throughout the network quickly, automatically and accurately.

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 23/24
8/26/2019 Print content

Summary
Static routing is simple, but is prone to errors and is not scalable. Dynamic routing, on
the other hand, has major advantages over static routing. There is much less
administration involved; you can benefit from redundant paths, and you can load balance
to name just a few.

In this module, you learned how to:

View a routing table on a Cisco router and how this routing table is populated
Determine and configure static routes to allow for routing between remote networks
(non-directly-connected-networks)
Configure dynamic routing using the RIP routing protocol
Compare and examine how static and dynamic routing configurations react to
changes in the network

https://www.practice-labs.com/authenticated/vNext/vn-print-content.aspx 24/24

You might also like