You are on page 1of 4

# VLAN Configuration

====================
set vlans UMS vlan-id 2
set interfaces irb unit 51 family inet address 172.16.2.254/24
set vlans UMS l3-interface irb.2

***on SRX Firewall****


set routing-option static route 172.16.2.0/24 next-hop 172.16.1.254

# DHCP Server Configuration


===========================

1. Create VLAN (all Switches)


=============================
set vlans WiFi vlan-id 51

2. Create irb Interface:


========================
set interfaces irb unit 51 family inet address 172.16.51.254/24
set vlans WiFi l3-interface irb.51

3. Allow permission for VLAN 51 on Firewall/SRX-1500


====================================================
set routing-option static route 172.16.51.0/24 next-hop 172.16.1.254

4. Crate Pool:
==============
set system services dhcp-local-server group DHCP-POOL-51 interface irb.51

5. Assign Network:
==================
set access address-assignment pool DHCP-POOL-51 family inet network 172.16.51.0/24
set access address-assignment pool DHCP-POOL-51 family inet dhcp-attributes name-
server 45.64.132.66
set access address-assignment pool DHCP-POOL-51 family inet dhcp-attributes router
172.16.51.254
set access address-assignment pool DHCP-POOL-51 family inet range User-Range low
172.16.51.1
set access address-assignment pool DHCP-POOL-51 family inet range User-Range high
172.16.51.230

6. DHCP Excluded Address:


=========================
set access address-assignment pool DHCP-POOL-51 family inet excluded-range RESERVE
low 172.16.53.231
set access address-assignment pool DHCP-POOL-51 family inet excluded-range RESERVE
high 172.16.53.253

7. Clear DHCP Server binding


============================
clear dhcp server binding all; clear DHCP pool
or
<address> or <interface interface-name> or <interfaces-vlan>

8. Neighbor Discovery betweenn Cisco and Juniper Switch


=======================================================

DC-EMC-SW#show lldp neighbors; from Cisco Switch


root@ServerFarm> show lldp neighbors; From Juniper Switch

# Static Route Configuration


============================
set system host-name R1
set interfaces ge-0/0/0 unit 0 description “Link from R1 to R2”
set interfaces ge-0/0/0 unit 0 family inet address 172.16.1.1/24
set interfaces lo0 unit 0 family inet address 10.0.0.1/32
set interfaces lo0 unit 0 family inet address 10.0.0.2/32
set routing-options static route 192.168.47.0/24 next-hop 172.16.1.2

set system host-name R2


set interfaces ge-0/0/0 unit 0 description “Link from R2 to R1”
set interfaces ge-0/0/0 unit 0 family inet address 172.16.1.2/24
set interfaces lo0 unit 0 family inet address 192.168.47.5/32
set interfaces lo0 unit 0 family inet address 192.168.47.6/32
set routing-options static route 0.0.0.0/0 next-hop 172.16.1.1

# System Backup and Restore


===========================
putty -> logging -> all sesssion output -> Browse <file location>
session -> SSH [ip address] -> root [******]
root@Core_Switch# show | display set | no-more

# Factory Reset / Password Reset


================================

# Port Security
===============

# Spanning-tree / BPDU Gurad


============================

# Port permission on Firewall


=============================

DHCP CONFIGURE
==============
set system services dhcp-local-server group DHCP-POOL-51 interface irb.51
set access address-assignment pool DHCP-POOL-51 family inet network 172.16.51.0/24
set access address-assignment pool DHCP-POOL-51 family inet range User-Range low
172.16.51.1
set access address-assignment pool DHCP-POOL-51 family inet range User-Range high
172.16.51.230
set access address-assignment pool DHCP-POOL-51 family inet dhcp-attributes name-
server 45.64.132.66
set access address-assignment pool DHCP-POOL-51 family inet dhcp-attributes router
172.16.51.254
set access address-assignment pool DHCP-POOL-51 family inet excluded-range RESERVE
low 172.16.53.231
set access address-assignment pool DHCP-POOL-51 family inet excluded-range RESERVE
high 172.16.53.253
IRB INTERFACE CREATE
====================
set interfaces irb unit 2 family inet address 172.16.2.254/24

VLAN CREATE
===========
set vlans UMS vlan-id 2

VLAN INTERFACE TAGGING


======================
set vlans UMS l3-interface irb.2

TRUNK CONFIGURE
===============
set interfaces xe-0/0/0 unit 0 family ethernet-switching interface-mode trunk
set interfaces xe-0/0/0 unit 0 family ethernet-switching vlan members all

SPECIFIC VLAN ASSIGN


====================
set interfaces xe-0/0/0 unit 0 family ethernet-switching vlan members UMS

INTERFACE STATUS
===============
show interface terse
monitor interface traffic

CONFIGURATION
==============
show | display set| no-more; configuration backup
show | compare; show changes
run show chasis hardware; show hardware status
show run interface description
set chasis fpc 0 pic 0 port 14 speed 1g
run show interfaces ge-0/0/1; Physical Link check
root@AIUB-FW# show |display set |match irb; Information about peer with irb
interface

Port Enable/Disable and Port Description


=========================================
aiub@ServerFarm# set interfaces xe-0/0/12 disable
aiub@ServerFarm# delete interfaces xe-0/0/12 disable
aiub@ServerFarm# set interfaces xe-0/0/46 description LINK->Project Office
^
aiub@ServerFarm# set interfaces xe-0/0/46 description LINK->EMC

CPU Process check


=================
Aiub@Core_Switch> show chasis routing-engin
Aiub@Core_Switch> show chasis environment

Port Speed
==========
set interface ge0/0/47 link-mode full-duplex
set interface g/0/047 ether-option auto-negotiation
set interface g0/0/47 speed auto

configure License/Antivirus
==========================
run show system license
show security utm feature-profile anti-virue | display set | no-more
show security utm utm avira-av-policy_1 | display set | no-more
set security utm feature-profile anti-virus type sophos-engine
commit check
commit confirmed 5

SSH Disable from WAN


=====================
load set terminal relative
show | compare

SRX 1500 License Install


=======================
run show system license
root> request system license add terminal
[Type ^D at a new line to end input,
enter blank line between each license key]
Paste the license key and press enter
Type Ctrl+D

Set Date and Time


=================
show system uptime
set date ntp bd.pool.ntp.org

Configure Web Interface


=======================
set system services web-management http

Misc
====

You might also like