You are on page 1of 66

Adama Science and Technology University

School of Electrical Engineering and Computing


Program of Electronics and Communication
Engineering

Data Communication and Computer Networks


Laboratory Manual
by 1. Yibeltal Abebaw/../../2022 G.C

1
EXIPERMENT - 1

Aim: To study different internetworking devices in a computer network.

1.0 Learning Objective: At the end of the session, you will be able to be familiar with different
types of internetworking devices and their function
1.1 REPEATER
A Repeater is a purely electrical device that extends maximum distance a LAN cable can span by
Amplifying signals passing through it. A Repeater connects two segments and broadcasts packets
between them. Since signal loss is a factor in the maximum length of a segment, a Repeater is used
to amplify the signal and extend the usable length.

1.2 BRIDGES
The networks bridge provides an inexpensive and easy way to connect network segments. A bridge
provides Amplification function of a repeater plus, ability to select filter packets based on their
addresses. When network grows in size, it is often necessary to partition it in to smaller group of
nodes to help isolate traffic and improve performance. One way to do this is to use bridge, the
operation of it is to keep one segment traffic to that side and other side will cross the bridge. The
bridge learns which packets should cross it as it is used.

2
1.3 ROUTERS

A router is a device that connects two LANs together to form an inter-network. A router is the
basic building block of the Internet. Each router connects two or more networks together by
providing an interface for an Ethernet network and ring network to which it is connected.

3
The router examines each packet of information to detection weather the packet must be translated
form on one network to another network performing a function similar to a bridge. Unlike a bridge,
a router can connect network that use different technologies, addressing methods, media type,
frame format and speeds. A router is a special purpose device designed to interconnect networks.
Such that three networks can be connected using two routers. Routers maintain routing tables in
their memories to store information about the physical connection on the networks; the router
examines each packet of data, checks the routing table and then forwards the packet if necessary.
Every other router in the path (between any state destinations) performs a similar procedure. Note
that a router does not maintain any state information about the packets; it simply moves them along
the network. Routers are operated at layer 3 (network) of OSI model.

1.4 GATEWAYS
A gateway, as the name suggests, is a passage to connect two networks together that may
work upon different networking models. They works as the messenger agents that
take data from one system, interpret it, and transfer it to another system. Gateways are also
called protocol converters and can operate at any network layer. Gateways are generally more
complex than switch or router. A gateway is node in a network that serves as an entrance to
another network. In enterprises, the gateway node often acts as a proxy server and a firewall. The
gateway is also associated with both a switch, which provides the actual path for the packet in
and out of the gateway. It is also known as a computer system located on earth that switches data
signals and voice signals between satellites and terrestrial networks. A gateway can operate at
any layer of the OSI or TCP/IP reference model. The hub of a gateway, also called a protocol
converter, is much more complex than that of a router or switch. Typically, a gateway must
convert from one protocol stack to another. E.g. a gateway may connect a TCP/IP network to an
IPX. /SPX network. A Circuit Level Gateway function provided by Application level gateway
products enables trusted users on private network to access Internet services with all security of
a proxy server. An Application Level Gateway provide much stricter form of security that packet
filters, but they are designed to regulate access only for a particular application.

4
1.5 HUBS
Hubs are also called concentrators; expand one Ethernet connection into many. For example, a
four-port hub connects up to four machines via UTP cables. The hub provides a star connection
for the four ports. Many hubs contains a single BNC connectors as well to connect the hub to
existing 10base2 network wiring, the hub can also be connected via one of its ports. One pot is
desired to operate in either straight through or crossover mode, selected by a switch on the hub.
Hubs that can connect in this fashion are called stackable hubs. A hub is similar to a repeater,
expect it broadcasts data received by any port to all other ports on the hub. Most hubs contain a
small amount of intelligence as well. Examining received packets and checking them for integrity.
If a bad packet arrives or the hub determines that a port is unreliable. It will shut down the line
under the error condition is appears. The hub also acts like a repeater. Because of its slight delay
when processing a packet, the numbers of hubs that may be connected in a series are limited.

1.6 SWITCHES

It is similar to a bridge, with some important enhancement. First, as witch may have
multiple ports, thus directing packets to several different segments further partitioning and
isolating network traffic in as way similar to router. For example, if 8-port n way switch is
there it can route packets from any input to any output.

5
Some or all of incoming packet is called store and forward, which stores the received packet
before examining it to for error before retransmitting. Bad packets are not forwarded. A
switch typically has auto-sensing 10/100 mbps ports and will just the speed of each port
accordingly; furthermore, a managed switch supports SNMP for further control over
network traffic. Switches operated at layer 2 (Data Link) of OSI model.

6
EXPERIMENT-2
Aim: To study the working of Basic Networking Commands.

1.0 Learning objective: At the end of the session you will be able to be familiar with
working of different networking commands like: hostname, ifconfig, ping, host, telnet, ftp,
net, arp, Winipcg, nslookup etc.

Networking Commands: The following commands are essentially used for network
management.

1.1 hostnameThis command is used for finding host/domain name and IP address.
Example:
hostname with no options displays the machines host name

hostname –d displays the domain name the machine belongs to

hostname –f displays the fully qualified host and domain name

hostname –i displays the IP address for the current machine

1.2 ifconfig This command will display the assigned IP address of ETHERNET adapter.

Ubuntu: ifconfig | grep inet

Windows: ipconfig

ipconfig Command Another indispensable and frequently used utility that is used for
finding network information about your local machine like IP addresses, DNS addresses
etc Basic Use: Finding Your IP Address and Default Gateway Type the command ipconfig
at the prompt. The following is displayed.

7
Ipconfig has a number of switches the most common are:

ipconfig /all – displays more information about the network setup on your systems
including the MAC address.

ipconfig /release – release the current IP address

ipconfig /renew – renew IP address

ipconfig /? -shows help

ipconfig/flushdns – flush the dns cache

1.3 ping This command is used for checking the network connectivity.
Ping verifies IP-level connectivity to another TCP/IP device by sending Internet Control
Message Protocol (ICMP) Echo Request messages. If received, the corresponding Echo
Reply messages are displayed, along with round-trip times. Otherwise, a timed-out request
or an ICMP unreachable message is displayed.(i.e. You can “ping” an IP address to see if
a machine is alive. If there is no response, you know something is wrong) Example:- ping
www.google.com or ping 216.58.208.68

1.4 getmac Another very simple command that shows the MAC address of your network
interfaces

8
1.5 taskkill

Allows a user running Microsoft Windows XP Professional, Windows 2003, or later to kill a task
from a Windows command line by process id (PID) or image name.

Availability The taskkill command is an external command that is available in the below Microsoft
operating systems as taskkill.exe.

Tip: Windows XP home editions do not have access to this command. Use the command tskill
instead.

Windows XP Professional

Windows Vista

Windows 7

Windows 8

Windows 10

Taskkill syntax

Windows Vista and later syntax.

Windows XP and earlier syntax.

Windows Vista and later syntax TASKKILL [/S system [/U username [/P [password]]]] { [/FI
filter] [/PID processid | /IM imagename] } [/T] [/F]

9
10
11
12
13
1.7 arp This command is used for displaying or manipulating the ARP (Address
Resolution Protocol) information on a network device or computer.

Explanation: The ARP protocol maps Layer 3 IP addresses to Layer 2 MAC addresses. If
a packet must move across networks, the Layer 2 MAC address changes with each hop
across a router, but the Layer 3 address never changes. ARP cache stores ARP address
mappings. If the entry was learned dynamically, it will eventually be deleted from cache.
If the entry was manually inserted in ARP cache, it is a static entry and will remain until
the computer is turned off or the ARP cache is manually flushed. On Windows, arp displays
and modifies entries in the Address Resolution Protocol (ARP) cache, which contains one
or more tables that are used to store IP addresses and their resolved Ethernet or Token Ring
physical addresses. There is a separate table for each Ethernet or Token Ring network
adapter installed on your computer. Used without parameters, arp displays help. This
command must be used with a command line switch arp -a is the most common.

14
1.8 Winipcg This command is used to know the IP configuration of the PC in a
graphical form. It shows the following in the windows command prompt.
 IP Address
 Subnet Mask
 Type of H/W used for communication & it’s address Availability The
winipcfg program is available in:
 Windows 95
 Windows 98
 Windows ME
 Windows NT
Note: Windows 2000, Widows XP, and later versions of Windows do not use this
command. If you are using a later version of Windows, use the ipconfig command
instead.

15
1.9 nslookup This command displays information from Domain Name System (DNS)
name servers.
 The main use of nslookup is for troubleshooting DNS related problems.
 Nslookup can be use in interactive and non-interactive mode.
 To use in interactive mode type nslookp at the command line and hit return.
 You should get an nslookup command prompt.

 To use in non-interactive mode type nslookup options at the command prompt.

Using Nslookup
To illustrate the use of nslookup we are going to use it to:
 Find the IP address of a host.
 Find the domain name of an IP address.
 Find mail servers for a domain.
 These are probably the most common usage scenarios.
 Finding The IP Address of an Host-
 To find the ip address of a host e.g. www.astu.edu.et.com
 nslookup www.astu.edu.et.com
 at a command prompt.
1.10 netstat

This command is used for finding connection to and from the host? Example: netstat nap|
grep port will display process id of application which is using that port netstat a or netstat

16
–all will display all connections including TCP and UDP netstat tcp or netstat –t will
display only TCP connection netstat udp or netstat –u will display only UDP connection
netstat g will display all multicast network subscribed by this host.

17
Experiment 3
Aim: To assign IP address to the PC connected to the internet and Set Up a Network
Between Two Computers

1.0 Learning Objective: At the end of the session you will be able to know how to
assign IP address to a PC connected to the Internet.

1.1 Assigning IP address in Windows 7 or Windows 10

Step-1 To assign or change the computer’s IP address in Windows, first type control panel
into the search box then click on network and internet into the control panel and select
Network and Sharing Center when it comes up. If you’re in Windows 7 or 10 it’ll be in the
start menu.

Step-2

Then when the Network and Sharing Center opens, click on Change adapter settings. This
will be the same on Windows 7 or 10.

18
Step-3

Double click on your local adapter and select Properties.

Step-4

In the Local Area Connection Properties window highlight Internet Protocol Version 4
(TCP/IPv4) then click the Properties button.

19
Now select the radio button Use the following IP address and enter in the correct IP, Subnet
mask, and Default gateway that corresponds with your network setup. Then enter your
Preferred and Alternate DNS server addresses. Here we’re on a home network and using a
simple Class C network configuration and Google DNS.

20
Step-5

Check Validate settings upon exit so Windows can find any problems with the addresses
you entered. When you’re finished click OK.

Set Up a Network Between Two Computers

The first step is to connect the crossover Ethernet cable to the LAN (RJ45) ports of both
computers.

Now, follow the directions below working with one computer at a time.

Start on the desktop of PC 1 and go to My Computer > Properties > Computer Name.
Change the Computer Name to A and the workgroup name to ABC. Click on OK to save
changes.

Next go to Control Panel > Network Connections. Right-click on your LAN connection
and select Properties.

21
22
Experiment - 4
Aim: Creating a Network topology using CISCO packet tracer software.

Learning Objective: At the end of this session you should be able know how to create
a network topology using CISCO packet tracer software.

Apparatus ((Software): Packet tracer Software (Open Source) Version:

This lab is based on Packet Tracer 7.1.1.

Packet Tracer – Creating a New Topology What is Packet Tracer? Packet Tracer is a
protocol simulator developed by Dennis Frezzo and his team at Cisco Systems. Packet
Tracer (PT) is a powerful and dynamic tool that displays the various protocols used in
networking, in either Real Time or Simulation mode. This includes layer 2 protocols such
as Ethernet and PPP, layer 3 protocols such as IP, ICMP, and ARP, and layer 4 protocols
such as TCP and UDP. Routing protocols can also traced.

23
Step 2: Choosing Devices and Connections

We will begin building our network topology by selecting devices and the media in which
to connect them. Several types of devices and network connections can used.

For this lab we will keep it simple by using End Devices, Switches, Hubs, and
Connections. Single click on each group of devices and connections to display the various
choices. The devices you see may differ slightly.

Step 3: Building the Topology

 Adding Hosts Single click on the End Devices.

24
Step 4: Building the Topology – Connecting the Hosts to Hubs and Switches

Adding a Hub

Select a hub, by clicking once on Hubs and once on a Generic hub.

25
Add the hub by moving the plus sign “+” below PC0 and PC1 and click once.

Connect PC0 to Hub0 by first choosing Connections.

Click once on the Copper Straight-through cable.

Perform the following steps to connect PC0 to Hub0:

1. Click once on PC0

26
2. Choose FastEthernet

3. Drag the cursor to Hub0

4. Click once on Hub0 and choose Port 0

5. Notice the green link lights on both the PC0 Ethernet NIC and the Hub0 Port 0 showing that the
link is active.

Repeat the steps above for PC1 connecting it to Port 1 on Hub0. (The actual hub port you choose
does not matter.)

27
Select a switch, by clicking once on Switches and once on a 2950-24 switch.

Add the switch by moving the plus sign “+” below PC2 and PC3 and click once.

28
Perform the following steps to connect PC2 to Switch0:

1. Click once on PC2

2. Choose Fast Ethernet

3. Drag the cursor to Switch0

4. Click once on Switch0 and choose FastEthernet0/1

5. Notice the green link lights on PC2 Ethernet NIC and amber light Switch0 FastEthernet0/1
port. The switch port is temporarily not forwarding frames, while it goes through the stages
for the Spanning Tree Protocol (STP) process.

6. After a about 30 seconds the amber light will change to green indicating that the port has entered
the forwarding stage. Frames can now have forwarded out the switch port.

Repeat the steps above for PC3 connecting it to Port 3 on Switch0 on port FastEtherent0/2. (The
actual switch port you choose does not matter.)

29
Move the cursor over the link light to view the port number. Fa means FastEthernet, 100 Mbps
Ethernet.

Step 5: Configuring IP Addresses and Subnet Masks on the Hosts.

Before we can communicate between the hosts we need to configure IP Addresses and Subnet Masks on
the devices.

Click once on PC0.

Choose the Config tab and click on Settings. It is here that you can change the name of PC0. It is
also here where you would enter a Gateway IP Address, also known as the default gateway and
the DNS Server IP Address. We will discuss this later, but this would be the IP address of the

30
local router. If you want, you can enter the Gateway IP Address 172.16.1.1 and DNS Server IP
Address 172.16.1.100, although it will not be used in this lab.

Click on Interface and then Fast Ethernet. Although we have not yet discussed IP Addresses, add
the IP Address to 172.16.1.10. Click once in the Subnet Mask field to enter the default Subnet
Mask. You can leave this at 255.255.0.0. We will discuss this later.

31
Also, notice this is where you can change the Bandwidth (speed) and Duplex of the Ethernet NIC
(Network Interface Card). The default is Auto (auto negotiation), which means the NIC will
negotiate with the hub or switch. The bandwidth and/or duplex can be manually set by removing
the check from the Auto box and choosing the specific option.

Bandwidth - Auto If the host is connected to a hub or switch port which can do 100 Mbps, then
the Ethernet NIC on the host will choose 100 Mbps (Fast Ethernet). Otherwise, if the hub or switch
port can only do 10 Mbps, then the Ethernet NIC on the host will choose 10 Mbps (Ethernet).

Duplex - Auto

Hub: If the host is connected to a hub, then the Ethernet NIC on the host will choose Half Duplex.

Switch: If the host is connected to a switch, and the switch port is configured as Full Duplex (or
Auto negotiation), then the Ethernet NIC on the host will choose Full Duplex. If the switch port is
configured as Half Duplex, then the Ethernet NIC on the host will choose Half Duplex. (Full
Duplex is a much more efficient option.) The information is automatically saved when entered. To
close this dialog box, click the “X” in the upper right.

Repeat these steps for the other hosts. Use the information below for

IP Addresses and Subnet Masks.

Host IP Address Subnet Mask

PC0 172.16.1.10 255.255.0.0

PC1 172.16.1.11 255.255.0.0

PC2 172.16.1.12 255.255.0.0

PC3 172.16.1.13 255.255.0.0

Verify the information

To verify the information that you entered, move the Select tool (arrow) over each host.

32
Deleting a Device or Link

To delete a device or link, choose the Delete tool and click on the item you wish to delete.

Step 6: Connecting Hub0 to Switch0

To connect like-devices, like a Hub and a Switch, we will use a Cross-over cable.

Click once the Crossover Cable from the Connections options.

Move the Connections cursor over Hub0 and click once.

33
Move the Connections cursor to Switch0.

34
The link light for switch port FastEthernet0/4 will begin as amber and eventually change to green
as the Spanning Tree Protocol transitions the port to forwarding.

35
Step 7: Verifying Connectivity in Real-time Mode

Be sure you are in Real-time mode.

36
Now, Power Cycle Devices and confirm the action.

Waiting for Spanning Tree Protocol (STP)

Note: Because Packet Tracer also simulates the Spanning Tree Protocol (later), at times the switch
may show amber lights on its interfaces. You will need to wait for the lights to turn green on the
switches before they will forward any Ethernet frames.

37
38
Continue clicking Capture/Forward button until the ICMP ping is completed. You should see the
ICMP messages move between the hosts, hub and switch. The PDU Last Status should show as
Successful. Click on Clear Event List if you do not want to look at the events or click Preview
Previous Events if you do. For this exercise it does not matter.

39
Step 9: Saving the Topology

Perform the following steps to save the topology (uses. pkt file extension).

Opening Existing PT Topologies

40
EXPERIMENT-5
Aim: Configuring the Cisco Router using CISCO packet tracer software.

Learning Objective: At the end of this session you should be able know how to configure the
Cisco Router using CISCO packet tracer software.

Apparatus ((Software): Packet tracer Software (Open Source) Version:

This lab is based on Packet Tracer

4.1.1. Packet Tracer – Introduction: -

The way this lab has been setup resembles how you would configure a router in actuality. You
must use the PC to open a terminal (console) session to the router in order to configure it via the
command line interface (CLI). When the lab launches, click on “PC-PT Console Terminal”. This
is the PC that has a console (light blue) cable connected to the router that will be configured.

Click the “PC-PT Console Terminal” device.

Click the “Desktop” tab in the “Console Terminal” window.

41
Click the “Desktop” tab of the “Console Terminal” window.

Click the “Terminal” icon on the desktop.

Accept the default terminal configuration parameters by clicking “OK”.

42
Accept the default terminal configuration parameters by clicking “OK”.

Press the “enter” key to begin. Your prompt will show the router name followed by a greater than
sign. This means that you are in the User EXEC command mode.

Press the “enter” key to begin.

43
Type “enable” to enter the Privileged EXEC command mode and press “enter”. Remember that
pressing the enter key will tell the router to execute the command you have typed. The router name
is now followed by a pound (#) symbol to show this.

The router name is followed by a pound (#) symbol in Privileged EXEC command mode. The
command mode we must be in to change the name of the router is called Global configuration
command mode and is entered by typing “configure terminal”. This can also be done by entering
“config t”. The router name is now followed by the word “config” in parenthesis followed by the
pound (#) symbol.

HINT: When typing commands in the CLI you can press the “tab” key to auto complete the
command. This will save you lots off typing although it is not always necessary to have each word
in a command completely spelled out.

HINT: Use the question mark (?) when not sure about the syntax or availability of commands. It
will show you which of all the available commands are for the command mode you are in. You
can use it after typing a few letters of a word or after one or two words of a command.

44
Global configuration command mode and is entered by typing “configure terminal”.

We are now prepared to enter the commands to complete the lab. Below are the lab’s scenario and
instructions: You are the Network Administrator at Ranet. We have just installed a new router to
be our gateway. You have to do the basic configuration via Console Terminal (PC-PT) as below:

1. Set hostname to be “RanetA”

2. Set enable secret to be “ranetenablepass”

3. Set console password to be “ranetconsolepass”

4. Set telnet password to be “ranettelnetpass”

5. Set IP address of interface Fastethernet 0/0 to be the first address of network 10.0.0.0/30

6. Set IP address of interface Fastethernet 0/1 to be 192.168.0.254/26

7. Both interface Fastethernet 0/0 and 0/1 must be enable.

After configuring this, you should be able to

45
1. Ping to 10.0.0.2 from Ranet A

2. Telnet from Ranet PC to Ranet A by using IP address 192.168.0.254 and telnet password as
above.

Let’s begin with step 1.

1. Set hostname to be “RanetA”

Once in the global configuration mode, type “hostname” followed by a space and the new router
name which is “RanetA”. After pressing enter you will see the prompt change from
“Router(config)#” to “RanetA(config)#”.

After pressing enter you will see the prompt change from “Router(config)#” to “RanetA(config)#”.

2. Set enable secret to be “ranetenablepass”

This password will be required to enter privileged EXEC command mode. In global configuration
mode enter “enable secret ranetenablepass”.

46
In global configuration mode enter “enable secret ranetenablepass”.

3. Set console password to be “ranetconsolepass”

This password will deter unauthorized access to the router via the console connection. While in
global configuration mode enter “line con 0 password ranetenablepasslogin end”. You will then
be dropped down into the privileged EXEC command mode after entering the “end” command.
“Exit can also be used instead of “end”.

4. Set telnet password to be “ranettelnetpass”

“The VTY lines are the Virtual Terminal lines of the router, used solely to control inbound Telnet
connections. They are virtual, in the sense that they are a function of software – there is no
hardware associated with them. They appear in the configuration as line vty 0 4” (cisco.com).

To set the Telnet password type: “line vty 0 4 password ranettelnetpass exit”.

Note: The “exit” command will drop you down into the global configuration command mode.

47
5. Set IP address of interface Fast Ethernet 0/0 to be the first address of network 10.0.0.0/30
The first useable IP address of the 10.0.0.0/30 network is 10.0.0.1. A /30 network means the subnet
mask is 255.255.255.252. To accomplish this objective, we must enter the interface configuration
command mode for fast Ethernet port 0/0 and set the interface’s IP address as well as its subnet
mask. The “exit” command will drop us back into the global configuration command mode.
While in global configuration command mode type.
“interface fastethernet 0/0
ip address 10.0.0.1 255.255.255.252
exit”.
6. Set IP address of interface Fastethernet 0/1 to be 192.168.0.254/26

We will follow the same instructions as step 5 to configure fast Ethernet port 0/1. A /26 network means
the subnet mask is 255.255.255.128.

“interface fast Ethernet 0/1

ip address 192.168.0.254 255.255.255.192

exit”.

7. Both interface Fast Ethernet 0/0 and 0/1 must be enable.

In order for a port to be turned on or activated, the “no shutdown” command must be entered for each
interface.

“interface fastethernet 0/0

no shutdown

exit

interface fastethernet 0/1

no shutdown” You should see status updates in the CLI that both configured interfaces are “up”.

48
You should see status updates in the CLI that both configured interfaces are “up”.

Now that you have completed the configuration of the router, test your work.

1. Ping to 10.0.0.2 from Ranet A

To test connectivity between routers Ranet A and Ranet B we will execute a ping command.

While in privileged EXEC mode of router Ranet A enter

“ping 10.0.0.2”.

If things are correct, you should have an 80-100% ICMP success rate (see screenshot).

49
If things are correct, you should have an 80-100% ICMP success rate.

2. Telnet from Ranet PC to Ranet A by using IP address 192.168.0.254 and telnet password
as above.

To telnet from Ranet PC, open the Ranet PC desktop and click the command prompt.

To telnet from Ranet PC, open the Ranet PC desktop and click the command prompt.

50
In the command prompt type

“telnet 192.168.0.254

ranettelnetpass”.

In the command prompt type “telnet 192.168.0.254 ranettelnetpass”.

If you see RanetA>, congratulations! You have reached the user EXEC command mode of the
Ranet A router.

The list of commands below are an example of how you can type all the router commands into a
plain text file and paste it into the router CLI.

Be sure to order them correctly and remember which command mode you are in.

Enable

Configure terminal

Hostname RanetA

enable secret ranetenablepass

line con 0

51
password ranetenablepass

login

end

configure terminal

ranetenablepass

configure terminal

line vty 0 4

password ranettelnetpass

exit

interface fastethernet 0/0

ip address 10.0.0.1 255.255.255.252

exit

interface fastethernet 0/1

ip address 192.168.0.254 255.255.255.192

exit

interface fastethernet 0/0

no shutdown

exit

interface fastethernet 0/1

no shutdown

exit
exit
exit

52
PART II LAB MANUAL
Network Topology

Device Information
Device port Ip address Subnet mask Default
gateway
R1 Fa0/0 10.240.64.1 255.255.255.0 none
Fa0/1 10.240.84.1 255.255.255.0 None
Se0/0 10.240.65.1 255.255.255.0 None
R2 Fa0/0 10.240.66.1 255.255.255.0 None
Fa0/1 10.240.82.1 255.255.255.0 None
Se0/0/0 10.240.65.2 255.255.255.0 None
PC0 Fa0 10.240.64.2 255.255.255.0 10.240.64.1
PC1 Fa0 10.240.64.3 255.255.255.0 10.240.64.1
PC2 Fa0 10.240.84.2 255.255.255.0 10.240.84.1
PC3 Fa0 10.240.84.3 255.255.255.0 10.240.84.1
PC4 Fa0 10.240.82.2 255.255.255.0 10.240.82.1

53
PC5 Fa0 10.240.82.3 255.255.255.0 10.240.82.1
PC6 Fa0 10.240.66.2 255.255.255.0 10.240.66.1
PC7 Fa0 10.240.66.3 255.255.255.0 10.240.66.1

#Configuration of Router 1
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#enable password computer
R1(config)#enable secret computer1235
R1(config)#line vty 0 4
R1(config-line)#password astuict
R1(config-line)#login
R1(config-line)#exit
R1(config)#line console 0
R1(config-line)#password astuict
R1(config-line)#login
R1(config-line)#exit
R1(config)#interface fa0/0
R1(config-if)#ip address 10.240.64.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R1(config-if)#exit
R1(config)#interface fa0/1
R1(config-if)#ip address 10.240.84.1 255.255.255.0
R1(config-if)#no shutdown

54
R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R1(config-if)#exit
R1(config)#interface se0/0/0
R1(config-if)#ip address 10.240.65.1 255.255.255.0
R1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exit
R1(config)#ip route 10.240.66.0 255.255.255.0 10.240.65.2
R1(config)#ip route 10.240.82.0 255.255.255.0 10.240.65.2

Configuration of Router2

Would you like to enter the initial configuration dialog? [yes/no]: no


Press RETURN to get started!
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#enable password astuedu
R2(config)#enable secret astueduadama
R2(config)#line vty 0 4
R2(config-line)#password ciscopacket
R2(config-line)#login
R2(config-line)#exit
R2(config)#line console 0
R2(config-line)#password ciscopacket
R2(config-line)#login
R2(config-line)#exit
R2(config)#interface fa0/0

55
R2(config-if)#ip address 10.240.66.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R2(config-if)#exit
R2(config)#interface fa0/1
R2(config-if)#ip address 10.240.82.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
R2(config-if)#exit
R2(config)#interface se0/0/0
R2(config-if)#ip address 10.240.65.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
R2(config-if)#exit
R2(config)#ip route 10.240.64.0 255.255.255.0 10.240.65.1
R2(config)#ip route 10.240.84.0 255.255.255.0 10.240.65.1

56
Basic virtual area network configuration
VLAN Trunking Protocol (VTP) is a Cisco proprietary protocol that propagates the definition
of Virtual Local Area Networks (VLAN) on the whole local area network. To do this, VTP carries
VLAN information to all the switches in a VTP domain.Trunk links are required to pass VLAN
information between switches. A port on a Cisco switch is either an access port or a trunk port.
Access ports belong to a single VLAN and do not provide any identifying marks on the frames
that are passed between switches. Access ports also carry traffic that comes from only the VLAN
assigned to the port. A trunk port is by default a member of all the VLANs that exist on the switch
and carrytraffic for all those VLANs between the switches. To distinguish between the traffic
flows, a trunk port mustmark the frames with special tags as they pass between the switches.
Trunking is a function that must be enabled on both sides of a link.

57
Device Port Ip address Subnet mask Default gateway
Router Fa0/0 10.240.64.1/24 255.255.255.0 None
10.240.65.1/24
10.240.66.1/24
Fa0/1 10.240.84.1/24 255.255.255.0 None
PC0 Fa0 10.240.64.2 255.255.255.0 10.240.64.1
PC1 Fa0 10.240.64.3 255.255.255.0 10.240.64.1
PC2 Fa0 10.240.65.2 255.255.255.0 10.240.65.1
PC3 Fa0 10.240.65.3 255.255.255.0 10.240.65.1
PC4 Fa0 10.240.66.2 255.255.255.0 10.240.66.1
PC5 Fa0 10.240.66.3 255.255.255.0 10.240.66.1
PC6 Fa0 10.240.84.2 255.255.255.0 10.240.84.1
PC7 Fa0 10.240.84.3 255.255.255.0 10.240.84.1

# switch 1 configuration

Switch>
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#
Switch(config)#enable password
% Incomplete command.
Switch(config)#enable password cisco
Switch(config)#enable secret cisco1234
Switch(config)#line vty 0 4
Switch(config-line)#password astuece
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#line console 0
Switch(config-line)#password astuece

58
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#int range fa0/
%LINK-5-CHANGED: Interface FastEthernet0/4, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
%LINK-5-CHANGED: Interface FastEthernet0/4, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, change
Switch(config)#int range fa0/4-8
Switch(config-if-range)#
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
Switch(config-if-range)#switchport trunk native vlan 1

Switch(config-if-range)#exit

Switch(config)#vlan 10
Switch(config-vlan)#name EPCE

Switch(config-vlan)#exit
Switch(config)#interface fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#int fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#vlan 11

Switch(config-vlan)#name ECE
Switch(config-vlan)#interface fa0/1
Switch(config-if)#switchport mode access

59
Switch(config-if)#switchport access vlan 11
Switch(config-if)#exit
Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#exit

User Access Verification


Password:
Switch>en
Password:
Password:
Switch#show vlan brief

#Switch 2 configuration

Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname switch2
switch2(config)#enable password cisco
switch2(config)#enable secret cisco1234
switch2(config)#line vty 0 4
switch2(config-line)#password astuece
switch2(config-line)#login
switch2(config-line)#exit
switch2(config)#line console 0
switch2(config-line)#password astuece
switch2(config-line)#login
switch2(config-line)#exit
switch2(config)#vlan 11
switch2(config-vlan)#name ECE
switch2(config-vlan)#exit

60
switch2(config)#vlan 12
switch2(config-vlan)#name CSE
switch2(config-vlan)#exit

switch2(config)#
switch2(config)#int range fa0/4-8
switch2(config-if-range)#switchport mode trunk
switch2(config-if-range)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up
switch2(config-if-range)#switchport trunk native vlan 1
switch2(config-if-range)#exit
switch2(config)#interface fa0/1
switch2(config-if)#switchport mode access
switch2(config-if)#switchport access vlan 11
switch2(config-if)#exit

switch2(config)#int fa0/1
switch2(config-if)#switchport mode access
switch2(config-if)#switchport access vlan 11
switch2(config-if)#
switch2(config-if)#exit
switch2(config)#int fa0/2
switch2(config-if)#switchport mode access
switch2(config-if)#switchport access vlan 12
switch2(config-if)#exit

switch2(config)#interface fa0/3

switch2(config-if)#switchport mode access


switch2(config-if)#switchport access vlan 12

## switch 3 configuration

61
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#enable password cisco
Switch(config)#enable secret cisco1234
Switch(config)#line vty 0 4
Switch(config-line)#password astuece

Switch(config-line)#password astuece
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#line console 0
Switch(config-line)#password astuece
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#vlan 10
Switch(config-vlan)#name lan1
Switch(config-vlan)#exit
Switch(config)#vlan 11
Switch(config-vlan)#name lan2
Switch(config-vlan)#exit
Switch(config)#vlan 12
Switch(config-vlan)#name Lan3
Switch(config-vlan)#exit
Switch(config)#interface range fa0/1-4
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#switchport trunk native vlan 1
Switch(config-if-range)#exit
Switch(config)#
Switch(config)#int range fa0/5-24
Switch(config-if-range)#shutdown

62
#Switch 4v configuration
Switch>en
Switch#config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 13
Switch(config-vlan)#name LawLibrary
Switch(config-vlan)#
Switch(config-vlan)#int fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 13
Switch(config-if)#exit
Switch(config)#int fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 13
Switch(config-if)#exit
Switch(config)#int fa0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan 1
Switch(config-if)#
Switch(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

#Router configuration
yibe(config-if)#
yibe(config-if)#exit
yibe(config)#interface fa0/0.10
yibe(config-subif)#

63
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up
yibe(config-subif)#encap dot1q 10
yibe(config-subif)#ip address 10.240.64.1 255.255.255.0
yibe(config-subif)#exit
yibe(config)#interface fa0/0.11
yibe(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.11, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.11, changed state to up
yibe(config-subif)#encap dot1q 11
yibe(config-subif)#ip address 10.240.65.1 255.255.255.0
yibe(config-subif)#exit
yibe(config)#interface fa0/0.12
yibe(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.12, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.12, changed state to up
yibe(config-subif)#encap dot1q 12
yibe(config-subif)#ip address 10.240.66.1 255.255.255.0
yibe(config-subif)#end
yibe(config)#interface fa0/1
yibe(config-if)#no shutdown
yibe(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
yibe(config-if)#exit
yibe(config)#interface fa0/1.13
yibe(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/1.13, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1.13, changed state to up

yibe(config-subif)#encap dot1q 13

64
yibe(config-subif)#ip address 10.240.84.1 255.255.255.0

Thank you

65
66

You might also like