You are on page 1of 5

CONFIGURE DYNAMIC ROUTES (!!!

(!!! Before configuration make sure all necessary interfaces are “up” and “up” with: R1#show ip interface brief )
R2(config)#router ? (Shows routing protocols)

EIGRP – classless routing protocol, Protocol-Dependent Modules (PDM)


EIGRP Features:
– classless distance Vector Routing Protocol, Cisco proprietary protocol, in IOS 9.2.1, (IGRP stopped in IOS 12.2.)
– RTP; Partial-Bounded Updates; Diffusing Update Algorithm (DUAL); Establishing Adjacencies; Modules: Neighbor & Topology & Routing Tables
– EIGRP supports up to 6 unequal-cost paths

EIGRP Message format:


✓ If the EIGRP packet is encapsulated in an Ethernet frame, the destination MAC address is a unicast, or multicast with the address: 01-00-5E-00-00-0A.
✓ In the IP packet header, the protocol field is set to 88 (to indicate at transport layer RTP for EIGRP), and the destination address is set to unicast, or also
the multicast packets with ip address 224.0.0.10.
✓ In the EIGRP packet header:

= entire EIGRP packet,


excluding the IP header

= EIGRP process issuing the packet. The EIGRP process receiving the
packet will process the packet only if the receiving EIGRP process has the
same AS number; otherwise, the packet will be discarded = neighborhood

On (L4 OSI) Transport Layer EIGRP replaces TCP-UDP with RTP (Reliable Transport Protocol) with multicast and unicast packets, by using:
- unreliable delivery:
Opcode: 0x05 Hello = multicast packets with no Acknowledgements (discovering neighbors & form adjacencies) –> ACK = Hello; and
- reliable delivery:
0x01 Update:Ack = multicast (BMA, NBMA) or unicast (P-t-P) packets, depends on how many routers require it, partial-bounded upd – only the route
info that has changed and only impacted routers will be notified with the same EIGRP process ID;
0x03 Query:Ack = multicast, asking for a new route of failed destination,
0x04 Reply:Ack = unicast. Acknowledgements are always a unicast.

1
Adjacency-Neighborhood: (Hello Intervals+Hold Time are conducive only in holding neighborhood)
-> eigrp (ASN) routing proces ID must be the same on all routers!!!
-> EIGRP metric parameters (K1, K2, K3, K4, K5) have to be the same!!!

Hello Interval = multicast packet Default Hold Time = 3 x Hello Interval Removing route from routing table

5 sec. – most nets. BW>T1=1544 kbps 15 sec. – most networks (Ethernet) Router cancels an adjacence and DUAL
60 sec. – NBMA, P-MP = Serial, <T1 180 sec. – Serial nets. searches for a new path by sending out
queries to his neighbors about fallen route
- unreliable connection through RTP - the max. time router should wait before
declaring a neighbor down

Hello-interval eigrp and Hold-time eigrp can be modified manually using the following interface commands on Adjacency Routers:

Router(config-if)#ip hello-interval eigrp 1 5


Router(config-if)#ip hold-time eigrp 1 15

Network types:
- Point-to-point (P-P) - Serial networks (HDLC, PPP), BW T1=1544 kbps
- Broadcast Multiaccess (BMA) - Ethernet – BW=100 000 kbps
- Nonbroadcast Multiaccess (NBMA) - Frame Relay, ATM, and X.25 networks, BW T1=1544 kbps
- Point-to-multipoint (P-MP) - Frame Relay, ATM, and X.25 networks
- Virtual links - Virtual links are a special type of link that can be used in
multi-area OSPF. OSPF virtual links are discussed in CCNP.

Internal routes contain destination network numbers learned within this EIGRP AS.
External routes contain destination network numbers that were not learned within this EIGRP AS but
rather derived from another routing process and redistributed into this EIGRP AS.

Note: Null0 Summary Route in EIGRP – EIGRP automatically includes a null0 summary route as a child route whenever both of following conditions exist:
1.) There is at least one subnet that was learned via EIGRP
2.) Automatic summarization is enabled (if disabled = null0 summary route is
removed from routing table)
Regardless of whether classful or classless routing behavior is being used, the null0
summary will be used and therefore denying the use of any supernet or default route.

EIGRP can operate (like RIPv2) with:


- classful routing behavior (The longest most specific match Level 1 ultimate route
(Network), classful match of Level 1 Parent route, Level 2 ultimate children route, drop
the packet.) or
- classless routing behavior (moreover, Null0 child ultimate static route, drop the
packet. To cancel Null0 ultimate static route use no auto-summary command = after
that, less specific match – Supernet or Default route is used to forward the packet to
destination).

R1#show ip interface brief


R#debug eigrp {fsm | packet } (fsm: = EIGRP Dual Finite State Machine events/actions; EIGRP packets = UPDATE, QUERY, REPLY,
HELLO, ACK)
R#debug eigrp fsm (EIGRP route-calculation engine)
R#debug ip eigrp [neighbor <neighbor address>]
(or no debug ip eigrp, or undebug all, EIGRP supports VLSM + CIDR, includes subnet mask in rout. upds)

R1(config)#ip classless (or no ..., forwarding packets to the best supernet or default route. Classless routing behavior is by default from IOS 11.3.)
R1(config)#router eigrp <1> (or no router eigrp 1; <AS number = EIGRP process ID> and Metric weights must be the same
on all routers in Domain! Neighbors relationship = adjacency = sharing routing updates)
R(config-router)#metric weights tos k1 k2 k3 k4 k5 (tos *Type-of-service = 0, k1*bandwidth = 1, k2*load = 0, k3*delay = 1, k4,5*reliability = 0, by default)
R(config-router)#distance eigrp <90 = 1-255> <170 = 1-255> (default: EIGRP AD Internal = 90, External imported routes = 170)

R1(config-router)#network 172.16.0.0 (all nets on R1, classful range of addresses only!All subnets will be advertised in EIGRP updates, or)
R1(config-router)#network 192.168.10.4 0.0.0.3 (to configure EIGRP to advertise specific subnets only:
#network [<network-address> <wildcard-mask>] 255.255.255.255 - 255.255.255.252 = 0. 0. 0. 3 (Wildcard mask)
R1(config-router)#no auto-summary (EIGRP as RIPv1 summarizes networks at the classful boundary by default Cisco IOS 12,2;
use it to stop auto-summary; delete Null0 summary routes in routing table…)
R1(config-router)#neighbor 172.16.3.2 (next hop - a specific neighbor with which to exchange info)
R1(config-router)#neighbor 192.168.10.6 (next hop - a specific neighbor with which to exchange info)
R1(config-router)#eigrp log-neighbor-changes (On by default; monitor the stability of the routing system, detect neighboring router problems)

R1(config-router)#passive-interface fa 0/0 (it will stop sending of Hello packets on interface – no adjacency!)
R1(config-router)#passive-interface default (turn-down all interfaces on R1 into passive state = receive Hello packets only)
R1(config-router)#no passive-interface s0/0/0 (turn-on sending Hello packets out of serial interface)

R2(config)#ip route 0.0.0.0 0.0.0.0 loopback 1 (static route to the Internet by using Loopback interface joined to ISP router – in LABs only!)
R2(config-router)#redistribute ? <static | …> (advertising of default static 0.0.0.0 route, in EIGRP upds on stubborn or edge router, to ISP Router)
Note: R1 routing table = D*EX 0.0.0.0/0 [170/3651840] via 192.168.10.6, 00:01:08, Serial0/0/1

R1(config-router)#exit

R1(config)#key chain EIGRP_KEY (názov krúžku pre kľúče)


R1(config-keychain)#key 1 (poradie kľúčov)
R1(config-keychain-key)#key-string cisco (reťazec – zúbkovanie na kľúči)

2
Configuring interfaces with cooperation with EIGRP and MD5 Authentication between Routers:

R1(config)#interface s0/0/0
R1(config-if)#ip authentication mode eigrp 1 md5 (enables MD5 authentication in EIGRP packets, 1 = AS)
R1(config-if)#ip authentication key-chain eigrp 1 EIGRP_KEY (enables MD5 authentication in EIGRP packets, EIGRP_KEY is a name a key chain.)

R1(config-if)#ip summary-address eigrp 1 <supernet> <supernet mask> <AD>


(allowing EIGRP as RIPv2 supernet manual summarization on particular interfaces; default: EIGRP summary route AD = 5)
(configure the summary route on all interfaces that send EIGRP packets)

R1(config-if)#ip address 172.16.3.1 255.255.255.252


R1(config-if)#description default BW 1544 kbps to R3 (text is limited to 240 characters – good for troubleshooting)
R1(config-if)#clock rate 64000 (only on Data Circuit-terminating Equip.-DCE device, in show run router spels them as one = clockrate
64000, Data Link Layer protocol is up for WAN serial point-to-point connection)
R1(config-if)#bandwidth <64 = value-in-kbits > (no bandwidth – restores the static default value 1544 kbps, immediatelly check all interfaces on Routers:
(R1#show interface serial 0/0/0 and 0/0/1 ) (attention! – command show ip interface serial 0/0/0, is different in its result)
Note – static bandwidth command does not change the link’s physical bandwidth.
Default value for Serial interfaces is 1544 Kbps and for fastEth int. 100 000)
– If actual bandwidth of the link differs from the default bandwidth value, then you should modify the bandwidth value)
– bandwidth utilization : By default, EIGRP uses only up to 50% of interface bandwidth for EIGRP information.
R(config-if)#ip bandwidth-percent eigrp 1 <100percent> (The command to change the percentage of bandwidth used by EIGRP = 100% at least)
R(config-if)#ip hello-interval eigrp 1 <60sec> (Changing the hello interval also requires changing the hold time to a value 3x greater
than or equal to the hello interval )
R(config-if)#ip hold-time eigrp 1 <180sec> (amount of time left before neighbor is considered down: R#show ip eigrp neighbors)

R1(config-if)#no shutdown

R1(config-if)#interface fa0/0
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#description default BW 100 000 kbps LAN R1
R1(config-if)#no shutdown
R1(config-if)#end
R1#copy running-config startup-config (Save changes into config file into NVRAM; or write memory or write or wr)

R1(config-router)#key chain EIGRP_KEY R2(config-router)#key chain EIGRP_KEY Názov krúžku


R1(config-keychain)#key 1 R2(config-keychain)#key 1 Kľúče
R1(config-keychain-key)#key-string cisco R2(config-keychain-key)#key-string cisco Zúbkovanie na kľúči
R1(config-if)#ip authentication mode eigrp 1 md5 R2(config-if)#ip authentication mode eigrp 1 md5 Interfaces of neighbours
R1(config-if)#ip authentication key-chain eigrp 1 EIGRP_KEY R2(config-if)#ip authentication key-chain eigrp 1 EIGRP_KEY

R(config-keychain-key)#accept-lifetime 06:30:00 Apr 19 2010 (Optional) Run NTP–Network Time Protocol, the period during which the key can be
infinite received.
R(config-keychain-key)#send-lifetime 06:30:00 Apr 19 2010 (Optional) Run NTP, specifies the period during which the key can be sent.
09:45:00 Apr 19 2010

R1#show ip route (displays Routing table – AD, Metrics, ID networks...)


R1#clear ip route* (to force the routers to rebuild their routing tables)
R1#show ip route eigrp (displays Routing table – AD, Metrics, ID networks... with only EIGRP entries)

R1#show interfaces (view actual BW on interfaces – displays all timers of updates of Routing Protocols )
R1#show ip interface serial 0/0/0 (verify that EIGRP on serial interface only – displays all timers of updates of Routing Protocols)
R1#show ip eigrp interfaces <1> (info about eigrp interfaces running process ID = 1)
R1#show ip eigrp interfaces [<interface> | <AS number> | <details>] (info about all interfaces)
R1#show ip protocols (verify that EIGRP is enabled, displays all TOS, K1…K5, timers of updates of Routing Protocols)
R1#show protocols (verify BW… on all intefaces)

R1#show ip eigrp neighbors [detail] [<interface> | <AS number>] (verify that EIGRP has established adjacencies with neighbors)
R2#show ip eigrp topology 192.168.1.0 [<network address> <mask> | <AS number>]
R1#show ip eigrp topology [active | pending | zero-successors]
R1#show ip eigrp topology all-links (info about all links in topology table)
R1#show ip eigrp traffic [<AS number>] (info about number and type of packets sent and received)

Neighborhood:

SRTT (Smooth Round-Trip Timer) and RTO (Retransmit Interval) - Used by RTP to
manage reliable EIGRP packets. SRTT (ms – Time, EIGRP packet sent and received
ACK) and RTO (ms – Time, SW waits before resending a packet from the retransmition
queue to a neighbor; if Hello is default, RTO = 10-15 sec.) It is discussed further in
CCNP courses.
Queue Count - Should always be zero. If more than zero, then EIGRP packets are
waiting to be sent.
Sequence Number - Used to track updates, queries, and reply packets.

If not, troubleshoot:
- Are both routers configured with the same EIGRP process ID?
- Is the directly connected network included in the EIGRP network statements?
- Is the passive-interface command configured to prevent EIGRP Hello packets on the interface?

3
Purpose of DUAL = To prevent routing loops = loop-free path

• Successor = Primary next hop router to a destination network. It is chosen using DUAL from all of
the known FS.
• Feasible successor (FS) = A backup next hop router to a destination network, if the Primary next hop
(successor) goes down.
• Feasible distance (FD) = Path with Lowest calculated metric to a destination + the cost of reaching the neighbor.
• Reported distance (RD) = The distance towards a destination as advertised by an upstream neighbor or Advertised Distance (AD)
• Feasible or Feasibility Condition (FC) = If the receiving router has a FD to a network and it receives an update from a neighbor with a lower reported advertised
distance RD or AD to that network, then there is a Feasibility condition FC.

Route is in a Passive state = stable mode (or in an Active mode)

Calculated Distances (metrics) on R2

Reported distances (RD) to R2


advertised by upstream neighbors R3+R1

Choosing the best route = After router has received all updates from directly
connected neighbors, it can calculate its DUAL:
• 1st metric is calculated for each route BW+DLY
• 2nd route with lowest metric is designated successor & is placed in routing
table
• 3rd feasible successor is found
• Criteria for feasible successor: it must have lower reported distance to the
destination than the installed route’s feasible distance
• Feasible routes are maintained in topology table.

EIGRP Metrics:

Bandwidth (BW)
– EIGRP uses a static bandwidth to calculate metric, most serial interfaces
use a default bandwidth value of 1.544Mbps (T1).

Load (not a default EIGRP metric)


– A number that reflects how much traffic is using a link.
– Number is determined dynamically and is expressed as a fraction of 255. The lower the fraction the less the load on the link.

4
Delay (DLY)
– is the measure of time it takes for a packet to traverse a route, a static value based on link type to which interface is connected.

Reliability (not a default EIGRP metric)


– A measure of the likelihood that a link will fail
– Measure dynamically & expressed as a fraction of 255 the higher the fraction the better the reliability.

You might also like