You are on page 1of 8

ipv6 basic and configuration

ipv6 configuration
R1 interface configuration
Router#conf t
Router(config)#hostname R1
R1(config)#ipv6 unicast-routing
R1(config)#interface g0/0/0
R1(config-if)#ipv6 address 1000:1111::1/64
R1(config-if)#no shutdown
R1(config-if)#interface se0/2/0
R1(config-if)#ipv6 address 2000::1/64
R1(config-if)#no shutdown

R2 interface configuration
Router#conf t
Router(config)#hostname R2
R2(config)#ipv6 unicast-routing
R2(config)#interface se0/2/0
R2(config-if)#ipv6 address 2000::2/64
R2(config-if)#no shutdown
R2(config-if)#interface se0/2/1
R2(config-if)#ipv6 address 2001::1/64
R2(config-if)#no shutdown

R3 interface configuration
Router(config)#hostname R3
R3(config)#ipv6 unicast-routing
R3(config)#interface g0/0/0
R3(config-if)#ipv6 address 1001:aaaa::1/64
R3(config-if)#no shutdown
R3(config-if)#interface se0/2/0
R3(config-if)#ipv6 address 2001::2/64
R3(config-if)#no shutdown

===========================================================

how to configure ipv6 address in client pc


static routing configuration
R1(config)#ipv6 route 1001:aaaa::/64 2000::2
R1(config)#ipv6 route 2001::/64 2000::2

R2(config)#ipv6 route 1000:1111::/64 2000::1


R2(config)#ipv6 route 1001:aaaa::/64 2001::2
R3(config)#ipv6 route 1000:1111::/64 2001::1
R3(config)#ipv6 route 2000::/64 2001::1

to check show ipv6 route,

ping 1001:aaaa::2

========================================================================

RIPng configuration

R1(config)#interface g0/0/0
R1(config-if)#ipv6 rip jack enable
R1(config-if)#interface se0/2/0
R1(config-if)#ipv6 rip jack enable

R2(config)#interface se0/2/0
R2(config-if)#ipv6 rip jack enable
R2(config-if)#interface se0/2/1
R2(config-if)#ipv6 rip jack enable

R3(config)#interface se0/2/0
R3(config-if)#ipv6 rip jack enable
R3(config-if)#interface g0/0/0
R3(config-if)#ipv6 rip jack enable

============================================================================

ospf configuration

R1(config)#ipv6 router ospf 1


R1(config-rtr)#router-id 1.1.1.1
R1(config-rtr)#interface g0/0/0
R1(config-if)#ipv6 ospf 1 area 1
R1(config-if)#interface se0/2/0
R1(config-if)#ipv6 ospf 1 area 0
R2(config)#ipv6 router ospf 1
R2(config)#router-id 2.2.2.2
R2 (config-rtr)#interface se0/2/0
R2(config-if)#ipv6 ospf 1 area 0
R2(config-if)#interface se0/2/1
R2(config-if)#ipv6 ospf 1 area 0

3(config)#ipv6 router ospf 1


R3(config-rtr)#router-id 3.3.3.3
R3(config-rtr)#interface se0/2/0
R3(config-if)#interface se0/2/0
R3(config-if)#ipv6 ospf 1 area 0
R3(config-if)#interface g0/0/0
R3(config-if)#ipv6 ospf 1 area 2

to check ospf neighbor= show ipv6 ospf neighbor


to check ospf database =show ipv6 ospf database
to check ospf interface=show ipv6 ospf interface (interface name)

You might also like