You are on page 1of 64

Distance Vector vs.

Link
State B C D
A

Distance Routing by rumor Periodic Update


Vector
Route table
Link State Incremental Update
Topology
Hybrid

1
Distance Vector vs. Link State
Distance Vector Link State
► Updates frequently ► Updates are event
triggered
► Each router is "aware"
► Each router is "aware"
only of its immediate of all other routers in
neighbors the "area"
► Slow convergence ► Fast convergence

► Prone to routing loops ► Less subject to routing


loops
► Easy to configure
► More difficult to
configure
2
Comparison Continued
Distance Vector Link State
► Fewer router resources ► More router resource
required intensive
► Updates require more ► Updates require less
bandwidth bandwidth
► Does not "understand" the ► Has detailed knowledge of
topology of the network distant networks and
routers

3
Link State
 Example
OSPF

 OSPF is used for corporate networks

5
OSPF

6
Open Shortest Path First (OSPF)
 OSPF is an open standards routing protocol
 This works by using the Dijkstra algorithm
 OSPF provides the following features:
 Minimizes routing update traffic
 Allows scalability (e.g. RIP is limited to 15 hops)
 Has unlimited hop count
 Supports VLSM/CIDR
 Allows multi-vendor deployment (open standard)

7
Link State
 There are two types of Packets
Hello
LSA’s

8
OSPF Hello

B C
► When router A starts it send Hello packet – uses 224.0.0.5
► Hello packets are received by all neighbors
► B will write A’s name in its neighbor table
► C also process the same way

9
"Hello" Packets
► Small frequently issued packets
► Discover neighbours and negotiate "adjacencies"
► Verify continued availability of adjacent neighbours
► Hello packets and Link State Advertisements (LSAs) build
and maintain the topological database
► Hello packets are addressed to 224.0.0.5.

10
Link State Advertisement
(LSA)
 An OSPF data packet containing link state and routing
information that is shared among OSPF routers

 LSAs are shared only with routers with whom it has


formed adjacencies

 LSA packets are used to update and maintain the


topology database.

11
Link State
 There are three type of tables
Neighbor
Topology
Routing

12
Tables
 Neighbor
 Contain information about the neighbors
 Neighbor is a router which shares a link on same
network
 Another relationship is adjacency
 Not necessarily all neighbors
 LSA updates are only when adjacency is established

13
Tables
 Topology
 Contain information about all network and path to
reach any network
 All LSA’s are entered in to topology table
 When topology changes LSA’s are generated and send
new LSA’s
 On topology table an algorithm is run to create a
shortest path, this algorithm is known as SPF or
dijkstra algorithm

14
Tables
 Routing Table
 Also knows as forwarding database
 Generated when an algorithm is run on the topology
database
 Routing table for each router is unique

15
OSPF Terms
 Link  Backbone area
 Router ID  Internal routers
 Neighbours  Area Border Router
 Adjacency (ABR)
 OSPF Area  Autonomous System
Boundary Router
(ASBR)

16
OSPF Design

Each router connects to the backbone called area 0, or the backbone area.

Routers that connect other areas to the backbone within an AS are called Area Border Routers (ABRs). One
interface must be in area 0.

OSPF runs inside an autonomous system, but can also connect multiple autonomous systems together. The
router that connects these ASes together is called an Autonomous System Boundary Router (ASBR).
17
OSPF Areas
 An OSPF area is a grouping of contiguous networks and
routers
 Share a common area ID
 A router can be a member of more than one area (area
border router)
 All routers in the same area have the same topology
database
 When multiple areas exist, there must always be an area 0
(the backbone) to which other areas connect

18
OSPF Summary
 AD -100
 Hop count is unlimited
 Metric = Cost – 108/BW
 Classless, VLSM
 Load balance up to SIX routers
 Require more processing power

19
Basic OSPF Configuration
Router(config)# router ospf 1
 The number 1 in this example is a process-id # that
begins an OSPF process in the router
 More than one process can be launched in a router, but
this is rarely necessary
 Usually the same process-id is used throughout the
entire network, but this is not required
 The process-id # can actually be any value from 1 to
"very large integer“
 The process-id # cannot be ZERO
 This is NOT the same as the AS# used in IGRP and
EIGRP

20
Configuring OSPF Areas
 After identifying the OSPF process, you need to identify the interfaces that you
want to activate OSPF communications
Lab_A#config t
Lab_A(config)#router ospf 1
Lab_A(config-router)#network 10.0.0.0 0.255.255.255
area ?
<0-4294967295> OSPF area ID as a decimal value
A.B.C.D OSPF area ID in IP address format
Lab_A(config-router)#network 10.0.0.0 0.255.255.255
area 0
► Every OSPF network must have an area 0 (the backbone area) to which other
areas connect
 So in a multiple area network, there must be an area 0
 The wildcard mask represents the set of hosts supported by the network
and is really just the inverse of the subnet mask.
21
OSPF Configuration
► OSPF Process ID number is irrelevant. It can be the same on every
router on the network
► The arguments of the network command are the network number
(10.0.0.0) and the wildcard mask (0.255.255.255)
► Wildcards - A 0 octet in the wildcard mask indicates that the
corresponding octet in the network must match exactly
► A 255 indicates that you don’t care what the corresponding octet is in
the network number
► A network and wildcard mask combination of 1.1.1.1 0.0.0.0 would
match 1.1.1.1 only, and nothing else.
► The network and wildcard mask combination of 1.1.0.0 0.0.255.255
would match anything in the range 1.1.0.0–1.1.255.255

22
OSPF Configuration -1
S0 S1

20.0.0.2 30.0.0.1
R2
R1 R3
S0
S0 20.0.0.1
30.0.0.2 40.0.0.1
E0
10.0.0.1 E0

40.0.0.2
10.0.0.2
A B

23
OSPF Configuration -1
S0 S1

20.0.0.2 30.0.0.1
R2
R1 R3
S0
S0
30.0.0.2 40.0.0.1
E0
10.0.0.1 E0 20.0.0.1

40.0.0.2
10.0.0.2
A B
R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#router ospf 1
R1(config-router)#network 10.0.0.0 0.255.255.255 area 0
R1(config-router)#network 20.0.0.0 0.255.255.255 area 0
R1(config-router)#^Z

24
OSPF Configuration -2
S0 S1

200.0.0.8/30
200.0.0.12/30
R2
R1 R3
S0
S0

E0
E0
200.0.0.16/28 200.0.0.32/27

A B

25
OSPF Configuration -2
S0 S1

200.0.0.10 200.0.0.13
255.255.255.252 R2 255.255.255.252
R1 R3
S0
S0 200.0.0.9 200.0.0.14 200.0.0.33
E0
200.0.0.17 E0
255.255.255.224
255.255.255.240 200.0.0.18 200.0.0.34
A B

26
OSPF Configuration -2
S0 S1

200.0.0.10 200.0.0.13
255.255.255.252 R2 255.255.255.252
R1 R3
S0
S0 200.0.0.9
200.0.0.14 200.0.0.33
E0
200.0.0.17 E0
255.255.255.224
255.255.255.240 200.0.0.18 200.0.0.34
A B

R3#config t
R1#config t Enter configuration commands, one per line. End with CNTL/Z.
Enter configuration commands, one per line. End with CNTL/Z. R3(config)#router ospf 1
R1(config)#router ospf 1 R3(config-router)#network 200.0.0. 32 0.0.0.31 area 0
R1(config-router)#network 200.0.0.16 0.0.0.15 area 0 R3(config-router)#network 200.0.0. 12 0.0.0.3 area 0
R1(config-router)#network 200.0.0. 8 0.0.0.3 area 0 R3(config-router)#^Z
R1(config-router)#^Z

27
OSPF and Loopback Interfaces
 Configuring loopback interfaces when using the OSPF routing protocol
is important
 Cisco suggests using them whenever you configure OSPF on a router
 Loopback interfaces are logical interfaces, which are virtual, software-
only interfaces; they are not real router interfaces
 Using loopback interfaces with your OSPF configuration ensures that
an interface is always active for OSPF processes.
 The highest IP address on a router will become that router’s RID
 The RID is used to advertise the routes as well as elect the DR and
BDR.
 If you configure serial interface of your router with highest IP Address
this Address becomes RID of t is the RID of the router because e
router
 If this interface goes down, then a re-election must occur
 It can have an big impact when the above link is flapping

28
Configuring Loopback Interfaces
R1#config t
Enter configuration commands, one per line. End
with CNTL/Z.
R1(config)#int loopback 0
R1(config-if)#ip address 172.16.10.1
255.255.255.255
R1(config-if)#no shut
R1(config-if)#^Z
R1#
29
Verifying OSPF Operation
Router#
show ip protocols

• Verifies the configured IP routing protocol


processes, parameters and statistics
Router#
show ip route ospf

• Displays all OSPF routes learned by the router


Router#
show ip ospf interface

• Displays the OSPF router ID, area ID and


adjacency information 30
Verifying OSPF Operation
(Cont.)

Router#
show ip ospf

• Displays the OSPF router ID, timers, and statistics

Router#
show ip ospf neighbor [detail]

• Displays information about the OSPF neighbors,


including Designated Router (DR) and Backup
Designated Router (BDR) information on
broadcast networks
31
The show ip route ospf Command

RouterA# show ip route ospf

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile,

B - BGP, D - EIGRP, EX - EIGRP external, O - OSPF,


IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, E - EGP, i - IS-IS, L1 - IS-IS
level-1, L2 - IS-IS level-2, * - candidate default

Gateway of last resort is not set


10.0.0.0 255.255.255.0 is subnetted, 2 subnets
O 10.2.1.0 [110/10] via 10.64.0.2, 00:00:50, Ethernet0

32
The show ip ospf interface
Command
RouterA# show ip ospf interface e0

Ethernet0 is up, line protocol is up


Internet Address 10.64.0.1/24, Area 0
Process ID 1, Router ID 10.64.0.1, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State DROTHER, Priority 1
Designated Router (ID) 10.64.0.2, Interface address 10.64.0.2
Backup Designated router (ID) 10.64.0.1, Interface address 10.64.0.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:04
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.64.0.2 (Designated Router)
Suppress hello for 0 neighbor(s)

33
The show ip ospf neighbor
Command
RouterB# show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface


10.64.1.1 1 FULL/BDR 00:00:31 10.64.1.1 Ethernet0
10.2.1.1 1 FULL/- 00:00:38 10.2.1.1 Serial0

34
show ip ospf neighbor detail

show ip ospf database

35
Setting Priority for DR Election

Router(config-if)#
ip ospf priority number

This interface configuration command assigns the OSPF


priority to an interface.
Different interfaces on a router may be assigned different
values.
The default priority is 1. The range is from 0 to 255.
0 means the router is a DROTHER; it can’t be the DR or
BDR.

36
37
EIGRP
► IGRP ► OSPF
 DV  LS
 Easy to configure
  Incremental Updates
Neighbor
 Advanced Metric  Multicast
 Periodic  Open Standard
 Broadcast

► EIGRP
 Hybrid
 DUAL
 Topology Database
 Rapid Convergence
 Reliable
38
Overview
Enhanced Interior Gateway Routing Protocol (EIGRP) is a Cisco-
proprietary routing protocol based on Interior Gateway Routing Protocol
(IGRP).

Released in 1994, Unlike IGRP, which is a classful routing protocol,


EIGRP supports CIDR and VLSM.

 it is probably one of the two most popular routing protocols in use


today.

Compared to IGRP, EIGRP boasts faster convergence times, improved


scalability, and superior handling of routing loops.

EIGRP is often described as a hybrid routing protocol, offering the


best of distance vector and link-state algorithms. 39
Comparing EIGRP with IGRP

IGRP and EIGRP are compatible with each other.


EIGRP offers multiprotocol support, but IGRP does not.
Communication via Reliable Transport Protocol (RTP)
Best path selection via Diffusing Update Algorithm (DUAL)
Improved convergence time
Reduced network overhead

40
Introducing EIGRP

EIGRP supports:
Rapid convergence
Reduced bandwidth usage
Multiple network-layer protocols
EIGRP Tables
► EIGRP maintains 3 tables

 Neighbor table
 Topology table
 Routing table

42
Neighbor Discovery
 There are three conditions that must be met
for neighborship establishment
Hello or ACK received
AS numbers match
Identical metrics (K values)
? AS
?K
Hello

K1 – BW
K2- Delay
K3-Load
K3-Reliability
K5-MTU
43
Metric Calculation
 The metrics used by EIGRP in making routing decisions are (lower the metric the better):
 bandwidth
 delay
 load
 Reliability
 MTU

 By default, EIGRP uses only:


 Bandwidth
 Delay

Analogies:
Think of bandwidth as the width of the pipe
and
delay as the length of the pipe.

 Bandwidth is the carrying capacity


 Delay is the end-to-end travel time.

44
Neighbor Table
 The neighbor table is the most important table in EIGRP

 Stores address and interface of neighbor

45
Topology Table

ro utes
b ou t all Network
a
rma tion
me i n fo
Gi ve

46
Topology Table
The topology table is made up of all the EIGRP routing tables in the
autonomous system.

DUAL takes the information and calculates the lowest cost routes to each
destination.

By tracking this information, EIGRP routers can identify and switch to
alternate routes quickly.

The information that the router learns from the DUAL is used to determine
the successor route, which is the term used to identify the primary or best
route.

Every EIGRP router maintains a topology table. All learned routes to a


destination are maintained in the topology table.
47
Configuring EIGRP

Router(config)#router eigrp autonomous-system

• Defines EIGRP as the IP routing protocol

Router(config-router)#network network-number

• Selects participating attached networks


EIGRP Configuration Example
EIGRP Configuration
S0 S1

200.0.0.10 200.0.0.13
255.255.255.252 R2 255.255.255.252
R1 R3
S0
S0 200.0.0.9
200.0.0.14 200.0.0.33
E0
200.0.0.17 E0
255.255.255.224
255.255.255.240 200.0.0.18 200.0.0.34
A B

R3#config t
R1#config t Enter configuration commands, one per line. End with CNTL/Z.
Enter configuration commands, one per line. End with CNTL/Z. R3(config)#router eigrp 10
R1(config)#router eigrp 10 R3(config-router)#network 200.0.0. 32
R1(config-router)#network 200.0.0.16 R3(config-router)#network 200.0.0. 12
R1(config-router)#network 200.0.0. 8 R3(config-router)#^Z
R1(config-router)#^Z

51
Verifying the EIGRP Configuration

To verify the EIGRP configuration a number of show


and debug commands are available.

These commands are shown on the next few slides.

52
show ip eigrp topology

show ip eigrp topology


[active | pending |
successors]
53
show ip eigrp topology
all-links

show ip eigrp traffic

54
Administrative Distances

55
TELNET
 Getting information about remote device
 Can connect to remote device and configure a device
 Password must be set
R1(config)# line vty 0 4
Password cisco
login

56
Discovering Neighbors on the
Network

57

© 2002, Cisco Systems, Inc. All rights reserved. 57


Discovering Neighbors with CDP
 CDP runs on routers with Cisco IOS®
software Release 10.3 or later and on Cisco
switches.
 Show CDP ?
 Summary information
includes:
 Device ID
 Local Interface
 Port ID
 Capabilities list
 Platform
CDP
 CDP timer is how often CDP packets are transmitted to all
active interfaces.

Router(config)#cdp timer 90

 CDP holdtime is the amount of time that the device will


hold packets received from neighbor devices.
Router(config)#cdp holdtime 240

59
Using CDP

60
Using the show cdp
neighbors Command

The show cdp neighbor command (sh cdp nei for short) delivers
information about directly connected devices.
61
CDP
show cdp neighbor detail

 Thiscommand can be run on both routers


and switches, and it displays detailed
information about each device connected to
the device

62
Using the show cdp entry
Command

The show cdp entry * command displays the same information as the show cdp
neighbor details command.
63
Additional CDP Commands

The show cdp traffic command displays information about


interface traffic, including the number of CDP packets sent and
received and the errors with CDP.
64
CDP Commands
 To disable the CDP on particular interface use the
"no cdp enable" command

 To disable CDP on the entire router use the "no


cdp run" in global configuration mode.

65
Summary
 Cisco Discovery Protocol is an information-gathering tool used
by network administrators to get information about directly
connected devices.

 CDP exchanges hardware and software device information


with its directly connected CDP neighbors.

 You can enable or disable CDP on a router as a whole or on a


port-by-port basis.

 The show cdp neighbors command displays information about


a router’s CDP neighbors.

 The show cdp entry, show cdp traffic, and show cdp interface
commands display detailed CDP information on a Cisco device.
66

You might also like