P. 1
BGP Basic Labs

BGP Basic Labs

4.5

|Views: 2,358|Likes:
Published by baraynavab

More info:

Published by: baraynavab on Feb 26, 2008
Copyright:Public Domain

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PPT, PDF, TXT or read online from Scribd
See more
See less

01/07/2013

pdf

text

original

1

Cabrillo College
Basic
Basic BGP Lab Examples
Rick Graziani, Instructor
November 15, 2001 November 15, 2001
2
Note to instructors

If you have downloaded this presentation from the Cisco
Networking Academy Community FT Center! this may not "e
my latest version of this oweroint#

For the latest oweroints for all my CCNA! CCN! and
$ireless classes! please go to my we" site%
http%&&www#ca"rillo#edu&'rgra(iani&
• The username is cisco and the password is perlman for all of my materials#

If you have any )uestions on any of my materials or the
curriculum! please feel free to email me at gra(iani*ca"rillo#edu
+I really don,t mind helping#- Also! if you run across any typos
or errors in my presentations! please let me know#

I will add .+/pdated 0 date-1 ne2t to each presentation on my
we" site that has "een updated since these have "een uploaded to
the FT center#
Thanks! Rick
3
Objective

These lab examples are not meant to demonstrate
proper or realistic BGP configurations, nor does it
include all the necessary commands to ensure proper
routing operation.

The objectie of these examples are to sho! some of
the basic BGP configuration commands and their affect
on a net!or", including !rong configurations or
misconfigurations.

#opefully this series of configurations and outputs !ill
help explain the ho! BGP is implemented and its
operation.
4
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200
RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
O$r Scen"rio
5
%&' I!P(
'n order for the boundary routers $an(ose& and $an(ose) to exchange BGP routes that
they learn from '$P& and '$P) respectiely, they must do one of the follo!ing*
• Re)istrib$tion * +ot reco,,en)e)-
+ ,edistribute from BGP into the 'GP -,'P). so those routes get propagated to the
other boundary router.
+ ,edistribute from 'GP -,'P). to BGP to learn routes from the other boundary
router or the use of BGP net!or" statements.
+ .is")v"nt"/es* /an be a lot of routes being injected into the 'GP0 may also
re1uire the use of route filters so not all routes are injected into the 'GP or bac" out
to the other '$P.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200
RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
23ith ery fe!
exceptions, interior BGP
-'BGP. + BGP bet!een
peers in the same 4$ +
is used only in
multihomed scenarios.5 +
6oyle
6
'n order for the boundary routers $an(ose& and $an(ose) to exchange BGP routes
that they learn from '$P& and '$P) respectiely, they must do one of the
follo!ing*
• I!P
+ This allo!s the boundary routers to share EBGP routes !ithout the
redistributing ia an 'GP.
+ ,e1uires*
• S'nc&roni0"tion* /an7t adertise ia EBGP if the boundary router
doesn7t hae it in its 'GP routing table because the other 'GP routers !ill
drop it. -/an turn this off if fully meshed 'BGP or non8transit 4$9.
• :ust "no! ho! to reach the next hop address of the route. -example
coming9.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
23ith ery fe! exceptions,
interior BGP -'BGP. + BGP
bet!een peers in the same 4$ +
is used only in multihomed
scenarios.5 + 6oyle
%&' I!P(
7
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200
RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
8
Set$1

,'P) running !ithin 4$)%%

&%.&.%.%;)< is bet!een $an(ose& and '$P&7s &%.).%.%;)< net!or"s,
both of !hich are part of &%.%.%.%;= classful net!or".

,'P) !as chosen because this !ill create a different situation than
!ith the t!o different /lass B net!or"s bet!een $an(ose) and '$P).
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
9
Scen"rio A2 Ste1 31 * E!P "n) I!P 4RIPv25

EBGP is configured bet!een '$P routers and 4$)%% boundary routers.

,'P) is running !ithin 4$)%%

,'P net!or" statements only include those net!or"s in 4$)%%

+o 'BGP has been configured.

There are no static routes.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
1:
Res$6ts*

4$ )%% Boundary -$an(ose& and $an(ose). routers can ping peer '$P
net!or"s

4$ )%% Boundary -$an(ose& and $an(ose). routers can >?T ping
opposite '$P net!or"s -$an(ose& can not ping &@).&A.&.&.

'$P routers -'$P& and '$P). can ping remote peer7s attached net!or"s
only, >?T $an(oseB net!or" -!e !ill see !hy in a moment..
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
S$ccess7$6
1in/s
11
ISP1
router bgp 100
network 10.2.0.0 mask 255.255.255.0
neighbor 10.1.0.2 remote-as 200
ISP2
router bgp 300
network 172.16.0.0
neighbor 172.30.1.2 remote-as 200
SanJose3
router rip
version 2
network 12.16!.1.0
SanJose1
router rip
version 2
network 12.16!.1.0
"
router bgp 200
network 12.16!.1.0
neighbor 10.1.0.1 remote-as 100
SanJose2
router rip
version 2
network 12.16!.1.0
"
router bgp 200
network 12.16!.1.0
neighbor 172.30.1.1 remote-as 300
12
ISP1#show ip route
10.0.0.0$2% is subnette&' 2 subnets
( 10.2.0.0 is &ire)t*+ )onne)te&' ,oopba)k0
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0
- 12.16!.1.0$2% .20$0/ via 10.1.0.2' 00025016
ISP1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 0.0.0.0 0 3276! i
78 12.16!.1.0 10.1.0.2 0 0 200 i
------------------------------------------------------------------------
ISP2#show ip route

172.16.0.0$2% is subnette&' 1 subnets
( 172.16.1.0 is &ire)t*+ )onne)te&' ,oopba)k0
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$0
- 12.16!.1.0$2% .20$0/ via 172.30.1.2' 00030051
ISP2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 172.16.0.0 0.0.0.0 0 3276! i
78 12.16!.1.0 172.30.1.2 0 0 200 i
ISPs on6' see t&e !P
ro$tes )istrib$te) b'
t&e,se6ves "n) t&eir
1eers in t&eir !P
t"b6es.
13
SanJose1#show ip route

10.0.0.0$2% is subnette&' 2 subnets
- 10.2.0.0 .20$0/ via 10.1.0.1' 00032026
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$2/ via 12.16!.1.1%' 00000011' Seria*0$0
( 12.16!.1.6%$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1%' 00000011' Seria*0$0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
9 12.16!.1.16$30 .120$1/ via 12.16!.1.1%' 00000011' Seria*0$0
SanJose1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 10.1.0.1 0 0 100 i
78 12.16!.1.0 0.0.0.0 0 3276! i
Status codes ; <tatus of the ta"le entry# The status is displayed at the "eginning of each line in the ta"le# It can "e one
of the following values%
• s =The ta"le entry is suppressed#
• > =The ta"le entry is valid#
• ? =The ta"le entry is the "est entry to use for that network#
• i =The ta"le entry was learned via an internal @A +i@A- session
S"n#ose1 on6' sees t&e !P
ro$tes )istrib$te) b' itse67 "n)
its 1eer in t&eir !P t"b6es.
14
SanJose2#show ip route

- 172.16.0.0$16 .20$0/ via 172.30.1.1' 0002700!
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
( 12.16!.1.6$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.6%$27 .120$2/ via 12.16!.1.1!' 0000000' Seria*0$0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1!' 0000000' Seria*0$0
9 12.16!.1.12$30 .120$1/ via 12.16!.1.1!' 0000000' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$0
SanJose2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 172.16.0.0 172.30.1.1 0 0 300 i
78 12.16!.1.0 0.0.0.0 0 3276! i
S"n#ose2 on6' sees t&e
!P ro$tes )istrib$te) b'
itse67 "n) its 1eer in t&eir
!P t"b6es.
15
SanJose3#show ip route
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$1/ via 12.16!.1.17' 0000001!' Seria*0$1
9 12.16!.1.6%$27 .120$1/ via 12.16!.1.13' 00000007' Seria*0$0
( 12.16!.1.32$27 is &ire)t*+ )onne)te&' ,oopba)k0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$1
$an(oseB does not hae a route to the '$P net!or"s or the net!or"s
bet!een the '$Ps and the Boundary routers, so the '/:P Echo
,eplies fail.
$an(oseB does not get any routes from the boundary routers except
'GP routes.
There are no BGP routes redistributed into the 'GP and $an(oseB is
not 'BGP peering !ith any BGP spea"ers.
16
Ste1 32 * E!P8 I!P "n) I!P 4RIPv25

EBGP is configured bet!een '$P routers and 4$)%% boundary routers.

,'P) is running !ithin 4$)%%

'BGP is configured bet!een $an(ose& and $an(oseB.

There are no static routes.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
17
Res$6ts*

4$ )%% Boundary routers can ping peer '$P net!or"s

4$ )%% Boundary routers can >?T ping opposite '$P net!or"s

'$P routers can ping remote peer7s attached net!or"s only, >?T $an(oseB
net!or"

$ynchroniCation is on, 2The BGP synchroniCation rule states that if an 4$
proides transit serice to another 4$, BGP should not adertise a route until all
of the routers !ithin the 4$ hae learned about the route ia an 'GP.5 The
boundary routers do not for!ard the 2opposite5 '$P routes because the other
routers in the 4$ do not "no! about it.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
18
ISP1
router bgp 100
network 10.2.0.0 mask 255.255.255.0
neighbor 10.1.0.2 remote-as 200
ISP2
router bgp 300
network 172.16.0.0
neighbor 172.30.1.2 remote-as 200
SanJose3
router rip
version 2
network 12.16!.1.0
SanJose1
router rip
version 2
network 12.16!.1.0
"
router bgp 200
network 12.16!.1.0
neighbor 10.1.0.1 remote-as 100
neighbor 12.16!.1.17 remote-as 200
SanJose2
router rip
version 2
network 12.16!.1.0
"
router bgp 200
network 12.16!.1.0
neighbor 172.30.1.1 remote-as 300
neighbor 12.16!.1.13 remote-as 200
19
SanJose1#show ip route
10.0.0.0$2% is subnette&' 2 subnets
- 10.2.0.0 .20$0/ via 10.1.0.1' 0000013
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$2/ via 12.16!.1.1%' 00000027' Seria*0$0
( 12.16!.1.6%$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1%' 00000027' Seria*0$0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
9 12.16!.1.16$30 .120$1/ via 12.16!.1.1%' 00000027' Seria*0$0
SanJose1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 10.1.0.1 0 0 100 i
7 i172.16.0.0 172.30.1.1 0 100 0 300 i
78 12.16!.1.0 0.0.0.0 0 3276! i
7 i 12.16!.1.17 0 100 0 i
• Even t&o$/& 172.16.0.0 net9or: is in !P t"b6e it is not in ro$tin/ t"b6e
bec"$se t&ere is no ro$te to t&e ne;t &o1 o7 172.30.1.1
• A6so8 t&e !P S'nc&roni0"tion r$6e :ee1s t&e !P ro$te 7ro, bein/ in t&e
ro$tin/ t"b6e8 since t&ere is no I!P ro$te.
S"n#ose1 sti66 on6' sees t&e !P
ro$tes )istrib$te) b' itse67 "n)
its 1eer in t&eir !P t"b6es.
2:
SanJose2#show ip route

- 172.16.0.0$16 .20$0/ via 172.30.1.1' 00011027
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
( 12.16!.1.6$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.6%$27 .120$2/ via 12.16!.1.1!' 0000001' Seria*0$0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1!' 0000001' Seria*0$0
9 12.16!.1.12$30 .120$1/ via 12.16!.1.1!' 0000001' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$0
SanJose2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
7 i10.2.0.0$2% 10.1.0.1 0 100 0 100 i
78 172.16.0.0 172.30.1.1 0 0 300 i
7 i12.16!.1.0 12.16!.1.13 0 100 0 i
78 0.0.0.0 0 3276! i
• Even t&o$/& 10.2.0.0 net9or: is in !P t"b6e it is not in ro$tin/ t"b6e
bec"$se t&ere is no ro$te to t&e ne;t &o1 o7 10.1.0.1
• A6so8 t&e !P S'nc&roni0"tion r$6e :ee1s t&e !P ro$te 7ro, bein/ in t&e
ro$tin/ t"b6e8 since t&ere is no I!P ro$te.
S"n#ose2 sti66 on6' sees
t&e !P ro$tes )istrib$te)
b' itse67 "n) its 1eer in
t&eir !P t"b6es.
21
Ste1 33 * A))in/ S"n#ose3 "s " I!P 1eer

EBGP is configured bet!een '$P routers and 4$)%% boundary routers.

,'P) is running !ithin 4$)%%

'BGP is configured bet!een $an(ose&, $an(ose) and $an(oseB, full8
mesh.

>o synchroniCation has been configured on all 'BGP routers, because
!e are fully meshed 'BGP.

There are no static routes.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
22

$hen an I@A router receives an update a"out a destination from an I@A peer! it tries
to verify reacha"ility to that destination via an IGP! such as BI or C<F#

If the I@A router can,t find the destination network in it,s IGP routing ta"le! it will not
advertise the destination to other @A peers#

If the route is not reacha"le through the IGP running within the A<! non;@A routers
will not "e a"le to route traffic passing through the A< towards this destination#

It is pointless to advertise destinations to e2ternal peers if traffic sent through this A< is
going to "e dropped "y some non;@A router within the A< anyway#

<ynchroni(ation can "e safely turned off on "order routers%
0 $hen all transit routers inside the A< are running fully meshed I@A#
0 $hen the A< is not a transit A<#
<ynchroni(ation
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
23
Res$6ts2

By itself, this !ill not change the reachability issues, because !e hae
not resoled the problem !ith the boundary routers being able to reach
the next8hop interface -$an(ose& still can not reach &@).B%.&.&..

3e !ill ma"e another change in a moment.

Later, !e might see that creating a full8mesh 'BGP domain might not be
the best configuration choice.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
24
ISP1
router bgp 100
network 10.2.0.0 mask 255.255.255.0
neighbor 10.1.0.2 remote-as 200
ISP2
router bgp 300
network 172.16.0.0
neighbor 172.30.1.2 remote-as 200
SanJose3
router rip
version 2
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
neighbor 12.16!.1.13 remote-as 200
neighbor 12.16!.1.17 remote-as 200
SanJose1
router rip
version 2
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 10.1.0.1 remote-as 100
neighbor 12.16!.1.1% remote-as 200
neighbor 12.16!.1.17 remote-as 200
"
SanJose2
router rip
version 2
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 172.30.1.1 remote-as 300
neighbor 12.16!.1.13 remote-as 200
neighbor 12.16!.1.1! remote-as 200
25
SanJose1#show ip route
10.0.0.0$2% is subnette&' 2 subnets
- 10.2.0.0 .20$0/ via 10.1.0.1' 0000013
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$2/ via 12.16!.1.1%' 00000027' Seria*0$0
( 12.16!.1.6%$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1%' 00000027' Seria*0$0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
9 12.16!.1.16$30 .120$1/ via 12.16!.1.1%' 00000027' Seria*0$0
SanJose1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 10.1.0.1 0 0 100 i
7 i172.16.0.0 172.30.1.1 0 100 0 300 i
78 12.16!.1.0 0.0.0.0 0 3276! i
7 i 12.16!.1.17 0 100 0 i
• Even t&o$/& 172.16.0.0 net9or: is in !P t"b6e it is not in ro$tin/
t"b6e bec"$se t&ere is no ro$te to t&e ne;t &o1 o7 172.30.1.1
S"n#ose1 sti66 on6' sees t&e
!P ro$tes )istrib$te) b' itse67
"n) its 1eer in t&eir !P t"b6es.
S",e Prob6e,
26
SanJose2#show ip route

- 172.16.0.0$16 .20$0/ via 172.30.1.1' 00011027
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
( 12.16!.1.6$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.6%$27 .120$2/ via 12.16!.1.1!' 0000001' Seria*0$0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1!' 0000001' Seria*0$0
9 12.16!.1.12$30 .120$1/ via 12.16!.1.1!' 0000001' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$0
SanJose2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
7 i10.2.0.0$2% 10.1.0.1 0 100 0 100 i
78 172.16.0.0 172.30.1.1 0 0 300 i
7 i12.16!.1.0 12.16!.1.13 0 100 0 i
78 0.0.0.0 0 3276! i
• Even t&o$/& 10.2.0.0 net9or: is in !P t"b6e it is not in ro$tin/
t"b6e bec"$se t&ere is no ro$te to t&e ne;t &o1 o7 10.1.0.1
S"n#ose2 sti66 on6' sees
t&e !P ro$tes )istrib$te)
b' itse67 "n) its 1eer in
t&eir !P t"b6es.
S",e Prob6e,
27
Ste1 34 * A))in/ t&e net9or:s bet9een t&e bo$n)"r' ro$ters "n) t&e ISP
ro$ters to t&e RIP ro$tin/ )o,"in.

EBGP is configured bet!een '$P routers and 4$)%% boundary routers.

,'P) is running !ithin 4$)%%, inc6$)in/ t&e 10.0.0.0 "n) 172.30.0.0 net9or:
st"te,ents "n) 1"ssive inter7"ces.

'BGP is configured bet!een $an(ose&, $an(ose) and $an(oseB, full8mesh.

+o s'nc&roni0"tion has been configured on all 'BGP routers.

There are no static routes.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
<o,16ete
re"c&"bi6it'
28
ISP1
router bgp 100
network 10.2.0.0 mask 255.255.255.0
neighbor 10.1.0.2 remote-as 200
ISP2
router bgp 300
network 172.16.0.0
neighbor 172.30.1.2 remote-as 200
SanJose3
router rip
version 2
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
neighbor 12.16!.1.13 remote-as 200
neighbor 12.16!.1.17 remote-as 200
SanJose1
router rip
version 2
passive-inter5a)e Seria*0$1
network 10.0.0.0
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 10.1.0.1 remote-as 100
neighbor 12.16!.1.1% remote-as 200
neighbor 12.16!.1.17 remote-as 200
SanJose2
router rip
version 2
passive-inter5a)e Seria*0$1
network 172.30.0.0
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 172.30.1.1 remote-as 300
neighbor 12.16!.1.13 remote-as 200
neighbor 12.16!.1.1! remote-as 200
29
SanJose1#show ip route
- 172.16.0.0$16 .200$0/ via 172.30.1.1' 00017056
9 172.30.0.0$16 .120$2/ via 12.16!.1.1%' 00000020' Seria*0$0
10.0.0.0$2% is subnette&' 2 subnets
- 10.2.0.0 .20$0/ via 10.1.0.1' 00017050
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$2/ via 12.16!.1.1%' 00000020' Seria*0$0
( 12.16!.1.6%$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1%' 00000020' Seria*0$0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
9 12.16!.1.16$30 .120$1/ via 12.16!.1.1%' 00000020' Seria*0$0
SanJose1#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 10.1.0.1 0 0 100 i
78i172.16.0.0 172.30.1.1 0 100 0 300 i
78 12.16!.1.0 0.0.0.0 0 3276! i
7 i 12.16!.1.17 0 100 0 i
• +o9 t&"t t&e net9or:s bet9een t&e ISPs "n) t&e bo$n)"r' ro$ters "re
bein/ 1ro1"/"te) b' RIP8 t&e bo$n)"r' ro$ters no9 &"ve " ro$te to t&e
!P ne;t &o1s.
• ec"$se o7 t&is t&e !P ro$tes to t&e =o11osite> ISP net9or: is
re"c&"b6e "n) in t&e ro$tin/ t"b6e.
3:
SanJose2#show ip route
- 172.16.0.0$16 .20$0/ via 172.30.1.1' 00021051
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$1
10.0.0.0$! is variab*+ subnette&' 2 subnets' 2 masks
- 10.2.0.0$2% .200$0/ via 10.1.0.1' 000210%0
9 10.0.0.0$! .120$2/ via 12.16!.1.1!' 00000003' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
( 12.16!.1.6$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.6%$27 .120$2/ via 12.16!.1.1!' 00000003' Seria*0$0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1!' 00000003' Seria*0$0
9 12.16!.1.12$30 .120$1/ via 12.16!.1.1!' 00000003' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$0
SanJose2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78i10.2.0.0$2% 10.1.0.1 0 100 0 100 i
78 172.16.0.0 172.30.1.1 0 0 300 i
7 i12.16!.1.0 12.16!.1.13 0 100 0 i
78 0.0.0.0 0 3276! i
• +ot on6' is t&e 10.2.0.0 net9or: re"c&"b6e8 b$t t&e 10.0.0.0/8 c6"ss7$6
net9or:8 9&ic& inc6$)es 10.1.0.0/24. ?&is 9i66 co,e into 16"' in "
,o,ent.
• ?&e !P ro$te to t&e =o11osite> ISP net9or: is re"c&"b6e "n) in t&e
ro$tin/ t"b6e.
31
SanJose3#show ip route

- 172.16.0.0$16 .200$0/ via 172.30.1.1' 00020006
9 172.30.0.0$16 .120$1/ via 12.16!.1.17' 00000012' Seria*0$1
10.0.0.0$! is variab*+ subnette&' 2 subnets' 2 masks
- 10.2.0.0$2% .200$0/ via 10.1.0.1' 0001056
9 10.0.0.0$! .120$1/ via 12.16!.1.13' 00000011' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 6 subnets' 3 masks
9 12.16!.1.6$27 .120$1/ via 12.16!.1.17' 00000012' Seria*0$1
9 12.16!.1.6%$27 .120$1/ via 12.16!.1.13' 00000011' Seria*0$0
( 12.16!.1.32$27 is &ire)t*+ )onne)te&' ,oopba)k0
- 12.16!.1.0$2% .200$0/ via 12.16!.1.13' 0001053
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$1
SanJose3#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78i10.2.0.0$2% 10.1.0.1 0 100 0 100 i
78i172.16.0.0 172.30.1.1 0 100 0 300 i
78i12.16!.1.0 12.16!.1.13 0 100 0 i
7 i 12.16!.1.17 0 100 0 i
32
ISP1#show ip route

- 172.16.0.0$16 .20$0/ via 10.1.0.2' 0001501%
10.0.0.0$2% is subnette&' 2 subnets
( 10.2.0.0 is &ire)t*+ )onne)te&' ,oopba)k0
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0
- 12.16!.1.0$2% .20$0/ via 10.1.0.2' 0001501%
ISP1#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 0.0.0.0 0 3276! i
78 172.16.0.0 10.1.0.2 0 200 300 i
78 12.16!.1.0 10.1.0.2 0 0 200 i
• ?&e 172.16.0.0 net9or: is no9 1ro1"/"te) 7ro, S"n#ose1 to ISP1.
33
ISP2#show ip route

172.16.0.0$2% is subnette&' 1 subnets
( 172.16.1.0 is &ire)t*+ )onne)te&' ,oopba)k0
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$0
10.0.0.0$2% is subnette&' 1 subnets
- 10.2.0.0 .20$0/ via 172.30.1.2' 0002300
- 12.16!.1.0$2% .20$0/ via 172.30.1.2' 0002300
ISP2#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 172.30.1.2 0 200 100 i
78 172.16.0.0 0.0.0.0 0 3276! i
78 12.16!.1.0 172.30.1.2 0 0 200 i
• ?&e 10.2.0.0 net9or: 4"n) t&e 10.0.0.0 net9or:5 is no9 1ro1"/"te)
7ro, S"n#ose1 to ISP1.
34
SanJose1#ping 172.16.1.1
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > !%$!%$!% ms
SanJose1#ping 10.2.0.1
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 2!$2!$2! ms
-------------------------------------
SanJose3#ping 172.16.1.1
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 56$56$56 ms
SanJose3#ping 10.2.0.1
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 56$56$60 ms
---------------------------------------
SanJose2#ping 172.16.1.1
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 2!$2!$32 ms
SanJose2#ping 10.2.0.1
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > !%$!%$!% ms
35
ISP2#ping 10.2.0.1

?+pe es)ape se@uen)e to abort.
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
.....
Su))ess rate is 0 per)ent <0$5=

I t&o$/&t 'o$ s"i) "66 ro$ters co$6) re"c& "66 net9or:s(

%&"t &"11ene)(((

ISP2 c"n re"c& 10.2.0.1

%&"t )o 'o$ t&in: t&e 1rob6e, is(
36
ISP2#show ip route
172.16.0.0$2% is subnette&' 1 subnets
( 172.16.1.0 is &ire)t*+ )onne)te&' ,oopba)k0
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$0
10.0.0.0$2% is subnette&' 1 subnets
- 10.2.0.0 .20$0/ via 172.30.1.2' 0002300
- 12.16!.1.0$2% .20$0/ via 172.30.1.2' 0002300
ISP2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 172.30.1.2 0 200 100 i
78 172.16.0.0 0.0.0.0 0 3276! i
78 12.16!.1.0 172.30.1.2 0 0 200 i
ISP1#show ip route
- 172.16.0.0$16 .20$0/ via 10.1.0.2' 0001501%
10.0.0.0$2% is subnette&' 2 subnets
( 10.2.0.0 is &ire)t*+ )onne)te&' ,oopba)k0
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0
- 12.16!.1.0$2% .20$0/ via 10.1.0.2' 0001501%
ISP1#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 0.0.0.0 0 3276! i
78 172.16.0.0 10.1.0.2 0 200 300 i
78 12.16!.1.0 10.1.0.2 0 0 200 I
• ISP2 )oes &"ve " ro$te to 10.2.0.0 "n) ISP1 &"s " ro$te to 172.16.0.0
• ?&e 1in/ $ses " so$rce IP "))ress o7 172.30.1.1 "n) ISP1 )oes +O? &"ve " ro$te
b"c: to t&is )estin"tion "))ress. 4?&is "6so "116ies to 1in/s 7ro, ISP1.5
• E;ten)e) 1in/s 9it& " re"c&"b6e so$rce IP "))ress 9i66 9or:-
37
ISP2#ping
Proto)o* .ip/0
?arget IP a&&ress0 10.2.0.1
9epeat )ount .5/0
Aatagram si:e .100/0
?imeout in se)on&s .2/0
;2ten&e& )omman&s .n/0 +
Sour)e a&&ress or inter5a)e0 172.16.1.1
?+pe o5 servi)e .0/0
Set AB bit in IP hea&erC .no/0
Da*i&ate rep*+ &ataC .no/0
Aata pattern .02E-(A/0
,oose' Stri)t' 9e)or&' ?imestamp' Derbose.none/0
Sweep range o5 si:es .n/0
?+pe es)ape se@uen)e to abort.
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 10!$112$116 ms
• ISP2 )oes &"ve " ro$te to 10.2.0.0 "n) ISP1 &"s " ro$te to 172.16.0.0
• ?&e 1in/ $ses " so$rce IP "))ress o7 172.30.1.1 "n) ISP1 )oes +O? &"ve
" ro$te b"c: to t&is )estin"tion "))ress. 4?&is "6so "116ies to 1in/s 7ro,
ISP1.5
• E;ten)e) 1in/s 9it& " re"c&"b6e so$rce IP "))ress 9i66 9or:-
38
Scen"rio 2 Ste1 31 * I!P bet9een S"n#ose1 "n) S"n#ose2 on6'

EBGP is configured bet!een '$P routers and 4$)%% boundary routers.

,'P) is running !ithin 4$)%%, including the &%.%.%.% and &@).B%.%.%
net!or" statements and passie interfaces.

I!P is con7i/$re) on6' bet9een S"n#ose18 S"n#ose2.

>o synchroniCation has been configured on all 'BGP routers.

There are no static routes.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
39
ISP1
router bgp 100
network 10.2.0.0 mask 255.255.255.0
neighbor 10.1.0.2 remote-as 200
ISP2
router bgp 300
network 172.16.0.0
neighbor 172.30.1.2 remote-as 200
SanJose3
router rip
version 2
network 12.16!.1.0
"
no router bgp 200

SanJose1
router rip
version 2
passive-inter5a)e Seria*0$1
network 10.0.0.0
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 10.1.0.1 remote-as 100
neighbor 12.16!.1.17 remote-as 200
SanJose2
router rip
version 2
passive-inter5a)e Seria*0$1
network 172.30.0.0
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 172.30.1.1 remote-as 300
neighbor 12.16!.1.13 remote-as 200
4:
Res$6ts
• $an(oseB does +O? hae a route to &@).&A.%.% on '$P).
• $an(oseB does hae a route to &%.%.%.% on '$P& only because
$an(ose& is propagating its &%.&.%.%;)< subnet, so it has a route to the
classful &%.%.%.% net!or".
• $an(oseB does +O? hae the specific '$P net!or"s in its routing table
so it may drop pac"ets as it is passed through bet!een $an(ose& and
$an(ose).
+ $an(ose& and $an(ose) can +O? reach the opposite '$P)7s
&@).&A.&.& because $an(oseB does not hae a route to &@).&A.%.%
on '$P&.
+ #o!eer, $an(ose&, $an(ose) and $an(oseB can reach '$P&7s
&%.).%.& because ,'P is sending the &%.%.%.% classful route !hich
includes the serial lin" bet!een $(& and '$P&.
• '$Ps + They !ill +O? be able to ping each other, because $(B has a
route for the &%.%.%.% net!or" but +O? for the &@).&A.%.% net!or", thus
pings from '$P) to '$P& !ill get to '$P) but the replies !ill get dropped
by $(B as it does not hae a route for &@).&A.%.%.
41
ISP1#show ip route

- 172.16.0.0$16 .20$0/ via 10.1.0.2' 0003%013
10.0.0.0$2% is subnette&' 2 subnets
( 10.2.0.0 is &ire)t*+ )onne)te&' ,oopba)k0
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0
- 12.16!.1.0$2% .20$0/ via 10.1.0.2' 0003!03
ISP1#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 0.0.0.0 0 3276! i
78 172.16.0.0 10.1.0.2 0 200 300 i
78 12.16!.1.0 10.1.0.2 0 0 200 i
ISP1#ping 12.16!.1.33
Sen&ing 5' 100-b+te I(4P ;)hos to 12.16!.1.33' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 56$56$60 ms
ISP1#ping 172.16.1.1 4EF; ?3IS E1 ;G?;1A;A PI1H
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
I.I.I
Su))ess rate is 0 per)ent <0$5=
?&is 6oo:s 7ine
7or ISP18 b$t
6ets 6oo: "t t&e
AS200 ro$ters.
42
SanJose1#show ip route
- 172.16.0.0$16 .200$0/ via 172.30.1.1' 000350%0
9 172.30.0.0$16 .120$2/ via 12.16!.1.1%' 0000000%' Seria*0$0
10.0.0.0$2% is subnette&' 2 subnets
- 10.2.0.0 .20$0/ via 10.1.0.1' 000%0006
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$2/ via 12.16!.1.1%' 0000000%' Seria*0$0
( 12.16!.1.6%$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1%' 0000000%' Seria*0$0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
9 12.16!.1.16$30 .120$1/ via 12.16!.1.1%' 00000005' Seria*0$0
SanJose1#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 10.1.0.1 0 0 100 i
78i172.16.0.0 172.30.1.1 0 100 0 300 i
7 i12.16!.1.0 12.16!.1.17 0 100 0 i
78 0.0.0.0 0 3276! i
SanJose1#ping 10.2.0.1
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 2!$2!$32 ms
SanJose1#ping 172.16.1.1
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
I.I.I
Su))ess rate is 0 per)ent <0$5=
?&is 6oo:s 7ine
7or S#18 b$t
6ets 6oo: "t
S#3.
43
SanJose3#show ip route
9 172.30.0.0$16 .120$1/ via 12.16!.1.17' 00000025' Seria*0$1
9 10.0.0.0$! .120$1/ via 12.16!.1.13' 00000006' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$1/ via 12.16!.1.17' 00000025' Seria*0$1
9 12.16!.1.6%$27 .120$1/ via 12.16!.1.13' 00000006' Seria*0$0
( 12.16!.1.32$27 is &ire)t*+ )onne)te&' ,oopba)k0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$1
SanJose3#ping 10.2.0.1
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 56$56$60 ms
SanJose3#ping 172.16.1.1
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
.....
Su))ess rate is 0 per)ent <0$5=
• +otice t&"t S"n#ose3 )oes +O? &"ve " ro$te 7or 172.16.0.0 172.16.0.0.
• %&en " 1"c:et 9it& " )estin"tion "))ress 7or t&is net9or: re"c&es
S"n#ose3 it )ro1s it.
• Re,e,ber8 9e re,ove) S"n#ose3 "s "n I!P 1eer.
%&ere@s
172.16.0.0(
44
SanJose2#show ip route
- 172.16.0.0$16 .20$0/ via 172.30.1.1' 000%3013
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$1
10.0.0.0$! is variab*+ subnette&' 2 subnets' 2 masks
- 10.2.0.0$2% .200$0/ via 10.1.0.1' 0003!057
9 10.0.0.0$! .120$2/ via 12.16!.1.1!' 0000000%' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
( 12.16!.1.6$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.6%$27 .120$2/ via 12.16!.1.1!' 0000000%' Seria*0$0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1!' 00000005' Seria*0$0
9 12.16!.1.12$30 .120$1/ via 12.16!.1.1!' 00000005' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$0
SanJose2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78i10.2.0.0$2% 10.1.0.1 0 100 0 100 i
78 172.16.0.0 172.30.1.1 0 0 300 i
7 i12.16!.1.0 12.16!.1.13 0 100 0 i
78 0.0.0.0 0 3276! i
SanJose2#ping 10.2.0.1
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > !%$!%$!% ms
SanJose2#ping 172.16.1.1
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 2!$2$32 ms
A/"in8t&is
6oo:s 7ine 7or
S#28 b$t
172.16.0.0 )oes
+O? e;ist on
S#3.
45
ISP2#show ip route
172.16.0.0$2% is subnette&' 1 subnets
( 172.16.1.0 is &ire)t*+ )onne)te&' ,oopba)k0
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$0
10.0.0.0$2% is subnette&' 1 subnets
- 10.2.0.0 .20$0/ via 172.30.1.2' 000%%05!
- 12.16!.1.0$2% .20$0/ via 172.30.1.2' 000%015
ISP2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 172.30.1.2 0 200 100 i
78 172.16.0.0 0.0.0.0 0 3276! i
78 12.16!.1.0 172.30.1.2 0 0 200 i
ISP2#ping 10.2.0.1
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
.....
Su))ess rate is 0 per)ent <0$5=
ISP2#ping 12.16!.1.65
Sen&ing 5' 100-b+te I(4P ;)hos to 12.16!.1.65' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > !%$!%$!! ms
?&is "6so 6oo:s
7ine 7or ISP18 b$t
re,e,ber t&e
1"c:ets c"n@t
ret$rn to ISP2
bec"$se S#3 )oes
not &"ve " ro$te
7or 172.16.0.0.
46
Ste1 2 A ?&e So6$tion8 Re)istrib$tin/ !P ro$tes into RIP

EBGP is configured bet!een '$P routers and 4$)%% boundary routers.

,'P) is running !ithin 4$)%%, including the &%.%.%.% and &@).B%.%.% net!or"
statements and passie interfaces.

I!P is con7i/$re) on6' bet9een S"n#ose18 S"n#ose2.

>o synchroniCation has been configured on all 'BGP routers.

172.16.0.0 !P ro$tes "re re)istrib$te) into AS200 vi" RIP

There are no static routes.
<o,16ete
re"c&"bi6it'
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
47
ISP1
router bgp 100
network 10.2.0.0 mask 255.255.255.0
neighbor 10.1.0.2 remote-as 200
ISP2
router bgp 300
network 172.16.0.0
neighbor 172.30.1.2 remote-as 200
SanJose3
router rip
version 2
network 12.16!.1.0

SanJose1
router rip
version 2
passive-inter5a)e Seria*0$1
network 10.0.0.0
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 10.1.0.1 remote-as 100
neighbor 12.16!.1.17 remote-as 200
SanJose2
router rip
version 2
re&istribute bgp 200 metri) 2
passive-inter5a)e Seria*0$1
network 172.30.0.0
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 172.30.1.1 remote-as 300
neighbor 12.16!.1.13 remote-as 200
"
48
SanJose2#show ip route
- 172.16.0.0$16 .20$0/ via 172.30.1.1' 01022020
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$1
10.0.0.0$! is variab*+ subnette&' 2 subnets' 2 masks
- 10.2.0.0$2% .200$0/ via 10.1.0.1' 0101!00%
9 10.0.0.0$! .120$2/ via 12.16!.1.1!' 00000021' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
( 12.16!.1.6$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.6%$27 .120$2/ via 12.16!.1.1!' 00000021' Seria*0$0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1!' 00000021' Seria*0$0
9 12.16!.1.12$30 .120$1/ via 12.16!.1.1!' 00000021' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$0
SanJose2#show ip bgp
-HP tab*e version is %' *o)a* router IA is 12.16!.1.7
Status )o&es0 s suppresse&' & &ampe&' h histor+' 7 va*i&' 8 best' i - interna*
Jrigin )o&es0 i - IHP' e - ;HP' C - in)omp*ete

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78i10.2.0.0$2% 10.1.0.1 0 100 0 100 i
78 172.16.0.0 172.30.1.1 0 0 300 i
7 i12.16!.1.0 12.16!.1.13 0 100 0 i
78 0.0.0.0 0 3276! i
SanJose2#
As be7ore.
49
ISP2#show ip route
172.16.0.0$2% is subnette&' 1 subnets
( 172.16.1.0 is &ire)t*+ )onne)te&' ,oopba)k0
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$0
10.0.0.0$2% is subnette&' 1 subnets
- 10.2.0.0 .20$0/ via 172.30.1.2' 01010%%
- 12.16!.1.0$2% .20$0/ via 172.30.1.2' 0102%001
ISP2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 172.30.1.2 0 200 100 i
78 172.16.0.0 0.0.0.0 0 3276! i
78 12.16!.1.0 172.30.1.2 0 0 200 i
As be7ore.
5:
SanJose3#show ip route

9 172.16.0.0$16 .120$2/ via 12.16!.1.17' 0000000%' Seria*0$1
9 172.30.0.0$16 .120$1/ via 12.16!.1.17' 0000000%' Seria*0$1
9 10.0.0.0$! .120$1/ via 12.16!.1.13' 00000025' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$1/ via 12.16!.1.17' 0000000%' Seria*0$1
9 12.16!.1.6%$27 .120$1/ via 12.16!.1.13' 00000025' Seria*0$0
( 12.16!.1.32$27 is &ire)t*+ )onne)te&' ,oopba)k0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$1
SanJose3#ping 172.16.1.1
• $an(oseB no! has a route for 172.16.0.0 !hich !as redistributed into
,'P by $an(ose).
+ This gies us the rest of the connectiity !e need.
• &%.%.%.% net!or" !as already in $an(ose)7s routing table because
$an(ose&7s has a ,'P net!or" &%.%.%.% statement.
+ ,emember &%.).%.% and &%.&.%.% belong to this classful net!or".
51
SanJose1#show ip route

9 172.16.0.0$16 .120$3/ via 12.16!.1.1%' 00000002' Seria*0$0
9 172.30.0.0$16 .120$2/ via 12.16!.1.1%' 00000002' Seria*0$0
10.0.0.0$2% is subnette&' 2 subnets
- 10.2.0.0 .20$0/ via 10.1.0.1' 0102!01!
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$2/ via 12.16!.1.1%' 00000002' Seria*0$0
( 12.16!.1.6%$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1%' 00000002' Seria*0$0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
9 12.16!.1.16$30 .120$1/ via 12.16!.1.1%' 00000002' Seria*0$0
SanJose1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 10.1.0.1 0 0 100 i
78i172.16.0.0 172.30.1.1 0 100 0 300 i
7 i12.16!.1.0 12.16!.1.17 0 100 0 i
78 0.0.0.0 0 3276! i
• 172.16.0.0 is no! redistributed ia ,'P !hich has a lo!er administratie
distance -&)%. than 'BGP -)%%.0 -EBGP is )%., !hich !as ho! this
route !as in $an(ose&7s routing table prior to redistribution by
$an(ose)..
52
ISP1#show ip route

- 172.16.0.0$16 .20$0/ via 10.1.0.2' 01025026
10.0.0.0$2% is subnette&' 2 subnets
( 10.2.0.0 is &ire)t*+ )onne)te&' ,oopba)k0
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0
- 12.16!.1.0$2% .20$0/ via 10.1.0.2' 0102053
ISP1#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 0.0.0.0 0 3276! i
78 172.16.0.0 10.1.0.2 0 200 300 i
78 12.16!.1.0 10.1.0.2 0 0 200 i
As be7ore.
53
Scen"rio <2 Anot&er %"' * Ste1 31

3hat if !e did not !ant to redistribute the serial net!or"s bet!een the boundary routers and the '$Ps not !ant to redistribute the serial net!or"s bet!een the boundary routers and the '$Ps
into our rip net!or" into our rip net!or". 3hat !ould be the conse1uencesD #o! could !e fix themD

Eentually, for '$P& to reach '$P) !e !ill use next8hop attribute.

$an(ose& can ping &@).&A.&.&. 3e !ill see that $an(ose& has an 'GP route to &@).&A.%.% as this !as
redistributed by $an(ose) from BGP into rip, so it can ping &@).&A.&.&. #o!eer, the &@).&A.%.% route
in the BGP routing table sho!s a next hop of &@).B%.&.&, in !hich $an(ose& does not hae a route for.
Because BGP does not hae a route for the next hop, it does not include this route in its update to its
EBGP peer, '$P&.

'$P) does hae a route to '$P&7s &%.).%.%;)< net!or" because ,'P is adertising the classful &%.%.%.%
net!or" !hich includes the serial lin" bet!een '$P& and $an(ose&. #o!eer, it can >?T ping it
because the reply can >?T get bac" as explained in the preious paragraph.
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
B
54
ISP1
router bgp 100
network 10.2.0.0 mask 255.255.255.0
neighbor 10.1.0.2 remote-as 200
ISP2
router bgp 300
network 172.16.0.0
neighbor 172.30.1.2 remote-as 200
SanJose3
router rip
version 2
network 12.16!.1.0

SanJose1
router rip
version 2
re&istribute bgp 200 metri) 2
passive-inter5a)e Seria*0$1
no network 10.0.0.0
network 12.16!.1.0
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 10.1.0.1 remote-as 100
neighbor 12.16!.1.17 remote-as 200
SanJose2
router rip
version 2
re&istribute bgp 200 metri) 2
passive-inter5a)e Seria*0$1
no network 172.30.0.0
network 12.16!.1.0
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 172.30.1.1 remote-as 300
neighbor 12.16!.1.13 remote-as 200
"
55
ISP1#show ip route
10.0.0.0$2% is subnette&' 2 subnets
( 10.2.0.0 is &ire)t*+ )onne)te&' ,oopba)k0
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0
- 12.16!.1.0$2% .20$0/ via 10.1.0.2' 0000!03%
ISP1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 0.0.0.0 0 3276! i
78 12.16!.1.0 10.1.0.2 0 0 200 i
ISP1#ping 12.16!.1.7
Sen&ing 5' 100-b+te I(4P ;)hos to 12.16!.1.7' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > !%$!%$!% ms
ISP1#ping
Proto)o* .ip/0
?arget IP a&&ress0 172.16.1.1
?+pe es)ape se@uen)e to abort.
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
.....
Su))ess rate is 0 per)ent <0$5=
ISP1#ping 172.30.1.1 <1ote0 ?his is norma* behavior an& ma+ not be ne)essar+.=
Sen&ing 5' 100-b+te I(4P ;)hos to 172.30.1.1' timeout is 2 se)on&s0
.....
Su))ess rate is 0 per)ent <0$5=
+otice2 +o ro$te 7or 172.16.0.0/16 49e@66 see 9&'5
56
SanJose1#show ip route

9 172.16.0.0$16 .120$3/ via 12.16!.1.1%' 0000001' Seria*0$0
10.0.0.0$2% is subnette&' 2 subnets
- 10.2.0.0 .20$0/ via 10.1.0.1' 010200%5
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$2/ via 12.16!.1.1%' 0000001' Seria*0$0
( 12.16!.1.6%$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1%' 0000001' Seria*0$0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
9 12.16!.1.16$30 .120$1/ via 12.16!.1.1%' 0000001' Seria*0$0
SanJose1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 10.1.0.1 0 0 100 i
7 i172.16.0.0 172.30.1.1 0 100 0 300 i
78 12.16!.1.0 0.0.0.0 0 3276! i
7 i 12.16!.1.17 0 100 0 i
SanJose1#ping 10.2.0.1

?+pe es)ape se@uen)e to abort.
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 2!$2$32 ms
SanJose1#ping 172.16.1.1

?+pe es)ape se@uen)e to abort.
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > !%$!%$!% ms
Cno9n vi" RIP
bec"$se is 9"s
re)istrib$te) 7ro,
!P.
+O? sent to ISP1
vi" E!P bec"$se
+e;t &o1 is not
re"c&"b6e.
E!P ro$tes c"rrie) into I!P $se t&e e;tern"6
E!P ne;t &o1.
57
SanJose3#show ip route

9 172.16.0.0$16 .120$2/ via 12.16!.1.17' 0000000' Seria*0$1
9 10.0.0.0$! .120$1/ via 12.16!.1.13' 00000022' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$1/ via 12.16!.1.17' 0000000' Seria*0$1
9 12.16!.1.6%$27 .120$1/ via 12.16!.1.13' 00000022' Seria*0$0
( 12.16!.1.32$27 is &ire)t*+ )onne)te&' ,oopba)k0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$1
SanJose3#
SanJose3#ping 10.2.0.1

?+pe es)ape se@uen)e to abort.
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 56$57$6% ms
SanJose3#ping 172.16.1.1

?+pe es)ape se@uen)e to abort.
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 56$56$56 ms
58
SanJose2#show ip route

- 172.16.0.0$16 .20$0/ via 172.30.1.1' 01023021
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$1
10.0.0.0$! is variab*+ subnette&' 2 subnets' 2 masks
- 10.2.0.0$2% .200$0/ via 10.1.0.1' 0003102%
9 10.0.0.0$! .120$2/ via 12.16!.1.1!' 00000025' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
( 12.16!.1.6$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.6%$27 .120$2/ via 12.16!.1.1!' 00000025' Seria*0$0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1!' 00000025' Seria*0$0
9 12.16!.1.12$30 .120$1/ via 12.16!.1.1!' 00000025' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$0
SanJose2#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78i10.2.0.0$2% 10.1.0.1 0 100 0 100 i
78 172.16.0.0 172.30.1.1 0 0 300 i
7 i12.16!.1.0 12.16!.1.13 0 100 0 i
78 0.0.0.0 0 3276! i
SanJose2#ping 10.2.0.1
Sen&ing 5' 100-b+te I(4P ;)hos to 10.2.0.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > !%$!%$!% ms
SanJose2#ping 172.16.1.1
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 2!$2$32 ms
S"n#ose2 sen)s
10.2.0.0 to ISP2 vi"
E!P bec"$se +e;t
&o1 o7 10.1.0.1 is
re"c&"b6e8 "s 1"rt o7
t&e 10.0.0.0/8 net.
RIP re)istrib$te) t&e
entire c6"ss7$6
10.0.0.0/8 net9or:.
59
ISP2#show ip route
172.16.0.0$2% is subnette&' 1 subnets
( 172.16.1.0 is &ire)t*+ )onne)te&' ,oopba)k0
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$0
10.0.0.0$2% is subnette&' 1 subnets
- 10.2.0.0 .20$0/ via 172.30.1.2' 00033001
- 12.16!.1.0$2% .20$0/ via 172.30.1.2' 01025053
ISP2#show ip bgp
1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 172.30.1.2 0 200 100 i
78 172.16.0.0 0.0.0.0 0 3276! i
78 12.16!.1.0 172.30.1.2 0 0 200 i
ISP2#ping
Proto)o* .ip/0
?arget IP a&&ress0 10.2.0.1
.....
Su))ess rate is 0 per)ent <0$5=
+otice2 ?&ere is " ro$te 7or 10.2.0.0
6:
Ste1 32 A ?&e So6$tion * ne;tA&o1Ase67 ne;tA&o1Ase67

E!P ro$tes c"rrie) into I!P $se t&e e;tern"6 E!P ne;t &o1. S"n#ose1@s !P
t"b6e &"s 172.30.1.1 "s t&e ne;t &o1 7or 172.16.0.0/168 b$t )oes not &"ve " ro$te to
172.30.1.18 so it )oes not 7or9"r) t&is ro$te to ISP1.

!P P"t& Se6ection2 =I7 t&e 1"t& s1eci7ies " ne;t &o1 t&"t is in"ccessib6e8 )ro1 t&e
$1)"te.> 4co,in/5

Dets c&"n/e t&e ne;t &o1 to be t&e intern"6 I!P ne;t &o1.

I!P 1eers S"n#ose1 "n) S"n#ose2 9i66 $se ne;tA&o1 se67 in 1eerin/ 9it& e"c&
ot&er. ?&is 9i66 c&"n/e to ne;t &o1s 7ro, t&e E!P ne;t &o1 to t&e intern"6 I!P
ne;t &o1.

A66 9or:s---
<o,16ete
re"c&"bi6it'
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200 RIP
version 2
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
61
ISP1
router bgp 100
network 10.2.0.0 mask 255.255.255.0
neighbor 10.1.0.2 remote-as 200
ISP2
router bgp 300
network 172.16.0.0
neighbor 172.30.1.2 remote-as 200
SanJose3
router rip
version 2
network 12.16!.1.0

SanJose1
router rip
version 2
re&istribute bgp 200 metri) 2
passive-inter5a)e Seria*0$1
no network 10.0.0.0 <5rom be5ore=
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 10.1.0.1 remote-as 100
neighbor 12.16!.1.17 remote-as 200
neighbor 12.16!.1.17 ne2t-hop-se*5
SanJose2
router rip
version 2
re&istribute bgp 200 metri) 2
passive-inter5a)e Seria*0$1
no network 172.30.0.0 <5rom be5ore=
network 12.16!.1.0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 172.30.1.1 remote-as 300
neighbor 12.16!.1.13 remote-as 200
neighbor 12.16!.1.13 ne2t-hop-se*5
"
62
ISP1#show ip route

- 172.16.0.0$16 .20$0/ via 10.1.0.2' 000030%
10.0.0.0$2% is subnette&' 2 subnets
( 10.2.0.0 is &ire)t*+ )onne)te&' ,oopba)k0
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0
- 12.16!.1.0$2% .20$0/ via 10.1.0.2' 00003022
ISP1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 0.0.0.0 0 3276! i
78 172.16.0.0 10.1.0.2 0 200 300 i
78 12.16!.1.0 10.1.0.2 0 0 200 i
ISP1#ping 12.16!.1.33
Sen&ing 5' 100-b+te I(4P ;)hos to 12.16!.1.33' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 56$56$60 ms
ISP1#ping
Proto)o* .ip/0
?arget IP a&&ress0 172.16.1.1
;2ten&e& )omman&s .n/0 +
Sour)e a&&ress or inter5a)e0 10.2.0.1
Sen&ing 5' 100-b+te I(4P ;)hos to 172.16.1.1' timeout is 2 se)on&s0
"""""
Su))ess rate is 100 per)ent <5$5=' roun&-trip min$avg$ma2 > 10!$111$112 ms
ISP1#
Doo:s /oo)-
63
SanJose20 neighbor 12.16!.1.13 ne2t-hop-se*5 <-812.16!.1.17=
SanJose1#show ip route

9 172.16.0.0$16 .120$3/ via 12.16!.1.1%' 0000002%' Seria*0$0
10.0.0.0$2% is subnette&' 2 subnets
- 10.2.0.0 .20$0/ via 10.1.0.1' 00005051
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$2/ via 12.16!.1.1%' 0000002%' Seria*0$0
( 12.16!.1.6%$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1%' 0000002%' Seria*0$0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1%' 0000002%' Seria*0$0
9 12.16!.1.16$30 .120$1/ via 12.16!.1.1%' 00000025' Seria*0$0
SanJose1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 10.1.0.1 0 0 100 i
78i172.16.0.0 12.16!.1.17 0 100 0 300 i
7 i12.16!.1.0 12.16!.1.17 0 100 0 i
78 0.0.0.0 0 3276! i
Doo:s /oo)-
E77ect o7 t&e ne;tA&o1Ase67 49"s 172.30.1.15
?&e ro$te to t&e ne;t &o1
64
SanJose3#show ip route

9 172.16.0.0$16 .120$2/ via 12.16!.1.17' 00000005' Seria*0$1
9 10.0.0.0$! .120$1/ via 12.16!.1.13' 00000026' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
9 12.16!.1.6$27 .120$1/ via 12.16!.1.17' 00000005' Seria*0$1
9 12.16!.1.6%$27 .120$1/ via 12.16!.1.13' 00000027' Seria*0$0
( 12.16!.1.32$27 is &ire)t*+ )onne)te&' ,oopba)k0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$1
65
SanJose10 neighbor 12.16!.1.17 ne2t-hop-se*5 <-812.16!.1.13=
SanJose2#show ip route

- 172.16.0.0$16 .20$0/ via 172.30.1.1' 0000030
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$1
10.0.0.0$! is variab*+ subnette&' 2 subnets' 2 masks
- 10.2.0.0$2% .200$0/ via 12.16!.1.13' 0000023
9 10.0.0.0$! .120$2/ via 12.16!.1.1!' 00000017' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 2 masks
( 12.16!.1.6$27 is &ire)t*+ )onne)te&' ,oopba)k0
9 12.16!.1.6%$27 .120$2/ via 12.16!.1.1!' 00000017' Seria*0$0
9 12.16!.1.32$27 .120$1/ via 12.16!.1.1!' 00000017' Seria*0$0
9 12.16!.1.12$30 .120$1/ via 12.16!.1.1!' 00000017' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$0
SanJose2#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78i10.2.0.0$2% 12.16!.1.13 0 100 0 100 i
78 172.16.0.0 172.30.1.1 0 0 300 i
7 i12.16!.1.0 12.16!.1.13 0 100 0 i
78 0.0.0.0 0 3276! i
A77ect o7 t&e ne;tA&o1Ase67 49"s 10.1.0.15
?&e ro$te to t&e ne;t &o1
66
:ore to comeE

'n the near future ' !ill expand this
example net!or" to include many more
examples including the use of
attributes.

For no!*
+
3hat if !e used a &@).&A.&.%;)< mas" on
'$P)D
+
3hat if !e !ere running ?$PF instead of
,'P.
+
:ore laterE
67
3hat if !e used a &@).&A.&.%;)< mas" on '$P)D

&@).&A.%.%;&A route distributed ia ,'P and BGP.
ISP2 -;BJ9;
router bgp 300
network 172.16.0.0
neighbor 172.30.1.2 remote-as 200
SanJose2#show ip route
- 172.16.0.0$16 .20$0/ via 172.30.1.1' 0000030
SanJose3#show ip route
9 172.16.0.0$16 .120$2/ via 12.16!.1.17' 00000005' Seria*0$1
SanJose1#show ip route
9 172.16.0.0$16 .120$3/ via 12.16!.1.1%' 0000002%' Seria*0$0
ISP1#show ip route
- 172.16.0.0$16 .20$0/ via 10.1.0.2' 000030%
68
3hat if !e used a &@).&A.&.%;)< mas" on '$P)D

&@).&A.%.%;&A route distributed ia ,'P and &@).&A.&.%;)<
distributed ia BGP.
ISP2 EB?;9
router bgp 300
network 172.16.1.0 mask 255.255.255.0
neighbor 172.30.1.2 remote-as 200
SanJose2#show ip route
- 172.16.1.0$2% .20$0/ via 172.30.1.1' 00000035
SanJose3#show ip route
9 172.16.0.0$16 .120$2/ via 12.16!.1.17' 00000005' Seria*0$1
SanJose1#show ip route
9 172.16.0.0$16 .120$3/ via 12.16!.1.1%' 0000002%' Seria*0$0
- 172.16.1.0$2% .20$0/ via 12.16!.1.17' 00000032
ISP1#show ip route
- 172.16.1.0$16 .20$0/ via 10.1.0.2' 000020%
69
Det@s see &o9 OSPE 9o$6) 9or: 9it& !PF

+otice t&"t t&e 172.16.1.0/24 net9or: is )istrib$te) 9it&in OSPE
"n) not t&e c6"ss7$6 172.16.0.0/16 6i:e 9it& RIP.

A66 9or:s---
<o,16ete
re"c&"bi6it'
10.2.0.0/24
10.1.0.0/24
192.168.1.64/27 192.168.1.96/27
192.168.1.32/27
192.168.1.192/30 192.168.1.196/30
172.16.1.0/24
172.30.1.0/24
$% $%
$% $%
$%
$& $&
$&
Lo% Lo%
Lo% Lo%
Lo%
.1 .1
.1 .1
.2 .2
.65
.97
.193
.194 .198
.197
.33
AS100 AS300
AS200
E!P E!P
ISP1 ISP2
S"n#ose1 S"n#ose2
S"n#ose3
I!P
OSPE
4"re" 05
7:
ISP1
router bgp 100
network 10.2.0.0 mask 255.255.255.0
neighbor 10.1.0.2 remote-as 200
ISP2
router bgp 300
network 172.16.0.0 mask 255.255.255.0
neighbor 172.30.1.2 remote-as 200
SanJose3
router osp5 1
network 12.16!.1.33 0.0.0.0 area 0
network 12.16!.1.1% 0.0.0.0 area 0
network 12.16!.1.1! 0.0.0.0 area 0

SanJose1
router osp5 1
re&istribute bgp 200 metri) 20 subnets
network 12.16!.1.65 0.0.0.0 area 0
network 12.16!.1.13 0.0.0.0 area 0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 10.1.0.1 remote-as 100
neighbor 12.16!.1.17 remote-as 200
neighbor 12.16!.1.17 ne2t-hop-se*5
"
a))ess-*ist 1 permit 10.2.0.0 0.0.0.255
SanJose2
router osp5 1
re&istribute bgp 200 metri) 20 subnets
network 12.16!.1.7 0.0.0.0 area 0
network 12.16!.1.17 0.0.0.0 area 0
"
router bgp 200
no s+n)hroni:ation
network 12.16!.1.0
neighbor 172.30.1.1 remote-as 300
neighbor 12.16!.1.13 remote-as 200
neighbor 12.16!.1.13 ne2t-hop-se*5
71
ISP2#show ip route

172.16.0.0$2% is subnette&' 1 subnets
( 172.16.1.0 is &ire)t*+ )onne)te&' ,oopba)k0
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$0
10.0.0.0$2% is subnette&' 1 subnets
- 10.2.0.0 .20$0/ via 172.30.1.2' 0002602%
- 12.16!.1.0$2% .20$0/ via 172.30.1.2' 0002602%
ISP2#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 172.30.1.2 0 200 100 i
78 172.16.1.0$2% 0.0.0.0 0 3276! i
78 12.16!.1.0 172.30.1.2 0 0 200 i
72
SanJose2#show ip route

172.16.0.0$2% is subnette&' 1 subnets
- 172.16.1.0 .20$0/ via 172.30.1.1' 0002502%
172.30.0.0$2% is subnette&' 1 subnets
( 172.30.1.0 is &ire)t*+ )onne)te&' Seria*0$1
10.0.0.0$2% is subnette&' 1 subnets
J ;2 10.2.0.0 .110$20/ via 12.16!.1.1!' 0000%002' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 3 masks
( 12.16!.1.6$27 is &ire)t*+ )onne)te&' ,oopba)k0
J 12.16!.1.65$32 .110$!%6/ via 12.16!.1.1!' 00000%6' Seria*0$0
J 12.16!.1.33$32 .110$7!2/ via 12.16!.1.1!' 00000%7' Seria*0$0
J 12.16!.1.12$30 .110$!%5/ via 12.16!.1.1!' 00000%7' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$0
SanJose2#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78i10.2.0.0$2% 12.16!.1.13 0 100 0 100 i
78 172.16.1.0$2% 172.30.1.1 0 0 300 i
78 12.16!.1.0 0.0.0.0 0 3276! i
7 i 12.16!.1.13 0 100 0 i
73
SanJose3#show ip route

172.16.0.0$2% is subnette&' 1 subnets
J ;2 172.16.1.0 .110$20/ via 12.16!.1.17' 00001053' Seria*0$1
10.0.0.0$2% is subnette&' 1 subnets
J ;2 10.2.0.0 .110$20/ via 12.16!.1.13' 00002023' Seria*0$0
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 3 masks
J 12.16!.1.7$32 .110$65/ via 12.16!.1.17' 00011001' Seria*0$1
J 12.16!.1.65$32 .110$65/ via 12.16!.1.13' 00011001' Seria*0$0
( 12.16!.1.32$27 is &ire)t*+ )onne)te&' ,oopba)k0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
( 12.16!.1.16$30 is &ire)t*+ )onne)te&' Seria*0$1
74
SanJose1#show ip route

172.16.0.0$2% is subnette&' 1 subnets
J ;2 172.16.1.0 .110$20/ via 12.16!.1.1%' 0000200!' Seria*0$0
10.0.0.0$2% is subnette&' 2 subnets
- 10.2.0.0 .20$0/ via 10.1.0.1' 0002!002
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0$1
12.16!.1.0$2% is variab*+ subnette&' 5 subnets' 3 masks
J 12.16!.1.7$32 .110$!%6/ via 12.16!.1.1%' 0001100' Seria*0$0
( 12.16!.1.6%$27 is &ire)t*+ )onne)te&' ,oopba)k0
J 12.16!.1.33$32 .110$7!2/ via 12.16!.1.1%' 0001100' Seria*0$0
( 12.16!.1.12$30 is &ire)t*+ )onne)te&' Seria*0$0
J 12.16!.1.16$30 .110$!%5/ via 12.16!.1.1%' 0001100' Seria*0$0
SanJose1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 10.1.0.1 0 0 100 i
78i172.16.1.0$2% 12.16!.1.17 0 100 0 300 i
7 i12.16!.1.0 12.16!.1.17 0 100 0 i
78 0.0.0.0 0 3276! i
75
SanJose1#show ip osp5 &ata

JSPB 9outer with IA <12.16!.1.65= <Pro)ess IA 1=


9outer ,ink States <Erea 0=

,ink IA EAD 9outer Ege Se@# (he)ksum ,ink )ount
12.16!.1.33 12.16!.1.33 !%5 02!0000005 02E-7! 5
12.16!.1.65 12.16!.1.65 21 02!000000% 02!!!3 3
12.16!.1.7 12.16!.1.7 !01 02!000000% 02-!;E 3

?+pe-5 ES ;2terna* ,ink States

,ink IA EAD 9outer Ege Se@# (he)ksum ?ag
10.2.0.0 12.16!.1.65 13 02!0000001 02(1(2 100
172.16.1.0 12.16!.1.7 165 02!0000001 022!(1 300
76
ISP1#show ip route

172.16.0.0$2% is subnette&' 1 subnets
- 172.16.1.0 .20$0/ via 10.1.0.2' 00025000
10.0.0.0$2% is subnette&' 2 subnets
( 10.2.0.0 is &ire)t*+ )onne)te&' ,oopba)k0
( 10.1.0.0 is &ire)t*+ )onne)te&' Seria*0
- 12.16!.1.0$2% .20$0/ via 10.1.0.2' 000200%
ISP1#show ip bgp

1etwork 1e2t 3op 4etri) ,o)Pr5 6eight Path
78 10.2.0.0$2% 0.0.0.0 0 3276! i
78 172.16.1.0$2% 10.1.0.2 0 200 300 i
78 12.16!.1.0 10.1.0.2 0 0 200 i
77
To be continuedE

You're Reading a Free Preview

Download
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->