You are on page 1of 3

Suppress-Map:

A Suppress-Map is a route map that's used for doing partial suppression of component routes
of an aggregate. The default, when aggregating with BGP, is to advertise both the aggregate
and all the component routes. If you want to advertise just the aggregate, you use the
summary-only keyword at the end of the aggregate. But if you want to suppress some, but not
all, of the component routes, you use a Suppress-Map. With the summary-only keyword we
would suppress all, but with a suppress-map we can suppress a few. Suppress Map is used to
allow specific networks along with summary network in BGP. It is possible to suppress prefixes
selectively, using a route-map associated via the parameter suppress-map. The prefixes
permitted by this route-map are suppressed.
The syntax is:
aggregate-address <aggregate address> <subnet mask> suppress-map <route-map-name>

Suppress-Map Lab:

R1 Basic Configuration
Router(config)#hostname R1
R1(config)#interface e0/0
R1(config-if)#ip add 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#interface loopback1
R1(config-if)#ip add 172.16.1.1 255.255.255.0
R1(config)#interface loopback2
R1(config-if)#ip add 172.16.2.1 255.255.255.0
R1(config)#interface loopback3
R1(config-if)#ip add 172.16.3.1 255.255.255.0
R1(config)#interface loopback4
R1(config-if)#ip add 172.16.4.1 255.255.255.0

R2 Basic Configuration
Router(config)#hostname R2
R2(config)#interface e0/0
R2(config-if)#ip add 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

1 | P a g e Created by Ahmad Ali E-Mail: ahmadalimsc@gmail.com , Mobile: 056 430 3717


R1 BGP Configuration
R1(config)#router bgp 1
R1(config-router)#neighbor 192.168.12.2 remote-as 2
R1(config-router)#network 172.16.1.0 mask 255.255.255.0
R1(config-router)#network 172.16.2.0 mask 255.255.255.0
R1(config-router)#network 172.16.3.0 mask 255.255.255.0
R1(config-router)#network 172.16.4.0 mask 255.255.255.0

R2 BGP Configuration
R2(config)#router bgp 2
R2(config-router)#neighbor 192.168.12.1 remote-as 1

2 | P a g e Created by Ahmad Ali E-Mail: ahmadalimsc@gmail.com , Mobile: 056 430 3717


R1 Suppress Map Configuration
R1(config)#access-list 1 permit 172.16.1.0 0.0.0.255
R1(config)#access-list 1 permit 172.16.2.0 0.0.0.255
R1(config)#route-map BLOCK permit 10
R1(config-route-map)#match ip address 1
R1(config-route-map)#exit
R1(config)#Router bgp 1
R1(config-router)# aggregate-address 172.16.0.0 255.255.248.0 suppress-map BLOCK

3 | P a g e Created by Ahmad Ali E-Mail: ahmadalimsc@gmail.com , Mobile: 056 430 3717

You might also like