You are on page 1of 3

============================================

Failover
============================================

Terminology

- Active - The Forwarding Box


- Standby - The Hot Spare

- Primary - (Priority / Name)


- Secondary - (Priority / Name)

- Stateless Failover - The connection Table is not replicated


- Statefull Failover - The connection Table is replicated allowing existing
connections to continue

- Failover LAN Interface - Used for Config Replication (Req.) & Heartbeat
- Failover Link Interface - Used for Connection Replication. Could be the same
interface as the Failover LAN Interface.

============================================
Multi-Context with Active-Active Failover
============================================

Configure the first box for Multi-context

Interface E 0
no shut
Interface E 1
no shut
Interface E 2
no shut
!
context SALES
allocate-interface E0
allocate-interface E1
config-url flash:SALES.cfg
!
context MARK
allocate-interface E0
allocate-interface E2
config-url flash:MARK.cfg

Configure SALES

Interface E0
nameif Outside
ip address 192.1.100.11 255.255.255.0 standby 192.1.100.12
!
Interface E1
nameif Inside
ip address 10.40.40.11 255.255.255.0 standby 10.40.40.12
!
route out 0 0 192.1.100.3
!
object network POOL-A
range 192.1.100.51 192.1.100.100
object network INS-NET
subnet 10.40.40.0 255.255.255.0
nat (inside,outside) dynamic POOL-A

Configure MARK

changeto context MARK


!
Interface E0
nameif Outside
ip address 192.1.100.21 255.255.255.0 standby 192.1.100.22
!
Interface E2
nameif Inside
ip address 10.50.50.21 255.255.255.0 standby 10.50.50.22
!
route out 0 0 192.1.100.3
!
object network POOL-A
range 192.1.100.151 192.1.100.200
object network INS-NET
subnet 10.50.50.0 255.255.255.0
nat (inside,outside) dynamic POOL-A

Failover Bootstrap Commands on the First Box

Interface E3
no shut
!
failover lan interface FC E3
failover interface ip FC 10.100.100.1 255.255.255.0 standby 10.100.100.2
failover lan unit primary
failover key cisco123
!

! Configure the Failover Link and Failover Group Configuration on the first box

failover link FC E3
!
failover group 1
primary
preempt
!
failover group 2
secondary
preempt
!
context SALES
join-failover-group 1
!
context MARK
join-failover-group 2
!
failover

Failover Bootstrap Commands on the Second Box

Interface E3
no shut
!
failover lan interface FC E3
failover interface ip FC 10.100.100.1 255.255.255.0 standby 10.100.100.2
failover lan unit secondary
failover key cisco123
failover

You might also like