You are on page 1of 14

AutoCAD

Osnovna navodila za uporabo


Andrej Vitek,
@iga Turk

Kazalo:

I. Splo{no o programu ...................................................................................................................................... 2


A. Vsebina ...................................................................................................................................................... 2
B. O programu ............................................................................................................................................... 2
C. Osnovni koncepti ...................................................................................................................................... 3
D. Orodjarna................................................................................................................................................... 3
E. Meniji.......................................................................................................................................................... 4
F. Nekaj nasvetov........................................................................................................................................... 4
G. Meniji programa ........................................................................................................................................ 5
II. Risanje in popravljnanje v ravnini .................................................................................................................. 6
A. Vsebina ...................................................................................................................................................... 6
B. Risanje tlorisa ............................................................................................................................................ 6
C. Nastavitve in pomagala .............................................................................................................................6
D. Koordinate ................................................................................................................................................. 7
E. Sloji ............................................................................................................................................................ 7
F. Enostavno modeliranje (risanje) in osnovni risarski pripomo~ki ..............................................................7
G. Popravljanje risbe ...................................................................................................................................... 8
III. Bloki, lastnosti, kotiranje, tiskanje ................................................................................................................ 9
A. Vsebina ...................................................................................................................................................... 9
B. Lastnosti gradnikov ................................................................................................................................... 9
C. Bloki........................................................................................................................................................... 9
D. Kotiranje..................................................................................................................................................... 9
E. Uporabni{ki koordinatni sistemi (UCS) ................................................................................................... 10
F. Organizacija risb na papirju .................................................................................................................... 10
G. Tiskanje in vnos slike v druge programe ...............................................................................................10
IV. Risanje v prostoru ...................................................................................................................................... 12
A. Vsebina .................................................................................................................................................... 12
B. Enostavno dvigovanje iz 2D .................................................................................................................... 12
C. Dolo~anje pogledov in projekcij ............................................................................................................. 12
D. Skrivanje nevidnih delov ......................................................................................................................... 12
E. Modeliranje teles...................................................................................................................................... 13

osnutek z dne 31.05.95


AutoCAD 1
I. Splo{no o programu

A. Vsebina

- spoznavanje osnovnih konceptov programa AutoCAD

B. O programu

AutoCAD je program za ra~unalni{ko podprto modeliranje (na~rtovanje). Z njim lahko med drugim:
- ri{emo “tehni~ne” risbe: ilustracije, diagrame, prosojnice, ..., na~rte;
- modeliramo dvo- ali trirazse`ne objekte; na~rt je pri tem prikaz modela.
V primerjavi z ro~nim na~inom risanja ima delo z AutoCADom naslednje prednosti:
- namesto v glavi imamo tu model objekta v ra~unalni{ki obliki; tak model lahko uporabimo tudi v
druga~ne namene kot je le risanje na~rtov;
- zapis modela je digitalen, zato je vedno to~en in zaseda bistveno manj prostora;
- s pripomo~ki AutoCADa z lahkoto obvladujemo kompleksnost modela: saj je preklop med pogledom
na detajl ter celoto hipen;
- model lahko prenesemo v (nekatere) programe za analizo konstrukcij in si z njim pomagamo pri
pripravi podatkov za analizo; pri tem je manj mo`nosti za napako;
- popravljanje (risbe, modela) je enostavno, zato si la`e privo{~imo prikaz in analizo variant;
- poenostavljena je izdelava na~rtov tipskih objektov;
- AutoCAD je mogo~e {iriti in povezovati tudi z drugimi programi (podatkovne zbirke, programi za
razna specializirana opravila).
Seveda pa je za obvladovanje vsega na{tetega potrebno precej ve~ znanja in s tem tudi ~asa za u~enje kot
pri ro~nem risanju. Program pa je vseeno tako zasnovan, da lahko `e v nekaj urah u~enja spoznamo
bistvene koncepte in za~nemo z njim produktivno risati.

Slika 1. AutoCADovo okno.

AutoCAD 2
C. Osnovni koncepti

Spoznali se bomo z verzijo AutoCADa, ki te~e pod MS-Windows. Obstajajo tudi verzije za MS-DOS ter
operacijske sisteme delovnih postaj (Unix, VMS). Vse verzije so si med seboj dovolj podobne, da ni
potrebno opisovati vsake posebej.
Program obi~ajno po`enemo z dvojnim klikom ikone na levi. DOSovsko verzijo po`enemo z
ukazom ACADRxx , kjer je Rxx {tevilka verzije (trenutno 12). Program je za{~iten proti
kopiranju s posebnim klju~em.
AutoCADovo okno (na sliki 1) sestavljajo:
• risalno podro~je na sredi,
• vise~i menuji na vrhu,
• statusna vrstica pod njimi,
• ukazno podro~je spodaj
• orodjarna z zbirko ikon najpogosteje rabljenega risalnega orodja.
V risalnem podro~ju ri{emo oz. modeliramo. Kri` s kvadratkom v njem ka`e trenutni polo`aj in ga
premikamo z mi{ko. Pri modeliranju si pomagamo z ukazi, zbranimi v menujih ali v orodjarni. Ukaze oz.
posamezne dele ukazov lahko tudi tipkamo (ali vse to kombiniramo). Zapisnik dela je prikazan v ukaznem
podro~ju (ali, na `eljo, v lo~enem oknu).
V statusni vrstici so prikazani (z leve proti desni): barva, sloj (gumb za definicijo in okno za izbiro), gumbi
oz. ikone za izbiro pravokotnega risanja in oprijemanja, za vklop orodjarne ter za odprtje nove datoteke z
modelom, koordinati trenutnega polo`aja (prikaz krmilimo s tipko F6) ter gumbi za shranitev risbe, tiskanje
na papir, spremembo pove~ave in podobno. V orodjarni so zbrani gumbi, s katerimi spro`imo
najpogostej{e ukaze. Sestav in pomen gumbov v statusni vrstici ali orodjarni lahko spreminjamo tako, da
na gumbu kliknemo z mi{kinim desnim gumbom, nato pa na gumb postavimo bodisi znak (Character )
ali ikono (Image ) ter povemo AutoCADov ukaz, ki ga gumb izvede.
Leva tipka mi{i je tipka za izbiro iz menuja in dolo~itev polo`aja. Vsaka izbira polo`aja na zaslonu pusti
sled (kri`ec), ki nam je lahko kasneje v pomo~.
Desna tipka mi{i pomeni isto kot Enter . Njen pomen je odvisen od trenutnega stanja: v ukazu, ki
zahteva niz polo`ajev z njo zaklju~imo posamezne dele ukazov (npr. izbiro) ali ukaz sam (npr. risanje
~rtovja); ko {e nismo za~eli nobenega ukaza, lahko z njo ponovimo zadnji ukaz. Ukaz opustimo s tipko
Ctrl-C oz. gumbom ^C v orodjarni.

D. Orodjarna
undo copylink
redraw line
pline arc
circle ellipse
polygon point
dtext ddim
move copy
erase scale
rotate change
mirror break
extend stretch
trim fillet
chamfer endpoint
align intersection
midpoint center
quadrant nearest
perpendicular tangent
^C^C pedit

AutoCAD 3
Slika2: Obi~ajna orodjarna.

E. Meniji

V menuju File so zbrani ukazi za delo z modelnimi datotekami: odpiranje (New , Open ), shranjevanje
(Save , Save As ), risanje na papir (Print/Plot ), uvoz/izvoz modelov v obliki drugih programov
(Import/Export ), konfiguriranje (Preferences , Configure ) in zaklju~ek dela (Exit AutoCAD ).
V menuju Edit so zbrani pomo`ni ukazi za delo z modelom: preklic ukazov ali preklica (Undo , Redo ),
prenos slike v drug program preko bele`ke (Copy Image , Copy Vectors ,...) ali slike oz. ukaza od
drugod (Paste , Paste Command ).
Z menujem View krmilimo prikaz modela: prikaz osve`imo (Redraw ), spremenimo pove~avo (Zoom ),
urejamo prikaz modela na papirju (Tilemode , Toggle Viewport , Model Space , Paper Space ,
Mview ) ali izberemo projekcijo za prikaz 3D modela (Set View ).
Ukaz Assist vsebuje risarske pripomo~ke: prekinitev ukaza (Cancel , pomeni isto kot Ctrl-C ),
uporabo oprijemkov gradnikov (Object Snap ), zaprtje ~rtovja ali zaporedja ~rt (Close ).
Ukazi za modeliranje so zbrani v menuju Draw. Gradniki modela so ~rte (Line ), kro`ni loki (Arc ), krogi
(Circle ), pravokotniki (Rectangle ), pravilni ve~kotniki (Polygon ), ~rtovja (Pline ) sestavljena iz
daljic in kro`nih lokov, itd. Z Insert vstavimo blok, s Hatch {rafiramo, s Text ri{emo besedilo in
dolo~amo njegov izgled, z Dimensions pa kotiramo.
Ukazi menuja Construct iz izbranih obstoje~ih gradnikov sestavijo nov del modela: Array jih razmno`i
po polkrogih ali ogli{~ih paralelograma, Copy doda njihovo kopijo, Mirror jih zrcali; Chamfer prire`e,
Fillet pa zaokro`i vogal; Block sestavi blok iz izbranih gradnikov.
Izbrane gradnike v modelu popravljamo z ukazi menuja Modify : z Entity pregledujemo in
spreminjamo njihove parametre, z Erase jih bri{emo, z Move , Rotate , Scale in Stretch jih
premikamo, sukamo, pove~ujemo in jim prestavljamo ogli{~a; Explode blok ali ~rtovje razstavi v
gradnike, ki ga sestavljajo; s Polyline Edit popravljamo ~rtovje, z Edit Dimensions pa kotnice.
Z ukazi menuja Settings nastavljamo parametre tvorbe gradnikov: z Drawing Aids vklju~imo
zaokro`anje koordinat in mre`o ter nastavljamo njune parametre; vklju~imo lahko tudi pravokotno
risanje; z Layer Control upravljamo delo s sloji; z Entity Modes nastavljamo parametre risanja
gradnikov; z Dimension Style oblikujemo izgled kotnic; z Drawing Limits pa dolo~imo meje
koordinat v modelu. Z UCS vpeljemo delovni koordinatni sistem pri risanju v 3D.
Prikaz 3D modela urejamo z menujem Render: s Hide iz prikaza trirazse`nega modela odstranimo skrite
robove; s Shade odstranimo skrite ploskve; z Render model realisti~no prika`emo; pri tem se upo{tevajo
tudi svetlobna telesa, ki jih postavljamo z Lights in materiali, ki jih opi{emo s Finishes .
Z ukazi menuja Model modeliramo v prostoru (AME): z Extrude raztegnemo like v prostor, z
Revolve lik zavrtimo v vrtenino, s Solidify 2½D gradnik pretvorimo v 3D, s Primitives v model
vstavimo enega od 3D gradnikov. Z Union , Subtract in Intersect operiramo s 3D gradniki:
dolo~imo unijo, razliko oz. presek. Z Modify 3D gradnike spreminjamo (lo~ujemo, prire`emo, zaoblimo,
odre`emo). S Setup izberemo na~in trirazse`ne predstavitve (s ploskvami oz. robovi), z Inquiry pa
izvemo povr{ino, maso in geometrijske karakteristike ali prekrivanje 3D gradnikov.

F. Nekaj nasvetov.

Osnovni vmesnik programa AutoCAD je preko ukaznih vrstic. Izbira v menijih samo dodaja ukaze tja.
Ukazno vrstico ka`e pazljivo brati.
Za razliko od nekaterih drugih programov, praviloma najprej izberemo ukaz in {ele po tem poka`emo, kaj
bomo s tem ukazom naredili. Primer: najprej ERASE, po tem kaj bomo zbrisali.
Va`ne tipke so:
F1 pomo~
F6 preklop izpisovanja koordinat
AutoCAD 4
F7 preklop risanja mre`e (GRID)
F8 preklop pravokotnega na~ina dela
F9 preklop magnetnih to~k

G. Meniji programa

Va`nej{i ukazi so sivi.


File Edit View Assist Draw Construc Modify Settings Render Model Help
New... Undo Redraw Cancel t
Array Entity Drawing Render Extrude Contents
Line
Open... Redo Redraw Object Array 3D Erase aids...
Layer Shade Revolve Search
Arc
Save... Copy all filters
Object Copy control..
Object Hide Solidify How to
Zoom Circle Break
Save image
Copy Pan snap
Close Mirror Extend snap...
Entity Views... Primitive use Help
About
Point
as... vectors modes... s AutoCAD
Save DIB Copy Tilemode Inquiry Polyline Mirror 3D Trim Point Lights... Union
Recover.. embedlink
Copy Toggle Calculato Donut Chamfer Align style...
Dimension Scenes... Subtract
. viewport r style...
Print/Plo Paste Model Ellipse Fillet Move Units Finishes. Intersect
t... Paste space
Paper Divide Rotate control.. ..
Preferenc
ASE Polygon UCS Modify
Import/Ex command
Text space Measure Rotate 3D Selection es...
Statistic
Mview Rectangle Setup
port window Insert... Offset Scale settings.
Grips... s...
Xref DDE Set view Files Inquiry
Preferenc Select Layout 3D Block Stretch Drawing Unload Display
es... surfaces limits render
Configure Hatch Change Menu RenderMan Utility
Compile.. Text... Explode bitmaps ...
.
Utilities Dimension Polyline
...
Applicati s edit
Edit
ons... dimension
Exit
AutoCAD
Find
file...

AutoCAD 5
II.Risanje in popravljnanje v ravnini

A. Vsebina

- spoznavanje osnovnih konceptov modeliranja v ravnini s programom AutoCAD ob risanju tlorisa na


sliki 1.

Slika 1: Enostaven tloris.

B. Risanje tlorisa

- dolo~imo risalno podro~je;


- dolo~imo risalne pripomo~ke;
- organiziramo plasti;
- nari{emo stene s ~rtovji ali ~rtami; popravimo napake z oprimki;
- nari{emo okna in balkonsko steno;
- nari{emo vhodna vrata s ~rtovjem iz ~rt in loka (risanje loka z za~etno smerjo);
- preri{emo vrata drugam, npr. z oprimki;
- balkonska vrata nari{emo kot pomanj{ano kopijo vhodnih;
- {rafiramo stene;
- opremimo z besedilom in kotnicami.

C. Nastavitve in pomagala

Nastavitve Z ukazom Settings|Drawing limits dolo~imo koordinatni obseg modela; obi~ajno nekaj
ve~ kot so dimenzije modeliranega objekta. Podamo ga v modelnih enotah, ki jih pri modeliranju izklju~no
uporabljamo. Po dolo~itvi obsega ostane pove~ava prikaza na zaslonu nespremenjena; prikazano je
podro~je med to~kama 0,0 in (odvisno od zaslona) 12,9.
Ker je z mi{ko obi~ajno te`ko zadeti to~no `eljeno koordinato ali dimenzijo, lahko z ukazom
Settings|Drawing Aids vklju~imo risarsko mre`o (Grid ) in zaokro`evanje koordinat (Snap ). V
ustreznem okencu navedemo, na koliko enot naj bodo koordinate zaokro`ene oz. kako razmaknjene naj
bodo to~ke pomo`ne mre`e. Mre`a se nari{e le na zaslonu kot mre`a pikic; ~e je pregosta, je AutoCAD
ne ri{e. ^e bo slika sestavljena prete`no iz vodoravnic in navpi~nic, lahko risanje omejimo na pravokotne

AutoCAD 6
smeri z vklopom Ortho . Zaokro`anje koordinat in risanje pravokotnic lahko preklopimo tudi z gumboma
v statusni vrstici (S in O).

D. Koordinate

Prikaz koordinat v okencu krmilimo s tipko F6: obi~ajno sta tam prikazani koordinati trenutnega
polo`aja, enkraten pritisk F6 preklopi v prikaz zadnjega izbranega polo`aja, ponoven pritisk pa v prikaz
relativnega polarnega prikaza. Pri slednjem med risanjem npr. ~rt vidimo dol`ino trenutnega odseka in
njen naklon.
Koordinate obi~ajno podajamo z mi{ko, lahko pa jih tudi natipkamo (pravokotne (x,y), polarne (r<ϕ);
absolutne, relativne (@x,y; @r<ϕ). Pri podajanju koordinat lahko s filtri (.x, .y, .z, .xy, .xz, .yz) koordinato
sestavimo iz koordinat ve~ pokazanih to~k. Prav tako lahko enostavno podamo karakteristi~ne to~ke
gradnikov (kraji{~, sredine, prese~i{~ ipd): z ukazom Assist|Object snap povemo, katere
karakteristi~ne to~ke naj se podana oprime.
Z ukazom Assist|Undo prekli~emo nazadnje opravljene ukaze v obratnem vrstnem redu, z ukazom
Redo pa zadnjega od njih spet izvr{imo.
Za risanje detajlov ali generalni pregled lahko z ukazom View|Zoom spremenimo pove~avo. Med drugim
lahko izberemo prikaz vsega (All ) predhodno pove~avo (Previous ), ali pa poka`emo diagonalni ogli{~i
novega obsega slike.

E. Sloji

Sloji (risalne ravnine) nam omogo~ajo enostavno kombiniranje ve~ prikazov enega modela. Obi~ajno
modeliramo v sloju 0; dodatno opremo modela (npr. dimenzije, dopolnilne na~rte - instalacije, notranja
oprema, materiali ipd; na po~asnej{ih ra~unalnikih v poseben sloj vstavimo tudi {rafure) pa ri{emo v
dodatne sloje - na “prosojnice” nad osnovnim modelom.
Delu s sloji je namenjeno dialogno okno, ki ga odpremo s klikom na gumbu Layer oz. z ukazom
Settings|Layer Control . Nov sloj najprej poimenujemo v ustreznem okencu in ga odpremo z
gumbom New . Obstoje~ sloj izberemo s klikom na njegovem imenu v spisku slojev. Z gumbom Current
izbrani sloj izberemo za trenutni sloj. Risanje vedno te~e v trenutnem sloju. Izbranim slojem lahko z
gumboma Set Color in Set Ltype dolo~imo barvo in tip ~rte. Z gumboma On in Off vklju~imo oz.
izklju~imo prikaz posameznega sloja; izklju~enih slojev AutoCAD ne ri{e ne na zaslon ne na papir. ^e
izklju~imo trenutni sloj, lahko vanj {e vedno ri{emo, a narisanega ne vidimo. Z gumboma Thaw in
Freeze “odtajamo” oz. “zamrznemo” prikaz izbranih slojev; zamrznjenih slojev AutoCAD ne ri{e ne na
sliko ne na papir, niti jih ne upo{teva pri prera~unavanju slike. Trenutnega sloja ne moremo zamrzniti.
Zamrzovanje uporabimo, kadar delamo prete`no v enem naboru slojev z mnogo spremembami pove~av
oz. regeneracijami slike; izklju~evanje pa, kopri delu z mnogo sloji brez sprememb pove~ave oz.
regeneracije slike prehajamo iz enega sloja v drugega. Z gumboma Unlock in Lock izbrane sloje
napravimo aktivne oz. neaktivne; gradnike neaktivnega sloja AutoCAD sicer nari{e, ne pusti pa nam jih
spremeniti. Trenutni sloj lahko deaktiviramo, v njem pa {e vedno lahko tvorimo nove gradnike.

F. Enostavno modeliranje (risanje) in


osnovni risarski pripomo~ki

Z ukazi menuja Draw ri{emo daljice, kro`nice, kro`ne loke, ~rtovja (zaporedja daljic in kro`nih lokov) in
podobne gradnike. Vsi ti ukazi so zbrani tudi v orodjarni. Risanje zaporedja daljic
(Draw|Line|Segments ) kon~amo s tipko Enter (oz. desno tipko mi{i), za zaprtje (daljico od zadnje
do za~etne to~ke) pa uporabimo ukaz Assist|Close . Lok lahko speljemo skozi tri to~ke, lahko pa ga
podamo tudi na ve~ drugih na~inov; ~e podatki dolo~ajo dva loka, AutoCAD nari{e tistega, ki pelje
protiurno; smisel lahko spremenimo z dolo~itvijo tangente v za~etni to~ki (podukaz Direction ). Pri
risanju ~rtovja lahko z Arc oz. Line preklopimo v risanje zaporedja lokov oz. daljic; z Width oz
Halfwidth pa navedemo debelino ~rte. Uporaben ukaz za risanje npr. sten je Draw|Line|Double
lines .

AutoCAD 7
Zadnji ukaz ponovimo s pritiskom desne tipke mi{i, presledka ali tipke Enter . Izvr{evanje izbranega
ukaza prekinemo s tipko Ctrl-C .

G. Popravljanje risbe

Gradnike bri{emo z ukazom Modify|Erase in izbiro `eljenih gradnikov.


Na~in izbire gradnikov je enak pri vseh ukazih: gradnik poka`emo s tem da z malim kvadratkom kliknemo
na eni od ~rt, ki ga sestavljajo. ^e ob kliku nismo izbrali nobenega gradnika, lahko podamo {e drugo
ogli{~e pravokotnika (polnega z vle~enjem v desno, ~rtkanega z vle~njem v levo); s polnim pravokotnikom
izberemo tiste gradnike, ki jih pravokotnik povsem objame; s ~rtkanim pa tiste, ki jih pravokotnik vsaj
deloma prekriva. ^e izberemo preve~ gradnikov, jih iz mno`ice izbranih lahko odstranimo: natipkati
moramo podukaz Remove , nato pa z izbiranjem vse odve~ne gradnike odstraniti iz mno`ice; dodajanje v
mno`ico izbranih gradnikov spet vklopimo s podukazom Add . S podukazom Last izberemo zadnji
narisani gradnik, s Previous pa ponovno izberemo zadnje predhodno izbrane gradnike.
Z ukazi menuja Modify lahko gradnike premikamo (Move ), sukamo (Rotate ), pove~ujemo (Scale ), jih
raztegujemo (premaknemo posamezne dele in raztegnemo povezave do njih) (Stretch ), razcepimo na
sestavne dele (Explode ) itd. Pri teh operacijah najprej izberemo gradnike (lahko jih izberemo celo pred
izbiro ukaza), nato podamo referen~no to~ko (npr. sredi{~e zasuka), nato pa {e preostale potrebne
podatke (npr. kot zasuka). Vse podatke lahko podamo bodisi z mi{ko ali pa jih natipkamo. Z ukazi
menuja Construct gradnike kopiramo (Copy ), razmno`imo po daljici, polju ali loku (Array ), zrcalimo
(Mirror ), jim prire`emo ali zaoblimo vogale (Chamfer , Fillet ), ali sestavimo v blok (Block ).
Z ukazom Trim gradnike obrezujemo na druge gradnike, za Extend pa podalj{ujemo do drugih
gradnikov. Pri obeh ukazih najprej poka`emo pomo`ne gradnike, po tem pa gradnike, ki jih `elimo
spremeniti.
Gradnike lahko raztegujemo, premikamo, sukamo in zrcalimo tudi z uporabo oprimkov (gripov). Oprimke,
to je karakteristi~ne to~ke gradnika, vklju~imo z izbiro gradnika ko nismo pred tem izbrali nobenega
ukaza; Prika`ejo se kot modri kvadratki; vsaka vrsta gradnika ima svoj nabor oprimkov. Ko z izbiro
aktiviramo enega od gradnikov (postane rde~), vklju~imo popravljanje: z desno tipko mi{i lahko potem
izbiramo med raztegovanjem (**STRETCH** ), premikanjem (**MOVE** ), sukanjem (**ROTATE** ),
pove~evanjem (**SCALE** ) in zrcaljenjem (**MIRROR** ). Vse operacije lahko opravimo na originalu
ali kopiji (podukaz Copy ). Referen~na to~ka operacije je aktivni oprimek, razen ~e s podukazom Base
point zahtevamo druga~e.
Zaklju~eno podro~je lahko z ukazom Draw|Hatch po{rafiramo. Najprej moramo s Hatch Options
oblikovati {rafuro: izbrati vzorec (Pattern ) {rafure, povedati pove~avo in zasuk (Scale in Angle );
primerno vrednost pove~ave moramo obi~ajno dolo~iti z eksperimentiranjem. Nato poka`emo bodisi
gradnike, ki sestavljajo mejo podro~ja (Select objects ) ali pa to~ko nekje v notranjosti podro~ja
(Pick points ).
Sliko lahko opremimo z besedilom (Draw|Text ). Najprej podamo stil besedila (...|Set Style ): pisavo,
vi{ino (~e jo pustimo enako 0, jo podamo kasneje ob risanju), razmerje med {irino in vi{ino, nagib ~rk,
poravnavo in podobno. Podani stil ostane v veljavi do spremembe. Obstoje~ (prej podan) stil besedila
izberemo z gumbom Text Style v dialognem oknu Settings|Entity Modes . Izbrani stil AutoCAD
uporabi pri vsakem risanju besedil (tudi npr. pri kotiranju). Po dolo~itvi stila lahko besedilo ri{emo z
ukazom ...|Dynamic ; podamo {e polo`aj in zasuk (neobvezno tudi stil, poravnavo in vi{ino), nato pa
nekaj vrstic besedila; vnos besedila zaklju~imo s prazno vrstico (dvojnim Enter ).

AutoCAD 8
III.Bloki, lastnosti, kotiranje, tiskanje

A. Vsebina

- spreminjanje lastnosti gradnikov;


- zahtevnej{i koncepti modeliranja: bloki, kotiranje;
- risanje na papir.

B. Lastnosti gradnikov

Lastnosti gradnikov so barva, tip ~rte, risalni sloj ter dvig in vi{ina (za risanje v 2½ dimenzijah).
Nastavljamo jih s Settings|Entity Modes , spreminjamo pa z Modify|Entity (posameznemu
gradniku) ali z Modify|Change|Properties (skupini gradnikov). Debelino ~rte lahko povemo le s
podukazoma Width in Halfwidth pri risanju ~rtovja. Navadne ~rte (dobljene pri risanju ~rt, lokov,
krogov, pravokotnikov, ve~kotnikov ipd.) so debeline 0, tj. najtanj{e, kar lahko risalna naprava nari{e.
Barvo gradnika lahko dolo~a tudi sloj (“barva” BYLAYER ) ali blok (BYBLOCK ), podobno tudi tip ~rte. ^e
barve posebej ne spreminjamo, barvo dolo~a sloj (ri{emo z barvo BYLAYER ); z izbiro razli~nih barv po
slojih lahko tako lo~imo, kaj sodi v posamezen sloj.
Obi~ajno AutoCAD pozna le polno ~rto, dodatne tipe (pik~asto, ~rtkano, ~rtka-pikasto, ~rtka-pika-pikasto
ipd.) moramo posebej nalo`iti. V menujih ni ustreznega ukaza za nalaganje tipov ~rt; razne tipe nalo`imo
z natipkanim ukazom LINETYPE LOAD * ACAD .

C. Bloki

Kadar se posamezne skupine gradnikov v sliki velikokrat ponove (npr. simboli za vodovodne pipe, ventile,
stikala, stole, ipd.) jih lahko razmno`imo s kopiranjem, delo pa je la`je, ~e z njimi definiramo bloke.
Blok definiramo tako, da najprej nari{emo gradnike, ki ga sestavljajo. Potem gradnike vstavimo v blok z
ukazom Construct|Block ; navedemo {e ime in referen~no to~ko bloka. Blok tedaj postane (neviden)
del modela. Z Draw|Insert... blok vstavljamo v risbo. Blok lahko kadarkoli redefiniramo: nari{emo
ga na novo (vstavimo razgrajenega in ga popravimo) in definiramo z istim imenom kot prej. Ker lahko
pove~avo in zasuk podamo ob vstavljanju bloka, blok obi~ajno tvorimo v enotski velikosti (npr. vrata {irine
1), pravo velikost pa povemo kot pove~avo ob vstavljanju; temu primerno izberemo tudi referen~no to~ko.
Blok vstavimo v model z ukazom Draw|Insert . Ime bloka izberemo iz spiska, ki ga dobimo z gumbom
Block ; z gumbom File drugo datoteko z modelom celo vstavimo kot blok. Podamo {e polo`aj
referen~ne to~ke, pove~avi v smereh x in y ter zasuk. ^e tako zahtevamo, te podatke povemo v dialognem
oknu ukaza Draw|Insert , sicer pa z mi{ko. Z Explode zahtevamo, da AutoCAD blok ob vstavljanju
razgradi v gradnike.
Blok lahko opremimo tudi z dodatnimi podatki. Temu slu`i menu Draw|Text|Attributes . Z
...|Define v blok vri{emo posebno besedilo; pravo vrednost tega besedila lahko zahteva {ele AutoCAD
ob vstavljanju tega bloka. Kosovnico (izpis teh podatkov po vseh blokih) dobimo z ...|Extract .

D. Kotiranje.

Dimenzije obi~ajno ri{emo v poseben sloj. Za risanje besedil AutoCAD uporabi trenutni stil besedila.
Pred kotiranjem lahko z Settings|Dimension Style dolo~imo stil kotiranja: barvo, velikost, polo`aj
in poravnavo besedila, obliko in velikost pu{~ic ipd. Na na~in kotiranja vplivamo tudi s
Settings|Units control (enote, {tevilo decimalih mest) in Draw|Text|Set style...
Kotiramo z Draw|Dimensions . Z Leader vpi{emo besedilo ob zaporedje ~rt, z Angular vpi{emo
velikost kota, z Ordinate vpi{emo koordinato x ali y to~ke, z Radial kotiramo polmer ali premer, z
Linear pa kotiramo razdaljo. Kotiramo lahko razdaljo v vodoravni smeri med pokazanima to~kama
(Horizontal ), razdaljo v navpi~ni smeri (Vertical ), razdaljo vzdol` pokazane daljice (Aligned ),
lahko pa kotiranje nadaljujemo od skupne za~etne (Baseline ) oz. kon~ne (Continue ) to~ke. Poleg
podatkov, ki dolo~ajo kotirano koli~ino, povemo {e lego kotnice in besedilo na njej (AutoCAD nam
AutoCAD 9
pripravi vrednost kotirane koli~ine). Kotiramo koli~ine med to~kami in ne gradniki; ~e `elimo, da se
kotiranje zares nana{a na to~ke gradnikov, uporabimo oprijem karakteristi~nih to~k gradnikov
(Assist|Object Snap ).

E. Uporabni{ki koordinatni sistemi (UCS)

^e nas zanimajo relativne razdalje (npr. razpostavljanje oken n centimetrov oz zidu) je prakti~no, da si
definiramo lokalni koordinatini sistem. V meniju Settings|UCS ga lahko dolo~imo tako, da podamo novo
izhodi{~e (Origin ) ali zasuk obstoje~ega sistema okrog njegove osi (Axis ). Da smo v lokalnem
kooridnatnem sistemu govori tudi XY ikona spodaj levo oz v izhodi{~u sistema (Settings|UCS|Icon ).
Nazaj na svetovni koordinatni sistem, na prej{njega ali na sistem, ki smo mu dali ime se vrnemo skozi
Settings|UCS|Presets .

F. Organizacija risb na papirju

Modeliranje te~e v modelnem prostoru. Z AutoCADom pa lahko urejamo tudi papirni prostor, tj. izris
modela na papirju. V njem lahko poleg obi~ajnih slikovnih gradnikov tvorimo {e ti. prizori{~a,
pravokotnike, ki vsebujejo (razli~ne) prikaze modela. Pri urejanju papirnega prostora lahko uporabimo
ve~ino obi~ajnih ukazov za modeliranje; upo{tevati moramo le, da je celotno prizori{~e pri tem en gradnik
papirnega prostora. Enote papirnega prostora so seveda enote na papirju (kot jih navedemo pri
File|Print/Plot ).
Z View|Tilemode vklju~imo oz. izklju~imo urejanje v na~inu, v katerem so vsa okna na zaslonu drug ob
drugem (angl. tiled). Ob vklopu se koordinatna ikona spremeni v trikotnik. Pri prvem vklopu se pove~ava,
zaokro`anje koordinat in podobne nastavitve vzamejo iz modela, jih pa lahko spreminjamo neodvisno od
njega.
Z View|Mview v papirni prostor postavimo eno (...|Create Viewport , ...|Fit Viewport ) ali ve~
(...|2 Viewports , ...|3 Viewports , ...|4 Viewports ) prizori{~. Poka`emo pravokotnik s prizori{~em
ali s Fit prizori{~a razpnemo ~ez ves zaslon. S ...|Hideplot zahtevamo, da v pokazanem prizori{~u
AutoCAD model vedno nari{e z odstranjenimi skritimi ~rtami. Z ...|Viewport OFF pokazano prizori{~e
ugasnemo (slike v njem AutoCAD ne prera~unava), z ...|Viewport ON pa spet pri`gemo.
Z View|Model Space vklju~imo urejanje modelnega prostora: v enem od prizori{~ lahko popravljamo
model ali njegov prikaz (pove~avo, prikaz slojev, ipd.), z View|Paper Space pa spet vklju~imo urejanje
papirnega prostora. Prikaz na zaslonu ostane nespremenjen. Pri vklu~enem urejanju modelnega prostora
lahko menjamo prizori{~a bodisi s klikom znotraj ustreznega pravokotnika ali pa z ukazom View|Toggle
Viewport .
Odnos med merilom v modelnem in merilom v papirnem prostoru dolo~amo z ukazom
View|Layout|MV Setup|Scale Viewports . Povemo, da N enot v papirnem prosturu ustreza M
enotam v modelnem prostoru.
Z View|Mview|Vplayer lahko v pokazanih prizori{~ih zamrznemo ali odtajamo posamezne sloje.
Podobno vlogo imata gumba Thw in Frz pri Cur VP oz. New VP v dialognem oknu za upravljanje slojev
(gumb Layer v statusni vrstici ali Settings|Layer Control ).

G. Tiskanje in vnos slike v druge programe

Z ukazom File|Print/Plot risbo natisnemo na papir. Tiskanje podrobneje opi{emo z dialogom. Z


gumbom Device and Default Selection izberemo risalno napravo; z izbirami v Additional
parameters povemo, kateri del modela `elimo narisati, ali `elimo pri tem skriti ~rte in ali `elimo izris
na datoteko; z izbiro v Paper Size and Orientation navedemo enote, ki jih uporabljamo na
papirju in njegovo velikost; s Scale, Rotation and Origin dolo~imo zasuk in polo`aj slike na
papirju ter merilo (zvezo med enotami v modelu in na papirju); s Plot Preview pa pregledamo, kako
bo izgledala na{a slika na papirju.
Le malo drugih programov zna delati s slikami v AutoCADovem internem formatu (DWG); zato lahko s
File|Import/Export preberemo ali zapi{emo sliko v tuje obliki. Za prenos modela uporabimo
datoteko formata DXF (...|DXFOut , npr. za prenos v AutoCAD na druga~nem ra~unalniku); ali pa
nevtralno obliko IGES (za prenos v drug modelirnik). Za prenos slike v drug program uporabimo zapis
AutoCAD 10
slike v Postscriptu (...|Postscript out ); pri verziji za Windows je sliko najudobneje prena{ati s
pomo~jo bele`ke (clipboarda) z ukazom Edit|Copy Vectors ali pa preko Windows metadatoteke (z
...|WMF out ). V~asih si lahko pomagamo tudi z izrisom v obliki HPGL (Print/Plot v obliki za risalnik
Hewlett-Packard).

AutoCAD 11
IV.Risanje v prostoru

A. Vsebina
- enostavno 2D risanje;
- dolo~anje projekcije;
- skrivanje nevidnih delov.

B. Enostavno dvigovanje iz 2D

Z dolo~itvijo dviga in vi{ine (parametrov Elevation in Thickness v dialogu Settings|Entity


Modes ) z risanjem ~rt v resnici ri{emo na risalno ravnino pravokotne ploskve; parametra povesta za
koliko je ploskev dvignjena nad risalno ravnino in kako visoka je. Z daljico tako nari{emo pravokotnik, s
krogom pa valj (zaprt zgoraj in spodaj). ^rtovje nari{e ograjo, ki pa ne zgoraj ne spodaj ni zaprta.
Vi{ino gradnikov lahko spremenimo z Modify|Entity , dvig pa s premikom (Modify|Move 0,0,z).
V meniju Draw|3D surfaces je nekaj 3D elementov.

C. Dolo~anje pogledov in projekcij

Pri delu v prostoru je koristno, da imamo na zaslonu hkrati ve~ oken skozi katera opazujemo na{ model.
^e je vklopljen Veiw|Tilemode, si organizacijo zaslonskih oken izbereno z View|Layout|Tiled
Viewports.
V vsakem od teh oken z ukazom View|Set View ali Settings|UCS dolo~imo projekcijo pri prikazu
prostorskega modela Poleg tlorisa AutoCAD omogo~a uporabo tako aksonometrije kot perspektive.
S podukazi ukaza View|Set View|Dview dinami~no podajamo perspektivo - podatke “kamere” s
kakr{no “snemamo” model. Pred podatki same kamere izberemo posamezne gradnike modela, ki
nastopajo v dinami~nem prikazu projekcije na zaslonu. S podukazom CAmera sukamo smer kamere glede
na cilj (opazovani objekt). Smer podamo s parom kotov, ki ju podamo bodisi z mi{ko ali tipkanjem; med
podajanjem odklona in naklona preklapljamo s Toggle . Na podoben na~in s podukazom TArget
sukamo smer cilja glede na kamero. S podukazom Distance kamero bli`amo ali oddaljujemo od cilja, z
Zoom pa menjamo gori{~nico objektiva in s tem zorni kot; obi~ajni objektiv ima gori{~nico 50mm, manj{a
ko je gori{~nica, {ir{i je zorni kot. S PAn premaknemo sliko modela, s TWist pa jo zasukamo okrog osi
gledanja. S CLip lahko iz slike odstranimo objekte, ki so kameri preblizu ali predale~, s Hide pa v
trenutno izbranem prikazu skrijemo ~rte. Off izklju~i perspektivo (spet jo vklju~i Distance ). Podajanje
zaklju~imo z eXit . V perspektivnem prikazu nekateri ukazi niso dovoljeni.
View|Set View |Plan View dolo~a tlorise v svetovnem (World ) ali enem od delovnih (UCS,
named ) koordinatnih sistemov.
Z View|Set View |Viewpoint podamo smer gledanja pri aksonometriji. S ...|Set Vpoint podamo
koordinate gledi{~a ali pa s podukazom Rotation odklon (kot od osi x v ravnini x,y) in naklon (na
ravnino x,y) smeri gledanja. S ...|Presets podamo odklon in naklon s pomo~jo dialognega okna, z
...|Axes pa s pomo~jo to~ke na krogli, raztegnjeni v krog ravnini (notranji krog ozna~uje ekvator, zunanji
pa ju`ni pol krogle).
Ukaz View|Zoom|Previous izbere prehodno projekcijo; z ukazom View|Set view|Named View pa
lahko trenutno projekcijo shranimo ali pa spet uporabimo.

D. Skrivanje nevidnih delov

Z ukazom Render|Hide skrijemo nevidne robove, z ukazom Render|Shade pa nevidne ploskve


modela. Pri skrivanju ploskev barva gradnika dolo~a tudi barvo ploskve.
Z ukazom Render|Render pripravimo realisti~en prikaz modela z upo{tevanjem dejanske osvetlitve in
lastnosti povr{in.

AutoCAD 12
Z ukazom Render|Lights model opremimo s svetili. Z gumbom New tega dialoga podamo novo
svetilo: tip (lahko je to~kasto ali oddaljeno, `arki slednjega so vzporedni); obvezno podamo ime (okence
Light Name ), lahko pa tudi mo~ (okence ali drsnik Intensity ; primerno osvetlitev pomaga dolo~iti
poskus), polo`aj (pri to~kastih svetilih) oz. smer `arkov (pri oddaljenih svetilih); (oboje z gumbom
Modify pri Position ) in barvno sestavo (gumb Modify Light Color ). Na podoben na~in z
gumbom Modify dialoga Render|Lights popravljamo podatke svetila (tipa svetila ne moremo
spremeniti); z gumbom Delete pa svetilo uni~imo. Z drsnikom ali okencem Ambient Light podamo
mo~ ambientne osvetlitve (med 0 in 1); z izbiro pri Point Light Fall-off pa dolo~imo, po kak{nem
zakonu osvetljenost pada z oddaljenostjo od to~kastega svetila.
Z ukazom Render|Finishes dolo~amo odbojne lastnosti povr{in modela. Z gumbom New dolo~imo
novo vrsto povr{ine, z gumbom Delete jo uni~imo, z Import pa uporabimo eno od naprej definiranih
vrst povr{ine. Z gumbom Entities pri Attach povemo, kateri gradniki imajo tovrstno povr{ino. Pri
popravljanju z Modify izberemo ime obstoje~e povr{ine, s Pick pa poka`emo gradnik modela katerega
povr{ino `elimo popraviti. Pri tvorbi povr{ine povemo njeno ime, barvo (lahko je enaka barvi gradnika ali
pa jo izberemo posebej); pod Settings z drsniki oz. {tevili med 0 in 1 (vse) povemo {e, kolik{en del
ambientne osvetlitve odbija povr{ina (Ambient ), kako svetlobo razpr{i (Diffuse ) oz. zrcalno odbija
(Specular ) ter kako hrapava je pri tovrstnem odboju (Roughness ). Z gumbom Preview Finish lahko
preverimo, kako bi izgledala krogla s podano povr{ino in osvetljena z ambientno svetlobo.

E. Modeliranje teles

Ukazi za modeliranje teles so v meniju xxx.

Slika 1: Aksonometrija, odklon 60°, naklon 30°, prikaz z mre`o robov brez skrivanja.

AutoCAD 13
Slika 2: Perspektiva, odklon -60°, naklon 30°, razdalja 1000, zoom 24, prikaz z Render|Hide .

Slika 3: Prikaz z Render|Render

AutoCAD 14