You are on page 1of 4

1.WHAT IS RIP?

--RIP stands for Routing Information Protocol


--it is an interior routing protocol
--it is an open standard protocol(can run on both cisco and non-cisco routers)
--it is a distance vector routing protocol
--it is also called routing by rumour
--it uses bellman ford algorithm
--it uses periodic update
--it sends update in every 30 sec
--metric is "hop count" as metric
--maximum hop count is 15
--the AD value is 120
--previously RIP used 6 equal cost load balancing but now it is 16

2. HOW MANY VERSIONS OF RIP?


--RIP has 2 versions
i)RIPV1
ii)RIPV2

3. DIFFERENCE BETWEEN RIPV1 AND RIPV2


RIPV1
i)it sends periodic update
ii)RIPV1 is classfull
iii)RIPV1 support broadcast and the address is 255.255.255.255
iv)RIPV1 does not support authentication

RIPV2
i)it sends triggered update
ii)RIPV2 is classless
iii)RIPV2 support multicast and the address is 224.0.0.0
iv)RIPV2 supports authentication

4.CONFIGURE RIPV2 BETWEEN 3 ROUTERS


i)configure all routers
ii)configure RIP
iii)verify the configuration

i)configure all routers


R1

Router>
Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#interface f0/0
R1(config-if)#ip address 10.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface s0/0
R1(config-if)#ip address 1.1.1.1 255.0.0.0
R1(config-if)#no shutdown
R1(config-if)#clock rate 64000
R1(config-if)#exit
R1(config)#exit
R1#show ip intreface brief
R2

Router>
Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#interface f0/0
R2(config-if)#ip address 11.1.1.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface s0/0
R2(config-if)#ip address 1.1.1.2 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface s0/1
R2(config-if)#ip address 2.2.2.1 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#clock rate 64000
R2(config-if)#exit
R2(config)#exit
R2#show ip intreface brief

R3

outer>
Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#interface f0/0
R3(config-if)#ip address 12.1.1.1 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface s0/0
R3(config-if)#ip address 2.2.2.2 255.0.0.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#exit
R3#show ip intreface brief

ii)configure RIP
R1
R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#exit
R1(config)#exit
R1#

R2
R2(config)#router rip
R2(config-router)#network 1.0.0.0
R2(config-router)#network 11.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#exit
R2(config)#exit
R2#
R3
R3(config)#router rip
R3(config-router)#network 12.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#exit
R3(config)#exit
R3#

5.RIP VERIFICATION COMMANDS


r1#show ip route
--this command shows the routing table

r1#show ip protocols
--show which routing protocol is running
--this command shows the timers and all routing details

r1#debug ip rip
--this command shows the routing updates send and received on the router

r1#ping <ip address>


this command is used to know about RTT(ROUND TRIP TIME)

r1#traceroute <ip address>


--this command is used to identify variour routes through which data packets travel
before reaching the destination

6. WHAT IS RTT(ROUND TRIP TIME)


--the time taken by the router to send the data packets to the destination and
receives a reply is called as RTT

7.RIP TIMERS
--RIP uses four timers
i)update timer=30sec
ii)invalid timer=180sec
iii)hold down timer=180sec
iv)flush timer=240sec

8. CONFIGURE RIP TIMERS


i)configure routers
ii)configure rip
iii)verify rip configuration and rip default timers
iv)configure timers
v)verify rip updated timers

iii)verify rip configuration and rip default timers


r3#sh ip protocols
output:-
--we can see the default value of every timers
Routing Protocol is "rip"
a)Sending updates every 30 seconds
b)Invalid after 180 seconds,
c)hold down 180,
d)flushed after 240

iv)configure timers
--we want to configure the timers
router(config)#router rip
router(config-router)#version 2
router(config-router)#timers basic 10 110 100 130
router(config-router)#timers basic <update timer> <invalid timer> <hold down timer>
<flush timer>
router#show ip protocols

output---
update timer=10 sec
invalid timer=110 sec
holddown timer=100sec
flush timer=130sec

9. PASSIVE INTERFACE IN RIP


--passive interface command is used in all routing protocols
--it is used to stop sending updates out from any specific interface
--in RIP this command will disable sending multicast updates via a specific
interface but will allow to receive incoming updates from other neoghbouring router
running rip

10.CONFGURE PASSIVE INTERFACE ON RIP

router(config)#router rip
router(config-router)#version 2
router(config-router)#passive-interface f0/0
router#show ip protocols
output
i)passive interface is configured on f0/0

router#debug ip rip
output:-
--we can see on interface f0/0 updates are receiving but updates are not sending

11.WHT DVRP IS CALLED AS ROUTING BY ROMOUR?


--the routers which are using DVRP,they update their routing table with every
received routing information without verifying whether the received routing
information is valid or not
--router believs every routing information received from neighbouring routers
without any verification
--this is the reason why DVRP is called as routing by rumours

RIP PRACTICAL IST


1. RIP CONFIGURATION AND VERIFICATION
2. CONFIGURE RIP TIMERS
3.CONFIGURE RIP PASSIVE INTERFACE
4.CONFIGURE RIP AUTHENTICATION
5. CONFIGURE RIP LOAD BALANCING
6.CONFIGURE RIP ROUTE SUMMARIZATION

You might also like